source: projects/specs/trunk/p/python-setuptools/python-setuptools-vl.spec @ 9818

Revision 9818, 4.5 KB checked in by tomop, 9 years ago (diff)

python-setuptools-18.5-1

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-setuptools
4Version:        18.5
5Release:        1%{?_dist_release}
6Summary:        Download, build, install, upgrade, and uninstall Python packages
7Summary(ja):     Python パッケージのダウンロード、ビルド、インストール、アップグレードおよびアンインストール用ツール
8Group:          Development/Tools
9License:        PSFL/ZPL
10URL:            https://pypi.python.org/pypi/setuptools
11Source0:        https://pypi.python.org/packages/source/s/setuptools/setuptools-%{version}.tar.gz
12Source1:        psfl.txt
13Source2:        zpl.txt
14Patch0:         add-setter-for-test_args.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17Requires(post): alternatives
18BuildArch:      noarch
19BuildRequires:  python-devel
20
21%description
22setuptools is a collection of enhancements to the Python distutils that allow
23you to more easily build and distribute Python packages, especially ones that
24have dependencies on other packages.
25
26%description -l ja
27setuptools は Python distutils の拡張機能を集めたツールです。
28このツールにより Python パッケージの構築や配布が簡単に行えるように
29なります。特に他のパッケージに依存しているパッケージを扱う際に便利
30です。
31
32
33%prep
34%setup -q -n setuptools-%{version}
35%patch0 -p1
36#find -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python}|'
37
38
39%build
40CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
41
42
43%install
44rm -rf $RPM_BUILD_ROOT
45%{__python} setup.py install -O1 --skip-build \
46    --root $RPM_BUILD_ROOT \
47    --single-version-externally-managed
48install -p -m 0644 %{SOURCE1} %{SOURCE2} .
49find $RPM_BUILD_ROOT%{python_sitelib} -name '*.exe' | xargs rm -f
50
51# for alternatives
52%__rm -f $RPM_BUILD_ROOT%{_bindir}/easy_install
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%post
58update-alternatives --install %{_bindir}/easy_install easy_install \
59                              %{_bindir}/easy_install-%{python_version} 30
60
61%triggerpostun -- python-setuptools < 5.4.2-2
62update-alternatives --auto easy_install
63
64%preun
65if [ "$1" = "0" ]
66then
67  update-alternatives --remove easy_install %{_bindir}/easy_install-%{python_version}
68fi
69
70%files
71%defattr(-,root,root,-)
72%doc *.txt
73%{_bindir}/easy_install-%{python_version}
74%{python_sitelib}/*
75
76
77%changelog
78* Sun Nov 15 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 18.5-1
79- new upstream release.
80- imported patch0 from rawhide.
81
82* Mon Mar  9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> - 5.4.2-2
83- alternatives for easy_install
84
85* Fri Aug 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4.2-1
86- new upstream release
87
88* Sat Jul 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4.1-1
89- new upstream release
90
91* Sun Jul 06 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4-1
92- new upstream release
93
94* Sat Apr 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.4.4-1
95- new upstream release
96
97* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6c11-2
98- rebuild with python-2.7.2
99
100* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c11-1
101- new upstream release
102
103* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c9-2
104- rebuild with python-2.6
105
106* Sun Dec 07 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6c9-1
107- new upstream release
108- add japanese summary and description
109
110* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> - 0.6c3-1vl5
111- rebuilt with python-2.5.2
112- applied new versioning policy
113
114* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6c3-1vl2
115- rebuilt for Vine Linux 4.0
116- changed Group to Development/Tools
117
118* Wed Nov 15 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
119- Refurbished for VineLinux3.2
120
121* Tue Sep 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c2-1
122- Upstream 0.6c2
123- Ghostbusting
124
125* Mon Jul 31 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-2
126- Set perms on license files (#200768)
127
128* Sat Jul 22 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-1
129- Version 0.6c1
130
131* Wed Jun 28 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6b3-1
132- Taking over from Ignacio
133- Version 0.6b3
134- Ghost .pyo files in sitelib
135- Add license files
136- Remove manual python-abi, since we're building FC4 and up
137- Kill .exe files
138
139* Wed Feb 15 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a10-1
140- Upstream update
141
142* Mon Jan 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a9-1
143- Upstream update
144
145* Sat Dec 24 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a8-1
146- Initial RPM release
Note: See TracBrowser for help on using the repository browser.