source: projects/specs/trunk/p/python-setuptools/python-setuptools-vl.spec @ 9418

Revision 9418, 4.3 KB checked in by iwaim, 9 years ago (diff)

python-setuptools 5.4.2-2

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-setuptools
4Version:        5.4.2
5Release:        2%{?_dist_release}
6Summary:        Download, build, install, upgrade, and uninstall Python packages
7Summary(ja):     Python パッケージのダウンロード、ビルド、インストール、アップグレードおよびアンインストール用ツール
8Group:          Development/Tools
9License:        PSFL/ZPL
10URL:            https://pypi.python.org/pypi/setuptools
11Source0:        https://pypi.python.org/packages/source/s/setuptools/setuptools-%{version}.tar.gz
12Source1:        psfl.txt
13Source2:        zpl.txt
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16Requires(post): alternatives
17BuildArch:      noarch
18BuildRequires:  python-devel
19
20%description
21setuptools is a collection of enhancements to the Python distutils that allow
22you to more easily build and distribute Python packages, especially ones that
23have dependencies on other packages.
24
25%description -l ja
26setuptools は Python distutils の拡張機能を集めたツールです。
27このツールにより Python パッケージの構築や配布が簡単に行えるように
28なります。特に他のパッケージに依存しているパッケージを扱う際に便利
29です。
30
31
32%prep
33%setup -q -n setuptools-%{version}
34#find -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python}|'
35
36
37%build
38CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
39
40
41%install
42rm -rf $RPM_BUILD_ROOT
43%{__python} setup.py install -O1 --skip-build \
44    --root $RPM_BUILD_ROOT \
45    --single-version-externally-managed
46install -p -m 0644 %{SOURCE1} %{SOURCE2} .
47find $RPM_BUILD_ROOT%{python_sitelib} -name '*.exe' | xargs rm -f
48
49# for alternatives
50%__rm -f $RPM_BUILD_ROOT%{_bindir}/easy_install
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%post
56update-alternatives --install %{_bindir}/easy_install easy_install \
57                              %{_bindir}/easy_install-%{python_version} 30
58
59%triggerpostun -- python-setuptools < 5.4.2-2
60update-alternatives --auto easy_install
61
62%preun
63if [ "$1" = "0" ]
64then
65  update-alternatives --remove easy_install %{_bindir}/easy_install-%{python_version}
66fi
67
68%files
69%defattr(-,root,root,-)
70%doc *.txt
71%{_bindir}/easy_install-%{python_version}
72%{python_sitelib}/*
73
74
75%changelog
76* Mon Mar  9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> - 5.4.2-2
77- alternatives for easy_install
78
79* Fri Aug 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4.2-1
80- new upstream release
81
82* Sat Jul 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4.1-1
83- new upstream release
84
85* Sun Jul 06 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4-1
86- new upstream release
87
88* Sat Apr 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.4.4-1
89- new upstream release
90
91* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6c11-2
92- rebuild with python-2.7.2
93
94* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c11-1
95- new upstream release
96
97* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c9-2
98- rebuild with python-2.6
99
100* Sun Dec 07 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6c9-1
101- new upstream release
102- add japanese summary and description
103
104* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> - 0.6c3-1vl5
105- rebuilt with python-2.5.2
106- applied new versioning policy
107
108* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6c3-1vl2
109- rebuilt for Vine Linux 4.0
110- changed Group to Development/Tools
111
112* Wed Nov 15 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
113- Refurbished for VineLinux3.2
114
115* Tue Sep 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c2-1
116- Upstream 0.6c2
117- Ghostbusting
118
119* Mon Jul 31 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-2
120- Set perms on license files (#200768)
121
122* Sat Jul 22 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-1
123- Version 0.6c1
124
125* Wed Jun 28 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6b3-1
126- Taking over from Ignacio
127- Version 0.6b3
128- Ghost .pyo files in sitelib
129- Add license files
130- Remove manual python-abi, since we're building FC4 and up
131- Kill .exe files
132
133* Wed Feb 15 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a10-1
134- Upstream update
135
136* Mon Jan 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a9-1
137- Upstream update
138
139* Sat Dec 24 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a8-1
140- Initial RPM release
Note: See TracBrowser for help on using the repository browser.