source: projects/specs/trunk/p/python-requests/python-requests-vl.spec @ 12469

Revision 12469, 3.0 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Summary: Python HTTP for Humans
2Name: python-requests
3Version: 2.24.0
4Release: 1%{?_dist_release}
5Group: programming
6Vendor: Project Vine
7Distribution: Vine Linux
8Packager: iwaim
9
10License: ASLv2
11URL: https://pypi.python.org/pypi/requests
12Source0: https://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
13
14# Explicitly use the system certificates in ca-certificates.
15# https://bugzilla.redhat.com/show_bug.cgi?id=904614
16Patch0: patch-requests-certs.py-to-use-the-system-CA-bundle.patch
17
18# https://bugzilla.redhat.com/show_bug.cgi?id=1450608
19Patch2: Remove-tests-that-use-the-tarpit.patch
20
21# Use 127.0.0.1 not localhost for socket.bind() in the Server test
22# class, to fix tests in Koji's no-network environment
23# This probably isn't really upstreamable, because I guess localhost
24# could technically be IPv6 or something, and our no-network env is
25# a pretty odd one so this is a niche requirement.
26Patch3: requests-2.12.4-tests_nonet.patch
27
28BuildArch: noarch
29BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30Requires: python
31Requires: python-urllib3
32Requires: python-chardet
33Requires: python-idna
34BuildRequires: python-rpm-macros
35BuildRequires: python3-rpm-macros
36BuildRequires: python-devel
37BuildRequires: python-setuptools
38BuildRequires: python3-devel
39BuildRequires: python3-rpm-macros
40BuildRequires: python3-setuptools
41
42%description
43Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
44
45
46%package -n python3-requests
47Summary: Python HTTP for Humans
48Group: programming
49Requires: python3
50Requires: python3-urllib3
51Requires: python3-chardet
52Requires: python3-idna
53
54%description -n python3-requests
55Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
56
57
58%prep
59%autosetup -p1 -n requests-%{version}
60
61# Unbundle the certificate bundle from mozilla.
62rm -rf requests/cacert.pem
63
64# env shebang in nonexecutable file
65sed -i '/#!\/usr\/.*python/d' requests/certs.py
66
67
68%build
69%py2_build
70%py3_build
71
72
73%install
74rm -rf $RPM_BUILD_ROOT
75%py2_install
76%py3_install
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%files
84%defattr(-,root,root,-)
85%license LICENSE
86%doc README* HISTORY*
87%{python_sitelib}/requests
88%{python_sitelib}/requests-%{version}-py*.egg-info
89
90%files -n python3-requests
91%defattr(-,root,root,-)
92%license LICENSE
93%doc README* HISTORY*
94%{python3_sitelib}/requests
95%{python3_sitelib}/requests-%{version}-py*.egg-info
96
97%changelog
98* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.24.0-1
99- new upstream release.
100
101* Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.23.0-1
102- new upstream release.
103- updated patches.
104
105* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-2
106- fixed R:.
107- imported Patch0-4 from rawhide.
108
109* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-1
110- new upstream release.
111- add python2 support.
112
113* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.1-2
114- rebuild with python3-3.5.2
115
116* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 2.5.1-1
117- Initial build.
Note: See TracBrowser for help on using the repository browser.