source: projects/specs/trunk/p/python-requests/python-requests-vl.spec @ 12367

Revision 12367, 2.9 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

krb5-1.18-1

python-pip-20.0.2-1

python-requests-2.23.0-1

python-rpm-macros-3.8-1

python-setuptools-44.1.0-1

Line 
1Summary: Python HTTP for Humans
2Name: python-requests
3Version: 2.23.0
4Release: 1%{?_dist_release}
5License: ASLv2
6Group: Development/Languages
7URL: https://pypi.python.org/pypi/requests
8
9Source0: https://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
10
11# Explicitly use the system certificates in ca-certificates.
12# https://bugzilla.redhat.com/show_bug.cgi?id=904614
13Patch0: patch-requests-certs.py-to-use-the-system-CA-bundle.patch
14
15# https://bugzilla.redhat.com/show_bug.cgi?id=1450608
16Patch2: Remove-tests-that-use-the-tarpit.patch
17
18# Use 127.0.0.1 not localhost for socket.bind() in the Server test
19# class, to fix tests in Koji's no-network environment
20# This probably isn't really upstreamable, because I guess localhost
21# could technically be IPv6 or something, and our no-network env is
22# a pretty odd one so this is a niche requirement.
23Patch3: requests-2.12.4-tests_nonet.patch
24
25# https://bugzilla.redhat.com/show_bug.cgi?id=1567862
26Patch4: Don-t-inject-pyopenssl-into-urllib3.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29Requires: python
30Requires: python-urllib3
31Requires: python-chardet
32Requires: python-idna
33BuildRequires: python-devel
34BuildRequires: python-rpm-macros
35BuildRequires: python-setuptools
36BuildRequires: python3-devel
37BuildRequires: python3-rpm-macros
38BuildRequires: python3-setuptools
39BuildArch: noarch
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: iwaim
44
45%description
46Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
47
48%package -n python3-requests
49Summary: Python HTTP for Humans
50Group: Development/Languages
51Requires: python3
52Requires: python3-urllib3
53Requires: python3-chardet
54Requires: python3-idna
55
56%description -n python3-requests
57Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
58
59%prep
60%autosetup -p1 -n requests-%{version}
61
62# Unbundle the certificate bundle from mozilla.
63rm -rf requests/cacert.pem
64
65# env shebang in nonexecutable file
66sed -i '/#!\/usr\/.*python/d' requests/certs.py
67
68%build
69%py_build
70%py3_build
71
72%install
73rm -rf $RPM_BUILD_ROOT
74%py_install
75%py3_install
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80
81%files
82%defattr(-,root,root,-)
83%license LICENSE
84%doc README* HISTORY*
85%{python_sitelib}/requests
86%{python_sitelib}/requests-%{version}-py*.egg-info
87
88%files -n python3-requests
89%defattr(-,root,root,-)
90%license LICENSE
91%doc README* HISTORY*
92%{python3_sitelib}/requests
93%{python3_sitelib}/requests-%{version}-py*.egg-info
94
95%changelog
96* Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.23.0-1
97- new upstream release.
98- updated patches.
99
100* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-2
101- fixed R:.
102- imported Patch0-4 from rawhide.
103
104* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-1
105- new upstream release.
106- add python2 support.
107
108* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.1-2
109- rebuild with python3-3.5.2
110
111* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 2.5.1-1
112- Initial build.
Note: See TracBrowser for help on using the repository browser.