source: projects/specs/trunk/p/python-requests/python-requests-vl.spec @ 12545

Revision 12545, 2.9 KB checked in by tomop, 3 years ago (diff)

rpm-4.16.1.2-1 and requirements

Line 
1Summary: Python HTTP for Humans
2Name: python-requests
3Version: 2.25.1
4Release: 1%{?_dist_release}
5Group: programming
6Vendor: Project Vine
7Distribution: Vine Linux
8Packager: iwaim
9
10License: ASLv2
11URL: https://pypi.python.org/pypi/requests
12Source0: https://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
13
14# Explicitly use the system certificates in ca-certificates.
15# https://bugzilla.redhat.com/show_bug.cgi?id=904614
16Patch0: patch-requests-certs.py-to-use-the-system-CA-bundle.patch
17
18# https://bugzilla.redhat.com/show_bug.cgi?id=1450608
19Patch2: Remove-tests-that-use-the-tarpit.patch
20
21# Use 127.0.0.1 not localhost for socket.bind() in the Server test
22# class, to fix tests in Koji's no-network environment
23# This probably isn't really upstreamable, because I guess localhost
24# could technically be IPv6 or something, and our no-network env is
25# a pretty odd one so this is a niche requirement.
26Patch3: requests-2.12.4-tests_nonet.patch
27
28BuildArch: noarch
29BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30Requires: python
31BuildRequires: python-rpm-macros
32BuildRequires: python3-rpm-macros
33BuildRequires: python-devel
34BuildRequires: python2-setuptools
35BuildRequires: python3-devel
36BuildRequires: python3-rpm-macros
37BuildRequires: python3-setuptools
38
39%description
40Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
41
42
43%package -n python3-requests
44Summary: Python HTTP for Humans
45Group: programming
46Requires: python3
47
48%description -n python3-requests
49Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
50
51
52%prep
53%autosetup -p1 -n requests-%{version}
54
55# Unbundle the certificate bundle from mozilla.
56rm -rf requests/cacert.pem
57
58# env shebang in nonexecutable file
59sed -i '/#!\/usr\/.*python/d' requests/certs.py
60
61
62%build
63%py_build
64%py3_build
65
66
67%install
68rm -rf $RPM_BUILD_ROOT
69%py_install
70%py3_install
71
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76
77%files
78%defattr(-,root,root,-)
79%license LICENSE
80%doc README* HISTORY*
81%{python_sitelib}/requests
82%{python_sitelib}/requests-%{version}-py*.egg-info
83
84%files -n python3-requests
85%defattr(-,root,root,-)
86%license LICENSE
87%doc README* HISTORY*
88%{python3_sitelib}/requests
89%{python3_sitelib}/requests-%{version}-py*.egg-info
90
91
92%changelog
93* Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.25.1-1
94- new upstream release.
95- updated Patch0.
96
97* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.24.0-1
98- new upstream release.
99
100* Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.23.0-1
101- new upstream release.
102- updated patches.
103
104* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-2
105- fixed R:.
106- imported Patch0-4 from rawhide.
107
108* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-1
109- new upstream release.
110- add python2 support.
111
112* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.1-2
113- rebuild with python3-3.5.2
114
115* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 2.5.1-1
116- Initial build.
Note: See TracBrowser for help on using the repository browser.