source: projects/specs/trunk/p/python-qt5/python-qt5-vl.spec @ 12348

Revision 12348, 23.5 KB checked in by tomop, 4 years ago (diff)

updated 25 packages

python-qt5-5.12.3-2

qt5-qt3d-5.12.7-1

qt5-qtbase-5.12.7-1

qt5-qtcanvas3d-5.12.7-1

qt5-qtconnectivity-5.12.7-1

qt5-qtdeclarative-5.12.7-1

qt5-qtdoc-5.12.7-1

qt5-qtgraphicaleffects-5.12.7-1

qt5-qtimageformats-5.12.7-1

qt5-qtlocation-5.12.7-1

qt5-qtmultimedia-5.12.7-1

qt5-qtquickcontrols-5.12.7-1

qt5-qtquickcontrols2-5.12.7-1

qt5-qtscript-5.12.7-1

qt5-qtsensors-5.12.7-1

qt5-qtserialport-5.12.7-1

qt5-qtsvg-5.12.7-1

qt5-qttools-5.12.7-1

qt5-qttranslations-5.12.7-1

qt5-qtwebchannel-5.12.7-1

qt5-qtwebengine-5.12.7-1

qt5-qtwebsockets-5.12.7-1

qt5-qtx11extras-5.12.7-1

qt5-qtxmlpatterns-5.12.7-1

qt5-5.12.7-1

Line 
1# prevent anything matching from being scanned for provides
2%define filter_provides_in(P) %{expand: \
3%global __filter_prov_cmd %{?__filter_prov_cmd} %{__grep} -v %{-P} '%*' | \
4}
5
6# prevent anything matching from being scanned for requires
7%define filter_requires_in(P) %{expand: \
8%global __filter_req_cmd %{?__filter_req_cmd} %{__grep} -v %{-P} '%*' | \
9}
10
11# filter anything matching out of the provides stream
12%define filter_from_provides() %{expand: \
13%global __filter_from_prov %{?__filter_from_prov} | %{__sed} -e '%*' \
14}
15
16# filter anything matching out of the requires stream
17%define filter_from_requires() %{expand: \
18%global __filter_from_req %{?__filter_from_req} | %{__sed} -e '%*' \
19}
20
21# actually set up the filtering bits
22%define filter_setup %{expand: \
23%global _use_internal_dependency_generator 0 \
24%global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u \
25%global __find_provides /bin/sh -c "%{?__filter_prov_cmd} %{__deploop P} %{?__filter_from_prov}" \
26%global __find_requires /bin/sh -c "%{?__filter_req_cmd}  %{__deploop R} %{?__filter_from_req}" \
27}
28
29%global with_python3 1
30%global python3_dbus_dir %(%{__python3} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
31%global with_python2 1
32%global python_dbus_dir %(%{__python} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
33
34# enable/disable individual modules
35# drop power64, it's not supported yet (than)
36%ifarch %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
37%global webengine 0
38%endif
39%global webkit 0
40
41#global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
42%global rpm_macros_dir %{_sysconfdir}/rpm
43
44%global py3_sipdir %{_datadir}/sip/PyQt5
45
46Summary: PyQt5 is Python bindings for Qt5
47Name:    python-qt5
48Version: 5.12.3
49Release: 2%{?_dist_release}
50
51Vendor:         Project Vine
52Distribution:   Vine Linux
53
54# all BSD, except for GPLv2+ dbus bindings and examples
55License: BSD and GPLv2+
56Url:     https://www.riverbankcomputing.com/software/pyqt/
57Source0: https://www.riverbankcomputing.com/static/Downloads/PyQt5/%{version}/PyQt5_gpl-%{version}.tar.gz
58Source1: macros.pyqt5
59# wrapper, see https://bugzilla.redhat.com/show_bug.cgi?id=1193107#c9
60Source2: pylupdate5.sh
61Source3: pyrcc5.sh
62Source4: pyuic5.sh
63
64## upstream patches
65
66## upstreamable patches
67Patch0: python-qt5_sipdir.patch
68
69Patch1000: python-qt5-sip-option.patch
70Patch1001: pyqt5-5.12.3-python2.patch
71
72BuildRequires: chrpath
73BuildRequires: findutils
74BuildRequires: qt5-rpm-macros
75BuildRequires: pkgconfig(dbus-1)
76BuildRequires: pkgconfig(dbus-python)
77BuildRequires: pkgconfig(phonon4qt5)
78BuildRequires: pkgconfig(Qt5Core)
79#BuildRequires: pkgconfig(Enginio)
80BuildRequires: pkgconfig(Qt5Bluetooth)
81BuildRequires: pkgconfig(Qt5DBus)
82#BuildRequires: pkgconfig(Qt5Declarative)
83BuildRequires: qt5-qtdeclarative-devel
84BuildRequires: pkgconfig(Qt5Designer)
85BuildRequires: pkgconfig(Qt5Gui) pkgconfig(Qt5Multimedia)
86BuildRequires: pkgconfig(Qt5Location)
87BuildRequires: pkgconfig(Qt5Nfc)
88BuildRequires: pkgconfig(Qt5Network) pkgconfig(Qt5OpenGL)
89BuildRequires: pkgconfig(Qt5Positioning)
90BuildRequires: pkgconfig(Qt5Quick) pkgconfig(Qt5QuickWidgets)
91#BuildRequires: pkgconfig(Qt5Script)
92BuildRequires: pkgconfig(Qt5Sensors)
93BuildRequires: pkgconfig(Qt5SerialPort)
94BuildRequires: pkgconfig(Qt5Sql) pkgconfig(Qt5Svg) pkgconfig(Qt5Test)
95BuildRequires: pkgconfig(Qt5X11Extras)
96BuildRequires: pkgconfig(Qt5Xml) pkgconfig(Qt5XmlPatterns)
97BuildRequires: pkgconfig(Qt5WebChannel)
98BuildRequires: pkgconfig(Qt5WebSockets)
99BuildRequires: sip-devel >= 4.18
100%if 0%{?with_python2}
101BuildRequires: python-devel python
102BuildRequires: python-rpm-macros
103BuildRequires: python-enum34
104%endif # with_python2
105%if 0%{?with_python3}
106BuildRequires: python3-devel python3
107BuildRequires: python3-rpm-macros
108BuildRequires: python3-sip-devel >= 4.18
109BuildRequires: dbus-python3
110%endif # with_python3
111
112# when split out
113%if 0%{?webengine} || 0%{?webkit}
114Obsoletes: python-qt5 < 5.5.1-10
115%endif
116
117Requires: %{name}-rpm-macros = %{version}-%{release}
118Requires: python-qt5-base = %{version}-%{release}
119Requires: dbus-python
120BuildRequires: qt5-qtbase-private-devel
121%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
122%{?_sip_api:Requires: sip-api(%{_sip_api_major}) >= %{_sip_api}}
123
124%filter_provides_in %{python_sitearch} %{?_qt5_plugindir}
125%if 0%{?with_python3}
126%filter_provides_in %{python3_sitearch} %{?_qt5_plugindir}
127%endif
128%filter_setup
129
130Provides: PyQt5 = %{version}-%{release}
131Provides: PyQt5%{?_isa} = %{version}-%{release}
132Provides: python-PyQt5 = %{version}-%{release}
133Provides: python-PyQt5%{?_isa} = %{version}-%{release}
134Provides: python2-PyQt5 = %{version}-%{release}
135Provides: python2-PyQt5%{?_isa} = %{version}-%{release}
136Provides: python2-qt5 = %{version}-%{release}
137Provides: python2-qt5%{?_isa} = %{version}-%{release}
138
139%description
140PyQt5 is Python bindings for Qt5.
141
142%if 0%{?with_python2}
143%package base
144Summary: Python bindings for Qt5 base
145Requires: %{name}-rpm-macros = %{version}-%{release}
146%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
147%{?_sip_api:Requires: python-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
148Requires: dbus-python
149Obsoletes: python-qt5 < 5.5.1-10
150Provides: python-PyQt5-base = %{version}-%{release}
151Provides: python-PyQt5-base%{?_isa} = %{version}-%{release}
152%{?python_provide:%python_provide python-qt5-base}
153%description base
154%{summary}.
155
156%package devel
157Summary: Development files for %{name}
158Requires: %{name}%{?_isa} = %{version}-%{release}
159Requires: qt5-qtbase-devel
160Requires: sip-devel
161Provides: PyQt5-devel = %{version}-%{release}
162Provides: python-PyQt5-devel = %{version}-%{release}
163%description devel
164Files needed to build other bindings for C++ classes that inherit from any
165of the Qt5 classes (e.g. KDE or your own).
166%endif
167
168%package rpm-macros
169Summary: RPM macros %{name}
170# when split out
171Conflicts: python-qt5 < 5.6
172Conflicts: python3-qt5 < 5.6
173BuildArch: noarch
174%description rpm-macros
175%{summary}.
176
177%package -n python3-qt5
178Summary: Python 3 bindings for Qt5
179%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
180%{?_sip_api:Requires: python3-sip-api(%{_sip_api_major}) >= %{_sip_api}}
181# when split out
182%if 0%{?webengine} || 0%{?webkit}
183Obsoletes: python3-qt5 < 5.5.1-10
184%endif
185Provides: python3-PyQt5 = %{version}-%{release}
186Provides: python3-PyQt5%{?_isa} = %{version}-%{release}
187Requires: %{name}-rpm-macros = %{version}-%{release}
188Requires: python3-qt5-base = %{version}-%{release}
189Requires: dbus-python3
190%description -n python3-qt5
191%{summary}.
192
193%package -n python3-qt5-base
194Summary: Python 3 bindings for Qt5 base
195%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
196%{?_sip_api:Requires: python3-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
197Provides: python3-PyQt5-base = %{version}-%{release}
198Provides: python3-PyQt5-base%{?_isa} = %{version}-%{release}
199Requires: %{name}-rpm-macros = %{version}-%{release}
200Requires: dbus-python3
201%{?python_provide:%python_provide python3-qt5-base}
202%description -n python3-qt5-base
203%{summary}.
204
205%package -n python3-qt5-devel
206Summary: Python 3 bindings for Qt5
207Requires: python3-qt5%{?_isa} = %{version}-%{release}
208Requires: qt5-qtbase-devel
209Requires: python3-sip-devel
210Provides: python3-PyQt5-devel = %{version}-%{release}
211%description -n python3-qt5-devel
212Files needed to build other bindings for C++ classes that inherit from any
213of the Qt5 classes
214
215%package doc
216Summary: Developer documentation for %{name}
217Provides: PyQt5-doc = %{version}-%{release}
218BuildArch: noarch
219%description doc
220%{summary}.
221
222%if 0%{?webengine}
223%package webengine
224Summary: Python bindings for Qt5 WebEngine
225BuildRequires: pkgconfig(Qt5WebEngine)
226BuildRequires: qt5-qtwebengine-devel
227Obsoletes: python-qt5 < 5.5.1-10
228Requires:  %{name}%{?_isa} = %{version}-%{release}
229%description webengine
230
231%package -n python3-qt5-webengine
232Summary: Python bindings for Qt5 WebEngine
233Obsoletes: python3-webengine < 5.5.1-13
234Obsoletes: python3-qt5 < 5.5.1-10
235Requires:  python3-qt5%{?_isa} = %{version}-%{release}
236%description -n python3-qt5-webengine
237%endif
238
239%if 0%{?webkit}
240%package webkit
241Summary: Python bindings for Qt5 Webkit
242BuildRequires: pkgconfig(Qt5WebKit) pkgconfig(Qt5WebKitWidgets)
243Obsoletes: python3-webkit < 5.5.1-12
244Obsoletes: python-qt5 < 5.5.1-10
245Requires:  %{name}%{?_isa} = %{version}-%{release}
246%description webkit
247
248%package -n python3-qt5-webkit
249Summary: Python bindings for Qt5 Webkit
250Obsoletes: python3-qt5 < 5.5.1-10
251Requires:  python3-qt5%{?_isa} = %{version}-%{release}
252%description -n python3-qt5-webkit
253%endif
254
255
256%prep
257%setup -q -n PyQt5_gpl-%{version}%{?snap:-snapshot-%{snap}}
258
259%patch0 -p1
260%patch1000 -p1
261%patch1001 -p1
262
263
264%build
265PATH=%{_qt5_bindir}:$PATH ; export PATH
266
267# Python 2 build:
268%if 0%{?with_python2}
269mkdir %{_target_platform}
270pushd %{_target_platform}
271%{__python} ../configure.py \
272  --assume-shared \
273  --confirm-license \
274  --no-designer-plugin \
275  --no-qml-plugin \
276  --qmake=%{_qt5_qmake} \
277  %{!?with_python3:--no-qsci-api}%{?with_python3:--qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci} \
278  --verbose \
279  --dbus=/usr/include/dbus-1.0/ \
280  QMAKE_CFLAGS_RELEASE="%{optflags}" \
281  QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
282  QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
283
284make %{?_smp_mflags}
285popd
286%endif # with_python2
287
288# Python 3 build:
289%if 0%{?with_python3}
290mkdir %{_target_platform}-python3
291pushd %{_target_platform}-python3
292%{__python3} ../configure.py \
293  --assume-shared \
294  --confirm-license \
295  --qmake=%{_qt5_qmake} \
296  %{?with_python2:--no-qsci-api}%{!?with_python2:--qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci} \
297  %{?py3_sip:--sip=%{_bindir}/python3-sip} \
298  %{?py3_sipdir:--sipdir=%{py3_sipdir}} \
299  --verbose \
300  %{?python3_sip_incdir} \
301  --dbus=/usr/include/dbus-1.0/ \
302  QMAKE_CFLAGS_RELEASE="%{optflags}" \
303  QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
304  QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
305
306make %{?_smp_mflags}
307popd
308%endif # with_python3
309
310
311%install
312
313# Python 3 build:
314%if 0%{?with_python3}
315%make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}-python3
316if [ "%{_prefix}" != "/usr" ]; then
317  cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
318  rm -rf %{buildroot}/usr/*
319fi
320%if "%py3_sipdir" == "%{_datadir}/sip/PyQt5"
321# copy files to old location for compat purposes temporarily
322mkdir -p %{buildroot}%{_datadir}/python3-sip
323cp -alf %{buildroot}%{py3_sipdir} \
324        %{buildroot}%{_datadir}/python3-sip/PyQt5
325%endif
326
327if [ "%{_prefix}" != "/usr" ]; then
328  cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/ || echo "Nothing to copy"
329  rm -rf %{buildroot}/usr/*
330fi
331
332# ensure .so modules are executable for proper -debuginfo extraction
333find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
334#for i in %%{buildroot}%%{python3_sitearch}/PyQt5/*.so %%{buildroot}%%{python3_dbus_dir}/pyqt5.so ; do
335#test -x $i  || chmod a+rx $i
336#done
337%endif # with_python3
338
339# Python 2 build:
340%if 0%{?with_python2}
341%make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
342if [ "%{_prefix}" != "/usr" ]; then
343  cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
344  rm -rf %{buildroot}/usr/*
345fi
346# ensure .so modules are executable for proper -debuginfo extraction
347find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
348#for i in %%{buildroot}%%{python2_sitearch}/PyQt5/*.so %%{buildroot}%%{python2_dbus_dir}/pyqt5.so ; do
349#test -x $i || chmod a+rx $i
350#done
351%endif # with_python2
352
353# remove Python3 code from Python2 directory, fixes FTBFS like PyQt4 (#564633)
354rm -rfv %{buildroot}%{python2_sitearch}/PyQt5/uic/port_v3/
355# remove Python2 code from Python3 directory (for when/if we support python3 here)
356rm -rfv %{buildroot}%{python3_sitearch}/PyQt5/uic/port_v2/
357
358# rpm macros
359install -p -m644 -D %{SOURCE1} \
360  %{buildroot}%{rpm_macros_dir}/macros.pyqt5
361sed -i \
362  -e "s|@@NAME@@|%{name}|g" \
363  -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
364  -e "s|@@VERSION@@|%{version}|g" \
365  -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
366  %{buildroot}%{rpm_macros_dir}/macros.pyqt5
367
368%if 0%{?with_python3}
369# install wrappers to handle both/either python2/python3
370# TODO: consider alternatives? -- rex
371rm -fv %{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
372install -p -m755 -D %{SOURCE2} %{buildroot}%{_bindir}/pylupdate5
373install -p -m755 -D %{SOURCE3} %{buildroot}%{_bindir}/pyrcc5
374install -p -m755 -D %{SOURCE4} %{buildroot}%{_bindir}/pyuic5
375sed -i \
376  -e "s|@PYTHON3@|%{__python3}|g" \
377  -e "s|@PYTHON2@|%{__python2}|g" \
378  %{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
379%endif
380
381%if 0%{?with_python2}
382%files
383#{python_sitearch}/PyQt5/Enginio.so
384%{python_sitearch}/PyQt5/QtBluetooth.so
385%{python_sitearch}/PyQt5/QtDesigner.so
386%{python_sitearch}/PyQt5/QtHelp.so
387%{python_sitearch}/PyQt5/QtLocation.so
388%{python_sitearch}/PyQt5/QtMultimedia.so
389%{python_sitearch}/PyQt5/QtMultimediaWidgets.so
390%{python_sitearch}/PyQt5/QtNfc.so
391%{python_sitearch}/PyQt5/QtPositioning.so
392%{python_sitearch}/PyQt5/QtQml.so
393%{python_sitearch}/PyQt5/QtQuick.so
394%{python_sitearch}/PyQt5/QtQuickWidgets.so
395%{python_sitearch}/PyQt5/QtSensors.so
396%{python_sitearch}/PyQt5/QtSerialPort.so
397%{python_sitearch}/PyQt5/QtSvg.so
398%{python_sitearch}/PyQt5/QtWebChannel.so
399%{python_sitearch}/PyQt5/QtWebSockets.so
400%{python_sitearch}/PyQt5/QtX11Extras.so
401%{python_sitearch}/PyQt5/QtXmlPatterns.so
402
403%files base
404%doc NEWS README
405%license LICENSE
406%{python_dbus_dir}/pyqt5.so
407%dir %{python_sitearch}/PyQt5/
408%{python_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
409%{python_sitearch}/PyQt5/__init__.py*
410%{python_sitearch}/PyQt5/Qt.so
411%{python_sitearch}/PyQt5/QtCore.so
412%{python_sitearch}/PyQt5/QtDBus.so
413%{python_sitearch}/PyQt5/QtGui.so
414%{python_sitearch}/PyQt5/QtNetwork.so
415%{python_sitearch}/PyQt5/QtOpenGL.so
416%{python_sitearch}/PyQt5/QtPrintSupport.so
417%{python_sitearch}/PyQt5/QtSql.so
418%{python_sitearch}/PyQt5/QtTest.so
419%{python_sitearch}/PyQt5/QtWidgets.so
420%{python_sitearch}/PyQt5/QtXml.so
421%{python_sitearch}/PyQt5/_QOpenGLFunctions_2_0.so
422%{python_sitearch}/PyQt5/_QOpenGLFunctions_2_1.so
423%{python_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.so
424# *was* in -devel
425%{_bindir}/pylupdate5
426%{_bindir}/pyrcc5
427%{_bindir}/pyuic5
428%{python_sitearch}/PyQt5/uic/
429%{python_sitearch}/PyQt5/pylupdate.so
430%{python_sitearch}/PyQt5/pylupdate_main.py*
431%{python_sitearch}/PyQt5/pyrcc.so
432%{python_sitearch}/PyQt5/pyrcc_main.py*
433
434%if 0%{?webengine}
435%files webengine
436%{python_sitearch}/PyQt5/QtWebEngine.*
437%{python_sitearch}/PyQt5/QtWebEngineCore.*
438%{python_sitearch}/PyQt5/QtWebEngineWidgets.*
439%endif
440
441%if 0%{?webkit}
442%files webkit
443%{python_sitearch}/PyQt5/QtWebKit.*
444%{python_sitearch}/PyQt5/QtWebKitWidgets.*
445%endif
446
447%files devel
448%{_datadir}/sip/PyQt5/
449%endif
450
451%files rpm-macros
452%{rpm_macros_dir}/macros.pyqt5
453
454%if 0%{?with_python3}
455%files -n python3-qt5
456#{python3_sitearch}/PyQt5/Enginio.*
457%{python3_sitearch}/PyQt5/QtBluetooth.*
458%{python3_sitearch}/PyQt5/QtDesigner.*
459%{python3_sitearch}/PyQt5/QtHelp.*
460%{python3_sitearch}/PyQt5/QtLocation.*
461%{python3_sitearch}/PyQt5/QtMultimedia.*
462%{python3_sitearch}/PyQt5/QtMultimediaWidgets.*
463%{python3_sitearch}/PyQt5/QtNfc.*
464%{python3_sitearch}/PyQt5/QtPositioning.*
465%{python3_sitearch}/PyQt5/QtQml.*
466%{python3_sitearch}/PyQt5/QtQuick.*
467%{python3_sitearch}/PyQt5/QtQuickWidgets.*
468%{python3_sitearch}/PyQt5/QtSensors.*
469%{python3_sitearch}/PyQt5/QtSerialPort.*
470%{python3_sitearch}/PyQt5/QtSvg.*
471%{python3_sitearch}/PyQt5/QtWebChannel.*
472%{python3_sitearch}/PyQt5/QtWebSockets.*
473%{python3_sitearch}/PyQt5/QtX11Extras.*
474%{python3_sitearch}/PyQt5/QtXmlPatterns.*
475
476%files -n python3-qt5-base
477%doc NEWS README
478%license LICENSE
479%{python3_dbus_dir}/pyqt5.so
480%dir %{python3_sitearch}/PyQt5/
481%{python3_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
482#{python3_sitearch}/PyQt5/__pycache__/__init__.*
483%{python3_sitearch}/PyQt5/__init__.py*
484%{python3_sitearch}/PyQt5/Qt.*
485%{python3_sitearch}/PyQt5/QtCore.*
486%{python3_sitearch}/PyQt5/QtDBus.*
487%{python3_sitearch}/PyQt5/QtGui.*
488%{python3_sitearch}/PyQt5/QtNetwork.*
489%{python3_sitearch}/PyQt5/QtOpenGL.*
490%{python3_sitearch}/PyQt5/QtPrintSupport.*
491%{python3_sitearch}/PyQt5/QtSql.*
492%{python3_sitearch}/PyQt5/QtTest.*
493%{python3_sitearch}/PyQt5/QtWidgets.*
494%{python3_sitearch}/PyQt5/QtXml.*
495%{python3_sitearch}/PyQt5/_QOpenGLFunctions_2_0.*
496%{python3_sitearch}/PyQt5/_QOpenGLFunctions_2_1.*
497%{python3_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.*
498# plugins
499%{_qt5_plugindir}/PyQt5/
500%{_qt5_plugindir}/designer/libpyqt5.so
501%{python3_sitearch}/PyQt5/uic/
502# *was* in python3-qt5-devel
503%{_bindir}/pylupdate5
504%{_bindir}/pyrcc5
505%{_bindir}/pyuic5
506%{python3_sitearch}/PyQt5/pylupdate.so
507%{python3_sitearch}/PyQt5/pylupdate_main.py*
508#{python3_sitearch}/PyQt5/__pycache__/pylupdate_main*
509%{python3_sitearch}/PyQt5/pyrcc.so
510%{python3_sitearch}/PyQt5/pyrcc_main.py*
511#{python3_sitearch}/PyQt5/__pycache__/pyrcc_main*
512
513%if 0%{?webengine}
514%files -n python3-qt5-webengine
515%{python3_sitearch}/PyQt5/QtWebEngine.*
516%{python3_sitearch}/PyQt5/QtWebEngineCore.*
517%{python3_sitearch}/PyQt5/QtWebEngineWidgets.*
518%endif
519
520%if 0%{?webkit}
521%files -n python3-qt5-webkit
522%{python3_sitearch}/PyQt5/QtWebKit.*
523%{python3_sitearch}/PyQt5/QtWebKitWidgets.*
524%endif
525
526%files -n python3-qt5-devel
527%{py3_sipdir}/
528# compat location
529%dir %{_datadir}/python3-sip/
530%{_datadir}/python3-sip/PyQt5/
531%endif # with_python3
532
533%files doc
534#doc doc/*
535%doc examples/
536# avoid dep on qscintilla-python, own %%_qt5_datadir/qsci/... here for now
537%dir %{_qt5_datadir}/qsci/
538%dir %{_qt5_datadir}/qsci/api/
539%dir %{_qt5_datadir}/qsci/api/python/
540%doc %{_qt5_datadir}/qsci/api/python/PyQt5.api
541
542
543%changelog
544* Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-2
545- rebuilt with qt5-5.12.7.
546
547* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-1
548- new upstream release.
549
550* Sat Jan 27 2018 Toshiaki Ara <ara_t@384.jp> - 5.6-7
551- rebuild under current VineSeed
552
553* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6-6
554- initial build for Vine Linux.
555
556* Wed Jul 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-5
557- BR: qt5-qtbase-private-devel
558- python3-qt5: add versioned qt5 dep (like base python-qt5 pkg has)
559
560* Wed Jun 29 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-4
561- rebuild (qt5)
562
563* Wed Jun 15 2016 Than Ngo <than@redhat.com> - 5.6-3
564- drop ppc ppc64 ppc64le, it's not supported yet
565
566* Mon May 02 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-2
567- -rpm-macros: Conflicts: python(3)-qt5 < 5.6
568
569* Mon Apr 25 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-1
570- PyQt5-5.6
571
572* Wed Apr 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-20
573- rebuild (sip), re-enable -webengine for secondary archs
574
575* Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-19
576- limit -webengine support to just primary archs (for now)
577
578* Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-18
579- -rpm-macros subpkg
580
581* Tue Mar 15 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-17
582- rebuild (qt5-qtenginio)
583
584* Mon Mar 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-16
585- -webengine: add ExclusiveArch (matching qt5-qtwebengine's)
586
587* Mon Mar 07 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-15
588- add Obsoletes for misnamed -webengine/-webkit pkgs (#1315025)
589
590* Sat Mar 05 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-14
591- python-qt5 is not built with $RPM_OPT_FLAGS (#1314998)
592
593* Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-13
594- fix python3-qt5-webengine name
595
596* Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-12
597- fix python3-qt5-webkit name
598
599* Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-11
600- use safer subdir builds
601
602* Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-10
603- -webengine,-webkit subpkgs
604
605* Sat Feb 27 2016 Christian Dersch <lupinix@mailbox.org> - 5.5.1-9
606- Enabled QtWebEngine for Fedora >= 24
607
608* Sat Feb 27 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-8
609- rebuild
610
611* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-7
612- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
613
614* Mon Feb 01 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-6
615- explicitly set CFLAGS,CXXFLAGS,LFLAGS
616
617* Wed Jan 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-5
618- %%description: mention PyQt5
619
620* Mon Dec 07 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-4
621- rebuild (qt5), Provides: python2-qt5
622
623* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.5.1-3
624- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
625
626* Mon Nov 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-2
627- rebuild (qt5)
628
629* Mon Oct 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-1
630- 5.5.1
631- enable qtenginio, fix pyuic5 wrapper, use %%license
632
633* Mon Oct 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-2
634- rebuild (qt5)
635
636* Thu Jul 30 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-1
637- 5.5
638
639* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.2-2
640- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
641
642* Fri Jun 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-1
643- 5.4.2
644
645* Fri Jun 05 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-5
646- wrong python release used in pyuic5 launch script (#1193107)
647- -doc: add qsci doc QyQt5.api content
648- enable Qt5WebChannel/Qt5WebSockets support
649
650* Fri Jun 05 2015 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
651- Add patch to fix python3 sip installation dir (#1228432)
652
653* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
654- Rebuilt for GCC 5 C++11 ABI change
655
656* Wed Mar 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-2
657- rebuild (sip)
658
659* Thu Feb 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-1
660- 5.4.1
661
662* Wed Feb 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-6
663- rebuild (sip)
664
665* Tue Jan 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-5
666- +macros.pyqt5
667
668* Fri Jan 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-4
669- -devel: restore dep on base pkg
670
671* Sun Dec 28 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4-3
672- python3-qt5-devel subpkg
673
674* Sat Dec 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-2
675- ensure .so modules are executable (for proper -debuginfo extraction)
676
677* Fri Dec 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-1
678- 5.4
679
680* Thu Nov 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-6
681- restore python3 support
682
683* Tue Nov 11 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-5
684- pkgconfig(QtOpenGL) being satisfied by qt4 devel (#1162415)
685
686* Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-4
687- try to determine dbus-python install paths dynamically (#1161121)
688
689* Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.3.2-3
690- Build failure in sipQtWebKitWidgestQWebInspector: qprinter.h not found (#1160932)
691- python2_sitelib should be python2_sitearch (#1161121)
692
693* Mon Sep 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
694- PyQt-gpl-5.3.2
695
696* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
697- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
698
699* Sun Jul 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.1-1
700- PyQt-gpl-5.3.1
701
702* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3-3
703- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
704
705* Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-2
706- python3: (Build)Requires: python3-dbus
707
708* Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-1
709- PyQt-gpl-5.3
710- +Qt5Bluetooth,Qt5Quick,Qt5SerialPorts support
711
712* Mon May 12 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
713- rebuild (f21-python)
714- +Qt5Positioning,Qt5Sensors support
715
716* Sun Mar 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
717- PyQt-5.2.1
718
719* Sat Mar 08 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.2-5
720- Rebuild against fixed qt5-qtbase to fix -debuginfo (#1065636)
721
722* Sat Feb 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-4
723- python3-qt5 support
724
725* Thu Feb 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-3
726- Provides: PyQt5
727
728* Thu Feb 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-2
729- BR: python2-devel, use %%__python2 macro
730
731* Wed Jan 08 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-1
732- PyQt-5.2
733
Note: See TracBrowser for help on using the repository browser.