source: projects/specs/trunk/p/python-qt5/python-qt5-vl.spec @ 11452

Revision 11452, 19.1 KB checked in by ara_t, 6 years ago (diff)

python-qt5: rebuild under current VineSeed

Line 
1%{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1))")}
2%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
3%{!?python3_version: %global python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
4
5%global __python3 /usr/bin/python3
6
7# prevent anything matching from being scanned for provides
8%define filter_provides_in(P) %{expand: \
9%global __filter_prov_cmd %{?__filter_prov_cmd} %{__grep} -v %{-P} '%*' | \
10}
11
12# prevent anything matching from being scanned for requires
13%define filter_requires_in(P) %{expand: \
14%global __filter_req_cmd %{?__filter_req_cmd} %{__grep} -v %{-P} '%*' | \
15}
16
17# filter anything matching out of the provides stream
18%define filter_from_provides() %{expand: \
19%global __filter_from_prov %{?__filter_from_prov} | %{__sed} -e '%*' \
20}
21
22# filter anything matching out of the requires stream
23%define filter_from_requires() %{expand: \
24%global __filter_from_req %{?__filter_from_req} | %{__sed} -e '%*' \
25}
26
27# actually set up the filtering bits
28%define filter_setup %{expand: \
29%global _use_internal_dependency_generator 0 \
30%global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u \
31%global __find_provides /bin/sh -c "%{?__filter_prov_cmd} %{__deploop P} %{?__filter_from_prov}" \
32%global __find_requires /bin/sh -c "%{?__filter_req_cmd}  %{__deploop R} %{?__filter_from_req}" \
33}
34
35%global with_python3 1
36%global python3_dbus_dir %(%{__python3} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
37%global with_python2 1
38%global python2_dbus_dir %(%{__python} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
39
40# enable/disable individual modules
41# drop power64, it's not supported yet (than)
42%ifarch %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
43%global webengine 1
44%endif
45%global webkit 1
46
47%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
48
49Summary: PyQt5 is Python bindings for Qt5
50Name:    python-qt5
51Version: 5.6
52Release: 7%{?_dist_release}
53
54# all BSD, except for GPLv2+ dbus bindings and examples
55License: BSD and GPLv2+
56Url:     http://www.riverbankcomputing.com/software/pyqt/
57%if 0%{?snap:1}
58Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt5/PyQt5_gpl-%{version}%{?snap:-snapshot-%{snap}}.tar.gz
59%else
60Source0: http://downloads.sourceforge.net/project/pyqt/PyQt5/PyQt-%{version}/PyQt5_gpl-%{version}.tar.gz
61%endif
62Source1: macros.pyqt5
63# wrapper, see https://bugzilla.redhat.com/show_bug.cgi?id=1193107#c9
64Source2: pyuic5.sh
65
66## upstream patches
67
68## upstreamable patches
69Patch0: python-qt5_sipdir.patch
70Patch1: PyQt5_gpl-5.6-dbus_ftbfs.patch
71
72BuildRequires: chrpath
73BuildRequires: findutils
74BuildRequires: pkgconfig(dbus-1)
75BuildRequires: pkgconfig(dbus-python)
76BuildRequires: pkgconfig(phonon4qt5)
77BuildRequires: pkgconfig(Qt5Core) >= 5.5
78BuildRequires: pkgconfig(Enginio)
79BuildRequires: pkgconfig(Qt5Bluetooth)
80BuildRequires: pkgconfig(Qt5DBus)
81BuildRequires: pkgconfig(Qt5Declarative)
82BuildRequires: pkgconfig(Qt5Designer)
83BuildRequires: pkgconfig(Qt5Gui) pkgconfig(Qt5Multimedia)
84BuildRequires: pkgconfig(Qt5Location)
85BuildRequires: pkgconfig(Qt5Nfc)
86BuildRequires: pkgconfig(Qt5Network) pkgconfig(Qt5OpenGL)
87BuildRequires: pkgconfig(Qt5Positioning)
88BuildRequires: pkgconfig(Qt5Quick) pkgconfig(Qt5QuickWidgets)
89BuildRequires: pkgconfig(Qt5Script)
90BuildRequires: pkgconfig(Qt5Sensors)
91BuildRequires: pkgconfig(Qt5SerialPort)
92BuildRequires: pkgconfig(Qt5Sql) pkgconfig(Qt5Svg) pkgconfig(Qt5Test)
93BuildRequires: pkgconfig(Qt5X11Extras)
94BuildRequires: pkgconfig(Qt5Xml) pkgconfig(Qt5XmlPatterns)
95BuildRequires: pkgconfig(Qt5WebChannel)
96BuildRequires: pkgconfig(Qt5WebSockets)
97BuildRequires: python-devel python
98BuildRequires: sip-devel >= 4.18
99%if 0%{?with_python3}
100BuildRequires: python3-devel python3
101BuildRequires: python3-sip-devel >= 4.18
102BuildRequires: dbus-python3
103%endif # with_python3
104
105# when split out
106%if 0%{?webengine} || 0%{?webkit}
107Obsoletes: python-qt5 < 5.5.1-10
108%endif
109
110Requires: %{name}-rpm-macros = %{version}-%{release}
111Requires: dbus-python
112BuildRequires: qt5-qtbase-private-devel
113%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
114%{?_sip_api:Requires: sip-api(%{_sip_api_major}) >= %{_sip_api}}
115
116%filter_provides_in %{python_sitearch} %{?_qt5_plugindir}
117%if 0%{?with_python3}
118%filter_provides_in %{python3_sitearch} %{?_qt5_plugindir}
119%endif
120%filter_setup
121
122Provides: PyQt5 = %{version}-%{release}
123Provides: PyQt5%{?_isa} = %{version}-%{release}
124Provides: python-PyQt5 = %{version}-%{release}
125Provides: python-PyQt5%{?_isa} = %{version}-%{release}
126Provides: python2-PyQt5 = %{version}-%{release}
127Provides: python2-PyQt5%{?_isa} = %{version}-%{release}
128Provides: python2-qt5 = %{version}-%{release}
129Provides: python2-qt5%{?_isa} = %{version}-%{release}
130
131%description
132PyQt5 is Python bindings for Qt5.
133
134%package devel
135Summary: Development files for %{name}
136Requires: %{name}%{?_isa} = %{version}-%{release}
137Requires: qt5-qtbase-devel
138Requires: sip-devel
139Provides: PyQt5-devel = %{version}-%{release}
140Provides: python2-PyQt5-devel = %{version}-%{release}
141%description devel
142Files needed to build other bindings for C++ classes that inherit from any
143of the Qt5 classes (e.g. KDE or your own).
144
145%package rpm-macros
146Summary: RPM macros %{name}
147# when split out
148Conflicts: python-qt5 < 5.6
149Conflicts: python3-qt5 < 5.6
150BuildArch: noarch
151%description rpm-macros
152%{summary}.
153
154%package -n python3-qt5
155Summary: Python 3 bindings for Qt5
156%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
157%{?_sip_api:Requires: python3-sip-api(%{_sip_api_major}) >= %{_sip_api}}
158# when split out
159%if 0%{?webengine} || 0%{?webkit}
160Obsoletes: python3-qt5 < 5.5.1-10
161%endif
162Provides: python3-PyQt5 = %{version}-%{release}
163Provides: python3-PyQt5%{?_isa} = %{version}-%{release}
164Requires: %{name}-rpm-macros = %{version}-%{release}
165Requires: dbus-python3
166%description -n python3-qt5
167%{summary}.
168
169%package -n python3-qt5-devel
170Summary: Python 3 bindings for Qt5
171Requires: python3-qt5%{?_isa} = %{version}-%{release}
172Requires: qt5-qtbase-devel
173Requires: python3-sip-devel
174Provides: python3-PyQt5-devel = %{version}-%{release}
175%description -n python3-qt5-devel
176Files needed to build other bindings for C++ classes that inherit from any
177of the Qt5 classes
178
179%package doc
180Summary: Developer documentation for %{name}
181Provides: PyQt5-doc = %{version}-%{release}
182BuildArch: noarch
183%description doc
184%{summary}.
185
186%if 0%{?webengine}
187%package webengine
188Summary: Python bindings for Qt5 WebEngine
189BuildRequires: pkgconfig(Qt5WebEngine)
190Obsoletes: python-qt5 < 5.5.1-10
191Requires:  %{name}%{?_isa} = %{version}-%{release}
192%description webengine
193
194%package -n python3-qt5-webengine
195Summary: Python bindings for Qt5 WebEngine
196Obsoletes: python3-webengine < 5.5.1-13
197Obsoletes: python3-qt5 < 5.5.1-10
198Requires:  python3-qt5%{?_isa} = %{version}-%{release}
199%description -n python3-qt5-webengine
200%endif
201
202%if 0%{?webkit}
203%package webkit
204Summary: Python bindings for Qt5 Webkit
205BuildRequires: pkgconfig(Qt5WebKit) pkgconfig(Qt5WebKitWidgets)
206Obsoletes: python3-webkit < 5.5.1-12
207Obsoletes: python-qt5 < 5.5.1-10
208Requires:  %{name}%{?_isa} = %{version}-%{release}
209%description webkit
210
211%package -n python3-qt5-webkit
212Summary: Python bindings for Qt5 Webkit
213Obsoletes: python3-qt5 < 5.5.1-10
214Requires:  python3-qt5%{?_isa} = %{version}-%{release}
215%description -n python3-qt5-webkit
216%endif
217
218
219%prep
220%setup -q -n PyQt5_gpl-%{version}%{?snap:-snapshot-%{snap}}
221
222%patch0 -p1
223%patch1 -p1
224
225
226%build
227PATH=%{_qt5_bindir}:$PATH ; export PATH
228
229# Python 2 build:
230%if 0%{?with_python2}
231mkdir %{_target_platform}
232pushd %{_target_platform}
233%{__python} ../configure.py \
234  --assume-shared \
235  --confirm-license \
236  --qmake=%{_qt5_qmake} \
237  --qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci \
238  --verbose \
239  QMAKE_CFLAGS_RELEASE="%{optflags}" \
240  QMAKE_CXXFLAGS_RELEASE="%{optflags}" \
241  QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
242
243make %{?_smp_mflags}
244popd
245%endif # with_python2
246
247# Python 3 build:
248%if 0%{?with_python3}
249mkdir %{_target_platform}-python3
250pushd %{_target_platform}-python3
251%{__python3} ../configure.py \
252  --assume-shared \
253  --confirm-license \
254  --qmake=%{_qt5_qmake} \
255  --no-qsci-api \
256  --verbose \
257  QMAKE_CFLAGS_RELEASE="%{optflags}" \
258  QMAKE_CXXFLAGS_RELEASE="%{optflags}" \
259  QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
260
261make %{?_smp_mflags}
262popd
263%endif # with_python3
264
265
266%install
267
268# Python 3 build:
269%if 0%{?with_python3}
270make install DESTDIR=%{buildroot} INSTALL_ROOT=%{buildroot} -C %{_target_platform}-python3
271# ensure .so modules are executable for proper -debuginfo extraction
272for i in %{buildroot}%{python3_sitearch}/PyQt5/*.so %{buildroot}%{python3_dbus_dir}/pyqt5.so ; do
273chmod a+rx $i
274done
275%endif # with_python3
276
277# Python 2 build:
278%if 0%{?with_python2}
279make install DESTDIR=%{buildroot} INSTALL_ROOT=%{buildroot} -C %{_target_platform}
280# ensure .so modules are executable for proper -debuginfo extraction
281for i in %{buildroot}%{python_sitearch}/PyQt5/*.so %{buildroot}%{python2_dbus_dir}/pyqt5.so ; do
282chmod a+rx $i
283done
284%endif # with_python2
285
286# remove Python3 code from Python2 directory, fixes FTBFS like PyQt4 (#564633)
287rm -rfv %{buildroot}%{python_sitearch}/PyQt5/uic/port_v3/
288# remove Python2 code from Python3 directory (for when/if we support python3 here)
289rm -rfv %{buildroot}%{python3_sitearch}/PyQt5/uic/port_v2/
290
291# rpm macros
292install -p -m644 -D %{SOURCE1} \
293  %{buildroot}%{rpm_macros_dir}/macros.pyqt5
294sed -i \
295  -e "s|@@NAME@@|%{name}|g" \
296  -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
297  -e "s|@@VERSION@@|%{version}|g" \
298  -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
299  %{buildroot}%{rpm_macros_dir}/macros.pyqt5
300
301%if 0%{?with_python3}
302# install pyuic5 wrapper to handle both/either python2/python3
303rm -fv %{buildroot}%{_bindir}/pyuic5
304install -p -m755 -D %{SOURCE2} \
305  %{buildroot}%{_bindir}/pyuic5
306sed -i \
307  -e "s|@PYTHON3@|%{__python3}|g" \
308  -e "s|@PYTHON2@|%{__python}|g" \
309  %{buildroot}%{_bindir}/pyuic5
310%endif
311
312
313%if 0%{?with_python2}
314%files
315%doc NEWS README
316%license LICENSE
317%{python2_dbus_dir}/pyqt5.so
318%{_qt5_plugindir}/PyQt5/
319%dir %{python_sitearch}/PyQt5/
320%{python_sitearch}/PyQt5/__init__.py*
321%{python_sitearch}/PyQt5/Enginio.so
322%{python_sitearch}/PyQt5/Qt.so
323%{python_sitearch}/PyQt5/QtBluetooth.so
324%{python_sitearch}/PyQt5/QtCore.so
325%{python_sitearch}/PyQt5/QtDBus.so
326%{python_sitearch}/PyQt5/QtDesigner.so
327%{python_sitearch}/PyQt5/QtGui.so
328%{python_sitearch}/PyQt5/QtHelp.so
329%{python_sitearch}/PyQt5/QtLocation.so
330%{python_sitearch}/PyQt5/QtMultimedia.so
331%{python_sitearch}/PyQt5/QtMultimediaWidgets.so
332%{python_sitearch}/PyQt5/QtNetwork.so
333%{python_sitearch}/PyQt5/QtNfc.so
334%{python_sitearch}/PyQt5/QtOpenGL.so
335%{python_sitearch}/PyQt5/QtPositioning.so
336%{python_sitearch}/PyQt5/QtPrintSupport.so
337%{python_sitearch}/PyQt5/QtQml.so
338%{python_sitearch}/PyQt5/QtQuick.so
339%{python_sitearch}/PyQt5/QtQuickWidgets.so
340%{python_sitearch}/PyQt5/QtSensors.so
341%{python_sitearch}/PyQt5/QtSerialPort.so
342%{python_sitearch}/PyQt5/QtSql.so
343%{python_sitearch}/PyQt5/QtSvg.so
344%{python_sitearch}/PyQt5/QtTest.so
345%{python_sitearch}/PyQt5/QtWebChannel.so
346%{python_sitearch}/PyQt5/QtWebSockets.so
347%{python_sitearch}/PyQt5/QtWidgets.so
348%{python_sitearch}/PyQt5/QtX11Extras.so
349%{python_sitearch}/PyQt5/QtXml.so
350%{python_sitearch}/PyQt5/QtXmlPatterns.so
351%{python_sitearch}/PyQt5/_QOpenGLFunctions_2_0.so
352%{python_sitearch}/PyQt5/_QOpenGLFunctions_2_1.so
353%{python_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.so
354%{python_sitearch}/PyQt5/uic/
355%{_qt5_plugindir}/designer/libpyqt5.so
356
357%if 0%{?webengine}
358%files webengine
359%{python_sitearch}/PyQt5/QtWebEngineCore.*
360%{python_sitearch}/PyQt5/QtWebEngineWidgets.*
361%endif
362
363%if 0%{?webkit}
364%files webkit
365%{python_sitearch}/PyQt5/QtWebKit.*
366%{python_sitearch}/PyQt5/QtWebKitWidgets.*
367%endif
368
369%files rpm-macros
370%{rpm_macros_dir}/macros.pyqt5
371
372%files devel
373%{_bindir}/pylupdate5
374%{_bindir}/pyrcc5
375%{_bindir}/pyuic5
376%{_datadir}/sip/PyQt5/
377%endif
378
379%if 0%{?with_python3}
380%files -n python3-qt5
381%doc NEWS README
382%license LICENSE
383%{python3_dbus_dir}/pyqt5.so
384%{python3_sitearch}/PyQt5
385%if 0%{?webengine}
386%exclude %{python3_sitearch}/PyQt5/QtWebEngineCore.*
387%exclude %{python3_sitearch}/PyQt5/QtWebEngineWidgets.*
388%endif
389%if 0%{?webkit}
390%exclude %{python3_sitearch}/PyQt5/QtWebKit.*
391%exclude %{python3_sitearch}/PyQt5/QtWebKitWidgets.*
392%endif
393
394%if 0%{?webengine}
395%files -n python3-qt5-webengine
396%{python3_sitearch}/PyQt5/QtWebEngineCore.*
397%{python3_sitearch}/PyQt5/QtWebEngineWidgets.*
398%endif
399
400%if 0%{?webkit}
401%files -n python3-qt5-webkit
402%{python3_sitearch}/PyQt5/QtWebKit.*
403%{python3_sitearch}/PyQt5/QtWebKitWidgets.*
404%endif
405
406%files -n python3-qt5-devel
407%{_bindir}/pylupdate5
408%{_bindir}/pyrcc5
409%{_bindir}/pyuic5
410%{_datadir}/python3-sip/PyQt5/
411%endif # with_python3
412
413%files doc
414%doc doc/*
415%doc examples/
416# avoid dep on qscintilla-python, own %%_qt5_datadir/qsci/... here for now
417%dir %{_qt5_datadir}/qsci/
418%dir %{_qt5_datadir}/qsci/api/
419%dir %{_qt5_datadir}/qsci/api/python/
420%doc %{_qt5_datadir}/qsci/api/python/PyQt5.api
421
422
423%changelog
424* Sat Jan 27 2018 Toshiaki Ara <ara_t@384.jp> - 5.6-7
425- rebuild under current VineSeed
426
427* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6-6
428- initial build for Vine Linux.
429
430* Wed Jul 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-5
431- BR: qt5-qtbase-private-devel
432- python3-qt5: add versioned qt5 dep (like base python-qt5 pkg has)
433
434* Wed Jun 29 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-4
435- rebuild (qt5)
436
437* Wed Jun 15 2016 Than Ngo <than@redhat.com> - 5.6-3
438- drop ppc ppc64 ppc64le, it's not supported yet
439
440* Mon May 02 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-2
441- -rpm-macros: Conflicts: python(3)-qt5 < 5.6
442
443* Mon Apr 25 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-1
444- PyQt5-5.6
445
446* Wed Apr 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-20
447- rebuild (sip), re-enable -webengine for secondary archs
448
449* Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-19
450- limit -webengine support to just primary archs (for now)
451
452* Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-18
453- -rpm-macros subpkg
454
455* Tue Mar 15 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-17
456- rebuild (qt5-qtenginio)
457
458* Mon Mar 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-16
459- -webengine: add ExclusiveArch (matching qt5-qtwebengine's)
460
461* Mon Mar 07 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-15
462- add Obsoletes for misnamed -webengine/-webkit pkgs (#1315025)
463
464* Sat Mar 05 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-14
465- python-qt5 is not built with $RPM_OPT_FLAGS (#1314998)
466
467* Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-13
468- fix python3-qt5-webengine name
469
470* Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-12
471- fix python3-qt5-webkit name
472
473* Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-11
474- use safer subdir builds
475
476* Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-10
477- -webengine,-webkit subpkgs
478
479* Sat Feb 27 2016 Christian Dersch <lupinix@mailbox.org> - 5.5.1-9
480- Enabled QtWebEngine for Fedora >= 24
481
482* Sat Feb 27 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-8
483- rebuild
484
485* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-7
486- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
487
488* Mon Feb 01 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-6
489- explicitly set CFLAGS,CXXFLAGS,LFLAGS
490
491* Wed Jan 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-5
492- %%description: mention PyQt5
493
494* Mon Dec 07 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-4
495- rebuild (qt5), Provides: python2-qt5
496
497* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.5.1-3
498- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
499
500* Mon Nov 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-2
501- rebuild (qt5)
502
503* Mon Oct 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-1
504- 5.5.1
505- enable qtenginio, fix pyuic5 wrapper, use %%license
506
507* Mon Oct 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-2
508- rebuild (qt5)
509
510* Thu Jul 30 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-1
511- 5.5
512
513* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.2-2
514- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
515
516* Fri Jun 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-1
517- 5.4.2
518
519* Fri Jun 05 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-5
520- wrong python release used in pyuic5 launch script (#1193107)
521- -doc: add qsci doc QyQt5.api content
522- enable Qt5WebChannel/Qt5WebSockets support
523
524* Fri Jun 05 2015 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
525- Add patch to fix python3 sip installation dir (#1228432)
526
527* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
528- Rebuilt for GCC 5 C++11 ABI change
529
530* Wed Mar 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-2
531- rebuild (sip)
532
533* Thu Feb 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-1
534- 5.4.1
535
536* Wed Feb 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-6
537- rebuild (sip)
538
539* Tue Jan 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-5
540- +macros.pyqt5
541
542* Fri Jan 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-4
543- -devel: restore dep on base pkg
544
545* Sun Dec 28 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4-3
546- python3-qt5-devel subpkg
547
548* Sat Dec 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-2
549- ensure .so modules are executable (for proper -debuginfo extraction)
550
551* Fri Dec 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-1
552- 5.4
553
554* Thu Nov 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-6
555- restore python3 support
556
557* Tue Nov 11 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-5
558- pkgconfig(QtOpenGL) being satisfied by qt4 devel (#1162415)
559
560* Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-4
561- try to determine dbus-python install paths dynamically (#1161121)
562
563* Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.3.2-3
564- Build failure in sipQtWebKitWidgestQWebInspector: qprinter.h not found (#1160932)
565- python2_sitelib should be python2_sitearch (#1161121)
566
567* Mon Sep 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
568- PyQt-gpl-5.3.2
569
570* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
571- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
572
573* Sun Jul 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.1-1
574- PyQt-gpl-5.3.1
575
576* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3-3
577- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
578
579* Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-2
580- python3: (Build)Requires: python3-dbus
581
582* Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-1
583- PyQt-gpl-5.3
584- +Qt5Bluetooth,Qt5Quick,Qt5SerialPorts support
585
586* Mon May 12 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
587- rebuild (f21-python)
588- +Qt5Positioning,Qt5Sensors support
589
590* Sun Mar 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
591- PyQt-5.2.1
592
593* Sat Mar 08 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.2-5
594- Rebuild against fixed qt5-qtbase to fix -debuginfo (#1065636)
595
596* Sat Feb 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-4
597- python3-qt5 support
598
599* Thu Feb 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-3
600- Provides: PyQt5
601
602* Thu Feb 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-2
603- BR: python2-devel, use %%__python2 macro
604
605* Wed Jan 08 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-1
606- PyQt-5.2
607
Note: See TracBrowser for help on using the repository browser.