source: projects/specs/trunk/p/python-qt5/python-qt5-vl.spec @ 12469

Revision 12469, 23.7 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1# prevent anything matching from being scanned for provides
2%define filter_provides_in(P) %{expand: \
3%global __filter_prov_cmd %{?__filter_prov_cmd} %{__grep} -v %{-P} '%*' | \
4}
5
6# prevent anything matching from being scanned for requires
7%define filter_requires_in(P) %{expand: \
8%global __filter_req_cmd %{?__filter_req_cmd} %{__grep} -v %{-P} '%*' | \
9}
10
11# filter anything matching out of the provides stream
12%define filter_from_provides() %{expand: \
13%global __filter_from_prov %{?__filter_from_prov} | %{__sed} -e '%*' \
14}
15
16# filter anything matching out of the requires stream
17%define filter_from_requires() %{expand: \
18%global __filter_from_req %{?__filter_from_req} | %{__sed} -e '%*' \
19}
20
21# actually set up the filtering bits
22%define filter_setup %{expand: \
23%global _use_internal_dependency_generator 0 \
24%global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u \
25%global __find_provides /bin/sh -c "%{?__filter_prov_cmd} %{__deploop P} %{?__filter_from_prov}" \
26%global __find_requires /bin/sh -c "%{?__filter_req_cmd}  %{__deploop R} %{?__filter_from_req}" \
27}
28
29%global with_python3 1
30%global python3_dbus_dir %(%{__python3} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
31%global with_python2 1
32%global python_dbus_dir %(%{__python} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
33
34# enable/disable individual modules
35# drop power64, it's not supported yet (than)
36%ifarch %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
37%global webengine 0
38%endif
39%global webkit 0
40
41#global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
42%global rpm_macros_dir %{_sysconfdir}/rpm
43
44%global py3_sipdir %{_datadir}/sip/PyQt5
45
46Summary:        PyQt5 is Python bindings for Qt5
47Name:           python-qt5
48Version:        5.15.0
49Release:        1%{?_dist_release}
50Group:          programming
51Vendor:         Project Vine
52Distribution:   Vine Linux
53
54License: GPLv3+
55Url:     https://www.riverbankcomputing.com/software/pyqt/
56Source0: PyQt5-%{version}.tar.gz
57Source1: macros.pyqt5
58# wrapper, see https://bugzilla.redhat.com/show_bug.cgi?id=1193107#c9
59Source2: pylupdate5.sh
60Source3: pyrcc5.sh
61Source4: pyuic5.sh
62
63## upstream patches
64
65## upstreamable patches
66Patch0: python-qt5_sipdir.patch
67
68BuildRequires: chrpath
69BuildRequires: findutils
70BuildRequires: qt5-rpm-macros
71BuildRequires: pkgconfig(dbus-1)
72BuildRequires: pkgconfig(dbus-python)
73BuildRequires: pkgconfig(phonon4qt5)
74BuildRequires: pkgconfig(Qt5Core)
75#BuildRequires: pkgconfig(Enginio)
76BuildRequires: pkgconfig(Qt5Bluetooth)
77BuildRequires: pkgconfig(Qt5DBus)
78#BuildRequires: pkgconfig(Qt5Declarative)
79BuildRequires: qt5-qtdeclarative-devel
80BuildRequires: pkgconfig(Qt5Designer)
81BuildRequires: pkgconfig(Qt5Gui) pkgconfig(Qt5Multimedia)
82BuildRequires: pkgconfig(Qt5Location)
83BuildRequires: pkgconfig(Qt5Nfc)
84BuildRequires: pkgconfig(Qt5Network) pkgconfig(Qt5OpenGL)
85BuildRequires: pkgconfig(Qt5Positioning)
86BuildRequires: pkgconfig(Qt5Quick) pkgconfig(Qt5QuickWidgets)
87#BuildRequires: pkgconfig(Qt5Script)
88BuildRequires: pkgconfig(Qt5Sensors)
89BuildRequires: pkgconfig(Qt5SerialPort)
90BuildRequires: pkgconfig(Qt5Sql) pkgconfig(Qt5Svg) pkgconfig(Qt5Test)
91BuildRequires: pkgconfig(Qt5X11Extras)
92BuildRequires: pkgconfig(Qt5Xml) pkgconfig(Qt5XmlPatterns)
93BuildRequires: pkgconfig(Qt5WebChannel)
94BuildRequires: pkgconfig(Qt5WebSockets)
95BuildRequires: sip-devel >= 4.18
96%if 0%{?with_python2}
97BuildRequires: python-devel python
98BuildRequires: python-rpm-macros
99BuildRequires: python-enum34
100%endif # with_python2
101%if 0%{?with_python3}
102BuildRequires: python3-devel python3
103BuildRequires: python3-rpm-macros
104BuildRequires: python3-sip-devel >= 4.18
105BuildRequires: dbus-python3
106%endif # with_python3
107
108# when split out
109%if 0%{?webengine} || 0%{?webkit}
110Obsoletes: python-qt5 < 5.5.1-10
111%endif
112
113Requires: %{name}-rpm-macros = %{version}-%{release}
114Requires: python-qt5-base = %{version}-%{release}
115Requires: dbus-python
116BuildRequires: qt5-qtbase-private-devel
117%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
118%{?_sip_api:Requires: sip-api(%{_sip_api_major}) >= %{_sip_api}}
119
120%filter_provides_in %{python_sitearch} %{?_qt5_plugindir}
121%if 0%{?with_python3}
122%filter_provides_in %{python3_sitearch} %{?_qt5_plugindir}
123%endif
124%filter_setup
125
126Provides: PyQt5 = %{version}-%{release}
127Provides: PyQt5%{?_isa} = %{version}-%{release}
128Provides: python-PyQt5 = %{version}-%{release}
129Provides: python-PyQt5%{?_isa} = %{version}-%{release}
130Provides: python2-PyQt5 = %{version}-%{release}
131Provides: python2-PyQt5%{?_isa} = %{version}-%{release}
132Provides: python2-qt5 = %{version}-%{release}
133Provides: python2-qt5%{?_isa} = %{version}-%{release}
134
135%description
136PyQt5 is Python bindings for Qt5.
137
138
139%if 0%{?with_python2}
140%package base
141Summary: Python bindings for Qt5 base
142Group: programming
143Requires: %{name}-rpm-macros = %{version}-%{release}
144%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
145%{?_sip_api:Requires: python-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
146Requires: dbus-python
147Obsoletes: python-qt5 < 5.5.1-10
148Provides: python-PyQt5-base = %{version}-%{release}
149Provides: python-PyQt5-base%{?_isa} = %{version}-%{release}
150%{?python_provide:%python_provide python-qt5-base}
151%description base
152%{summary}.
153
154
155%package devel
156Summary: Development files for %{name}
157Group: programming
158Requires: %{name}%{?_isa} = %{version}-%{release}
159Requires: qt5-qtbase-devel
160Requires: sip-devel
161Provides: PyQt5-devel = %{version}-%{release}
162Provides: python-PyQt5-devel = %{version}-%{release}
163%description devel
164Files needed to build other bindings for C++ classes that inherit from any
165of the Qt5 classes (e.g. KDE or your own).
166%endif
167
168
169%package rpm-macros
170Summary: RPM macros %{name}
171Group: programming
172# when split out
173Conflicts: python-qt5 < 5.6
174Conflicts: python3-qt5 < 5.6
175BuildArch: noarch
176%description rpm-macros
177%{summary}.
178
179
180%package -n python3-qt5
181Summary: Python 3 bindings for Qt5
182Group: programming
183%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
184%{?_sip_api:Requires: python3-sip-api(%{_sip_api_major}) >= %{_sip_api}}
185# when split out
186%if 0%{?webengine} || 0%{?webkit}
187Obsoletes: python3-qt5 < 5.5.1-10
188%endif
189Provides: python3-PyQt5 = %{version}-%{release}
190Provides: python3-PyQt5%{?_isa} = %{version}-%{release}
191Requires: %{name}-rpm-macros = %{version}-%{release}
192Requires: python3-qt5-base = %{version}-%{release}
193Requires: dbus-python3
194%description -n python3-qt5
195%{summary}.
196
197
198%package -n python3-qt5-base
199Summary: Python 3 bindings for Qt5 base
200Group: programming
201%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
202%{?_sip_api:Requires: python3-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
203Provides: python3-PyQt5-base = %{version}-%{release}
204Provides: python3-PyQt5-base%{?_isa} = %{version}-%{release}
205Requires: %{name}-rpm-macros = %{version}-%{release}
206Requires: dbus-python3
207%{?python_provide:%python_provide python3-qt5-base}
208%description -n python3-qt5-base
209%{summary}.
210
211
212%package -n python3-qt5-devel
213Summary: Python 3 bindings for Qt5
214Group: programming
215Requires: python3-qt5%{?_isa} = %{version}-%{release}
216Requires: qt5-qtbase-devel
217Requires: python3-sip-devel
218Provides: python3-PyQt5-devel = %{version}-%{release}
219%description -n python3-qt5-devel
220Files needed to build other bindings for C++ classes that inherit from any
221of the Qt5 classes
222
223%package doc
224Summary: Developer documentation for %{name}
225Group: documentation
226BuildArch: noarch
227Provides: PyQt5-doc = %{version}-%{release}
228%description doc
229%{summary}.
230
231
232%if 0%{?webengine}
233%package webengine
234Summary: Python bindings for Qt5 WebEngine
235Group: programming
236BuildRequires: pkgconfig(Qt5WebEngine)
237BuildRequires: qt5-qtwebengine-devel
238Obsoletes: python-qt5 < 5.5.1-10
239Requires:  %{name}%{?_isa} = %{version}-%{release}
240%description webengine
241
242%package -n python3-qt5-webengine
243Summary: Python bindings for Qt5 WebEngine
244Group: programming
245Obsoletes: python3-webengine < 5.5.1-13
246Obsoletes: python3-qt5 < 5.5.1-10
247Requires:  python3-qt5%{?_isa} = %{version}-%{release}
248%description -n python3-qt5-webengine
249%endif
250
251
252%if 0%{?webkit}
253%package webkit
254Summary: Python bindings for Qt5 Webkit
255Group: programming
256BuildRequires: pkgconfig(Qt5WebKit) pkgconfig(Qt5WebKitWidgets)
257Obsoletes: python3-webkit < 5.5.1-12
258Obsoletes: python-qt5 < 5.5.1-10
259Requires:  %{name}%{?_isa} = %{version}-%{release}
260%description webkit
261
262%package -n python3-qt5-webkit
263Summary: Python bindings for Qt5 Webkit
264Group: programming
265Obsoletes: python3-qt5 < 5.5.1-10
266Requires:  python3-qt5%{?_isa} = %{version}-%{release}
267%description -n python3-qt5-webkit
268%endif
269
270
271%debug_package
272
273
274%prep
275%setup -q -n PyQt5-%{version}%{?snap:-snapshot-%{snap}}
276
277%patch0 -p1
278
279
280%build
281PATH=%{_qt5_bindir}:$PATH ; export PATH
282
283# Python 2 build:
284%if 0%{?with_python2}
285mkdir %{_target_platform}
286pushd %{_target_platform}
287%{__python} ../configure.py \
288  --assume-shared \
289  --confirm-license \
290  --no-designer-plugin \
291  --no-qml-plugin \
292  --qmake=%{_qt5_qmake} \
293  --no-qsci-api \
294  --verbose \
295  --dbus=/usr/include/dbus-1.0/ \
296  QMAKE_CFLAGS_RELEASE="%{optflags}" \
297  QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
298  QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
299
300make %{?_smp_mflags}
301popd
302%endif # with_python2
303
304# Python 3 build:
305%if 0%{?with_python3}
306mkdir %{_target_platform}-python3
307pushd %{_target_platform}-python3
308%{__python3} ../configure.py \
309  --assume-shared \
310  --confirm-license \
311  --qmake=%{_qt5_qmake} \
312%ifarch x86_64
313  --qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci \
314%else
315  --no-qsci-api \
316%endif
317  %{?py3_sip:--sip=%{_bindir}/python3-sip} \
318  %{?py3_sipdir:--sipdir=%{py3_sipdir}} \
319  --verbose \
320  %{?python3_sip_incdir} \
321  --dbus=/usr/include/dbus-1.0/ \
322  QMAKE_CFLAGS_RELEASE="%{optflags}" \
323  QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
324  QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
325
326make %{?_smp_mflags}
327popd
328%endif # with_python3
329
330
331%install
332
333# Python 3 build:
334%if 0%{?with_python3}
335%make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}-python3
336if [ "%{_prefix}" != "/usr" ]; then
337  cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
338  rm -rf %{buildroot}/usr/*
339fi
340%if "%py3_sipdir" == "%{_datadir}/sip/PyQt5"
341# copy files to old location for compat purposes temporarily
342mkdir -p %{buildroot}%{_datadir}/python3-sip
343cp -alf %{buildroot}%{py3_sipdir} \
344        %{buildroot}%{_datadir}/python3-sip/PyQt5
345%endif
346
347if [ "%{_prefix}" != "/usr" ]; then
348  cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/ || echo "Nothing to copy"
349  rm -rf %{buildroot}/usr/*
350fi
351
352# ensure .so modules are executable for proper -debuginfo extraction
353find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
354#for i in %%{buildroot}%%{python3_sitearch}/PyQt5/*.so %%{buildroot}%%{python3_dbus_dir}/pyqt5.so ; do
355#test -x $i  || chmod a+rx $i
356#done
357%endif # with_python3
358
359# Python 2 build:
360%if 0%{?with_python2}
361%make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
362if [ "%{_prefix}" != "/usr" ]; then
363  cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
364  rm -rf %{buildroot}/usr/*
365fi
366# ensure .so modules are executable for proper -debuginfo extraction
367find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
368#for i in %%{buildroot}%%{python2_sitearch}/PyQt5/*.so %%{buildroot}%%{python2_dbus_dir}/pyqt5.so ; do
369#test -x $i || chmod a+rx $i
370#done
371%endif # with_python2
372
373# remove Python3 code from Python2 directory, fixes FTBFS like PyQt4 (#564633)
374rm -rfv %{buildroot}%{python2_sitearch}/PyQt5/uic/port_v3/
375# remove Python2 code from Python3 directory (for when/if we support python3 here)
376rm -rfv %{buildroot}%{python3_sitearch}/PyQt5/uic/port_v2/
377
378# rpm macros
379install -p -m644 -D %{SOURCE1} \
380  %{buildroot}%{rpm_macros_dir}/macros.pyqt5
381sed -i \
382  -e "s|@@NAME@@|%{name}|g" \
383  -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
384  -e "s|@@VERSION@@|%{version}|g" \
385  -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
386  %{buildroot}%{rpm_macros_dir}/macros.pyqt5
387
388%if 0%{?with_python3}
389# install wrappers to handle both/either python2/python3
390# TODO: consider alternatives? -- rex
391rm -fv %{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
392install -p -m755 -D %{SOURCE2} %{buildroot}%{_bindir}/pylupdate5
393install -p -m755 -D %{SOURCE3} %{buildroot}%{_bindir}/pyrcc5
394install -p -m755 -D %{SOURCE4} %{buildroot}%{_bindir}/pyuic5
395sed -i \
396  -e "s|@PYTHON3@|%{__python3}|g" \
397  -e "s|@PYTHON2@|%{__python2}|g" \
398  %{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
399%endif
400
401
402%if 0%{?with_python2}
403%files
404#{python_sitearch}/PyQt5/Enginio.so
405%{python_sitearch}/PyQt5/QtBluetooth.so
406%{python_sitearch}/PyQt5/QtDesigner.so
407%{python_sitearch}/PyQt5/QtHelp.so
408%{python_sitearch}/PyQt5/QtLocation.so
409%{python_sitearch}/PyQt5/QtMultimedia.so
410%{python_sitearch}/PyQt5/QtMultimediaWidgets.so
411%{python_sitearch}/PyQt5/QtNfc.so
412%{python_sitearch}/PyQt5/QtPositioning.so
413%{python_sitearch}/PyQt5/QtQml.so
414%{python_sitearch}/PyQt5/QtQuick.so
415%{python_sitearch}/PyQt5/QtQuickWidgets.so
416%{python_sitearch}/PyQt5/QtSensors.so
417%{python_sitearch}/PyQt5/QtSerialPort.so
418%{python_sitearch}/PyQt5/QtSvg.so
419%{python_sitearch}/PyQt5/QtWebChannel.so
420%{python_sitearch}/PyQt5/QtWebSockets.so
421%{python_sitearch}/PyQt5/QtX11Extras.so
422%{python_sitearch}/PyQt5/QtXmlPatterns.so
423
424%files base
425%doc NEWS README
426%license LICENSE
427%{python_dbus_dir}/pyqt5.so
428%dir %{python_sitearch}/PyQt5/
429%{python_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
430%{python_sitearch}/PyQt5/__init__.py*
431%{python_sitearch}/PyQt5/Qt.so
432%{python_sitearch}/PyQt5/QtCore.so
433%{python_sitearch}/PyQt5/QtDBus.so
434%{python_sitearch}/PyQt5/QtGui.so
435%{python_sitearch}/PyQt5/QtNetwork.so
436%{python_sitearch}/PyQt5/QtOpenGL.so
437%{python_sitearch}/PyQt5/QtPrintSupport.so
438%{python_sitearch}/PyQt5/QtSql.so
439%{python_sitearch}/PyQt5/QtTest.so
440%{python_sitearch}/PyQt5/QtWidgets.so
441%{python_sitearch}/PyQt5/QtXml.so
442%{python_sitearch}/PyQt5/_QOpenGLFunctions_2_0.so
443%{python_sitearch}/PyQt5/_QOpenGLFunctions_2_1.so
444%{python_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.so
445# *was* in -devel
446%{_bindir}/pylupdate5
447%{_bindir}/pyrcc5
448%{_bindir}/pyuic5
449%{python_sitearch}/PyQt5/uic/
450%{python_sitearch}/PyQt5/pylupdate.so
451%{python_sitearch}/PyQt5/pylupdate_main.py*
452%{python_sitearch}/PyQt5/pyrcc.so
453%{python_sitearch}/PyQt5/pyrcc_main.py*
454
455%if 0%{?webengine}
456%files webengine
457%{python_sitearch}/PyQt5/QtWebEngine.*
458%{python_sitearch}/PyQt5/QtWebEngineCore.*
459%{python_sitearch}/PyQt5/QtWebEngineWidgets.*
460%endif
461
462%if 0%{?webkit}
463%files webkit
464%{python_sitearch}/PyQt5/QtWebKit.*
465%{python_sitearch}/PyQt5/QtWebKitWidgets.*
466%endif
467
468%files devel
469%{_datadir}/sip/PyQt5/
470%endif
471
472%files rpm-macros
473%{rpm_macros_dir}/macros.pyqt5
474
475%if 0%{?with_python3}
476%files -n python3-qt5
477#{python3_sitearch}/PyQt5/Enginio.*
478%{python3_sitearch}/PyQt5/QtBluetooth.*
479%{python3_sitearch}/PyQt5/QtDesigner.*
480%{python3_sitearch}/PyQt5/QtHelp.*
481%{python3_sitearch}/PyQt5/QtLocation.*
482%{python3_sitearch}/PyQt5/QtMultimedia.*
483%{python3_sitearch}/PyQt5/QtMultimediaWidgets.*
484%{python3_sitearch}/PyQt5/QtNfc.*
485%{python3_sitearch}/PyQt5/QtPositioning.*
486%{python3_sitearch}/PyQt5/QtQml.*
487%{python3_sitearch}/PyQt5/QtQuick.*
488%{python3_sitearch}/PyQt5/QtQuickWidgets.*
489%{python3_sitearch}/PyQt5/QtSensors.*
490%{python3_sitearch}/PyQt5/QtSerialPort.*
491%{python3_sitearch}/PyQt5/QtSvg.*
492%{python3_sitearch}/PyQt5/QtWebChannel.*
493%{python3_sitearch}/PyQt5/QtWebSockets.*
494%{python3_sitearch}/PyQt5/QtX11Extras.*
495%{python3_sitearch}/PyQt5/QtXmlPatterns.*
496
497%files -n python3-qt5-base
498%doc NEWS README
499%license LICENSE
500%{python3_dbus_dir}/pyqt5.so
501%dir %{python3_sitearch}/PyQt5/
502%{python3_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
503#{python3_sitearch}/PyQt5/__pycache__/__init__.*
504%{python3_sitearch}/PyQt5/__init__.py*
505%{python3_sitearch}/PyQt5/Qt.*
506%{python3_sitearch}/PyQt5/QtCore.*
507%{python3_sitearch}/PyQt5/QtDBus.*
508%{python3_sitearch}/PyQt5/QtGui.*
509%{python3_sitearch}/PyQt5/QtNetwork.*
510%{python3_sitearch}/PyQt5/QtOpenGL.*
511%{python3_sitearch}/PyQt5/QtPrintSupport.*
512%{python3_sitearch}/PyQt5/QtSql.*
513%{python3_sitearch}/PyQt5/QtTest.*
514%{python3_sitearch}/PyQt5/QtWidgets.*
515%{python3_sitearch}/PyQt5/QtXml.*
516%{python3_sitearch}/PyQt5/_QOpenGLFunctions_2_0.*
517%{python3_sitearch}/PyQt5/_QOpenGLFunctions_2_1.*
518%{python3_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.*
519# plugins
520%{_qt5_plugindir}/PyQt5/
521%{_qt5_plugindir}/designer/libpyqt5.so
522%{python3_sitearch}/PyQt5/uic/
523# *was* in python3-qt5-devel
524%{_bindir}/pylupdate5
525%{_bindir}/pyrcc5
526%{_bindir}/pyuic5
527%{python3_sitearch}/PyQt5/pylupdate.so
528%{python3_sitearch}/PyQt5/pylupdate_main.py*
529#{python3_sitearch}/PyQt5/__pycache__/pylupdate_main*
530%{python3_sitearch}/PyQt5/pyrcc.so
531%{python3_sitearch}/PyQt5/pyrcc_main.py*
532#{python3_sitearch}/PyQt5/__pycache__/pyrcc_main*
533
534%if 0%{?webengine}
535%files -n python3-qt5-webengine
536%{python3_sitearch}/PyQt5/QtWebEngine.*
537%{python3_sitearch}/PyQt5/QtWebEngineCore.*
538%{python3_sitearch}/PyQt5/QtWebEngineWidgets.*
539%endif
540
541%if 0%{?webkit}
542%files -n python3-qt5-webkit
543%{python3_sitearch}/PyQt5/QtWebKit.*
544%{python3_sitearch}/PyQt5/QtWebKitWidgets.*
545%endif
546
547%files -n python3-qt5-devel
548%{py3_sipdir}/
549# compat location
550%dir %{_datadir}/python3-sip/
551%{_datadir}/python3-sip/PyQt5/
552%endif # with_python3
553
554%ifarch x86_64
555%files doc
556#doc doc/*
557%doc examples/
558# avoid dep on qscintilla-python, own %%_qt5_datadir/qsci/... here for now
559%dir %{_qt5_datadir}/qsci/
560%dir %{_qt5_datadir}/qsci/api/
561%dir %{_qt5_datadir}/qsci/api/python/
562%doc %{_qt5_datadir}/qsci/api/python/PyQt5.api
563%endif
564
565%changelog
566* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.15.0-4
567- new upstream release.
568- built with python-3.8.
569
570* Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-3
571- rebuilt with qt5-5.12.8.
572
573* Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-2
574- rebuilt with qt5-5.12.7.
575
576* Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-1
577- new upstream release.
578
579* Sat Jan 27 2018 Toshiaki Ara <ara_t@384.jp> - 5.6-7
580- rebuild under current VineSeed
581
582* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6-6
583- initial build for Vine Linux.
584
585* Wed Jul 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-5
586- BR: qt5-qtbase-private-devel
587- python3-qt5: add versioned qt5 dep (like base python-qt5 pkg has)
588
589* Wed Jun 29 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-4
590- rebuild (qt5)
591
592* Wed Jun 15 2016 Than Ngo <than@redhat.com> - 5.6-3
593- drop ppc ppc64 ppc64le, it's not supported yet
594
595* Mon May 02 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-2
596- -rpm-macros: Conflicts: python(3)-qt5 < 5.6
597
598* Mon Apr 25 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-1
599- PyQt5-5.6
600
601* Wed Apr 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-20
602- rebuild (sip), re-enable -webengine for secondary archs
603
604* Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-19
605- limit -webengine support to just primary archs (for now)
606
607* Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-18
608- -rpm-macros subpkg
609
610* Tue Mar 15 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-17
611- rebuild (qt5-qtenginio)
612
613* Mon Mar 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-16
614- -webengine: add ExclusiveArch (matching qt5-qtwebengine's)
615
616* Mon Mar 07 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-15
617- add Obsoletes for misnamed -webengine/-webkit pkgs (#1315025)
618
619* Sat Mar 05 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-14
620- python-qt5 is not built with $RPM_OPT_FLAGS (#1314998)
621
622* Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-13
623- fix python3-qt5-webengine name
624
625* Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-12
626- fix python3-qt5-webkit name
627
628* Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-11
629- use safer subdir builds
630
631* Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-10
632- -webengine,-webkit subpkgs
633
634* Sat Feb 27 2016 Christian Dersch <lupinix@mailbox.org> - 5.5.1-9
635- Enabled QtWebEngine for Fedora >= 24
636
637* Sat Feb 27 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-8
638- rebuild
639
640* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-7
641- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
642
643* Mon Feb 01 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-6
644- explicitly set CFLAGS,CXXFLAGS,LFLAGS
645
646* Wed Jan 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-5
647- %%description: mention PyQt5
648
649* Mon Dec 07 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-4
650- rebuild (qt5), Provides: python2-qt5
651
652* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.5.1-3
653- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
654
655* Mon Nov 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-2
656- rebuild (qt5)
657
658* Mon Oct 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-1
659- 5.5.1
660- enable qtenginio, fix pyuic5 wrapper, use %%license
661
662* Mon Oct 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-2
663- rebuild (qt5)
664
665* Thu Jul 30 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-1
666- 5.5
667
668* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.2-2
669- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
670
671* Fri Jun 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-1
672- 5.4.2
673
674* Fri Jun 05 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-5
675- wrong python release used in pyuic5 launch script (#1193107)
676- -doc: add qsci doc QyQt5.api content
677- enable Qt5WebChannel/Qt5WebSockets support
678
679* Fri Jun 05 2015 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
680- Add patch to fix python3 sip installation dir (#1228432)
681
682* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
683- Rebuilt for GCC 5 C++11 ABI change
684
685* Wed Mar 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-2
686- rebuild (sip)
687
688* Thu Feb 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-1
689- 5.4.1
690
691* Wed Feb 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-6
692- rebuild (sip)
693
694* Tue Jan 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-5
695- +macros.pyqt5
696
697* Fri Jan 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-4
698- -devel: restore dep on base pkg
699
700* Sun Dec 28 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4-3
701- python3-qt5-devel subpkg
702
703* Sat Dec 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-2
704- ensure .so modules are executable (for proper -debuginfo extraction)
705
706* Fri Dec 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-1
707- 5.4
708
709* Thu Nov 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-6
710- restore python3 support
711
712* Tue Nov 11 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-5
713- pkgconfig(QtOpenGL) being satisfied by qt4 devel (#1162415)
714
715* Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-4
716- try to determine dbus-python install paths dynamically (#1161121)
717
718* Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.3.2-3
719- Build failure in sipQtWebKitWidgestQWebInspector: qprinter.h not found (#1160932)
720- python2_sitelib should be python2_sitearch (#1161121)
721
722* Mon Sep 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
723- PyQt-gpl-5.3.2
724
725* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
726- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
727
728* Sun Jul 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.1-1
729- PyQt-gpl-5.3.1
730
731* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3-3
732- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
733
734* Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-2
735- python3: (Build)Requires: python3-dbus
736
737* Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-1
738- PyQt-gpl-5.3
739- +Qt5Bluetooth,Qt5Quick,Qt5SerialPorts support
740
741* Mon May 12 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
742- rebuild (f21-python)
743- +Qt5Positioning,Qt5Sensors support
744
745* Sun Mar 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
746- PyQt-5.2.1
747
748* Sat Mar 08 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.2-5
749- Rebuild against fixed qt5-qtbase to fix -debuginfo (#1065636)
750
751* Sat Feb 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-4
752- python3-qt5 support
753
754* Thu Feb 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-3
755- Provides: PyQt5
756
757* Thu Feb 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-2
758- BR: python2-devel, use %%__python2 macro
759
760* Wed Jan 08 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-1
761- PyQt-5.2
762
Note: See TracBrowser for help on using the repository browser.