source: projects/specs/trunk/p/python-pysocks/python-pysocks-vl.spec @ 11940

Revision 11940, 4.3 KB checked in by tomop, 5 years ago (diff)

python-sphinx-1.7.9-1 and requirements

Line 
1%global pypi_name   PySocks
2%global modname     pysocks
3%global sum         A Python SOCKS client module
4
5Name:               python-%{modname}
6Version:            1.6.8
7Release:            7%{?_dist_release}
8Summary:            %{sum}
9
10License:            BSD
11URL:                https://github.com/Anorov/%{pypi_name}
12
13Vendor:             Project Vine
14Distribution:       Vine Linux
15
16Source0:            https://files.pythonhosted.org/packages/source/P/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
17
18BuildArch:          noarch
19Patch0:             https://github.com/Anorov/PySocks/commit/d74c3f1d34d07a001656453823a153ea0c865449.patch
20
21BuildRequires:      python-devel
22BuildRequires:      python-setuptools
23BuildRequires:      python-rpm-macros
24%{?python_provide:%python_provide python2-%{modname}}
25
26%global _description \
27A fork of SocksiPy with bug fixes and extra features.\
28\
29Acts as a drop-in replacement to the socket module. Featuring:\
30\
31- SOCKS proxy client for Python 2.6 - 3.x\
32- TCP and UDP both supported\
33- HTTP proxy client included but not supported or recommended (you should use\
34  urllib2's or requests' own HTTP proxy interface)\
35- urllib2 handler included.
36
37%description
38%_description
39
40%package -n python3-%{modname}
41Summary:            %{sum}
42BuildRequires:      python3-devel
43BuildRequires:      python3-setuptools
44BuildRequires:      python3-rpm-macros
45%{?python_provide:%python_provide python3-%{modname}}
46
47%description -n python3-%{modname}
48%_description
49This package is for Python3 version %{python3_version} only.
50
51
52%prep
53%autosetup -n %{pypi_name}-%{version}
54# drop useless 3rdparty code
55rm -rfv test/bin
56
57%build
58%py_build
59%py3_build
60
61%install
62%py_install
63%py3_install
64
65%check
66
67
68%files
69%doc README.md
70%license LICENSE
71%{python_sitelib}/socks.py*
72%{python_sitelib}/sockshandler.py*
73%{python_sitelib}/%{pypi_name}-%{version}*
74
75%files -n python3-%{modname}
76%doc README.md
77%license LICENSE
78%{python3_sitelib}/socks.py*
79%{python3_sitelib}/sockshandler.py*
80%{python3_sitelib}/__pycache__/*socks*
81%{python3_sitelib}/%{pypi_name}-%{version}-*
82
83
84%changelog
85* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.6.8-7
86- initial build for Vine Linux.
87
88* Sun Nov 11 2018 Kevin Fenzi <kevin@scrye.com> - 1.6.8-6
89- Add upstream patch to avoid DeprecationWarning. Fixes bug #1648583
90
91* Wed Oct 03 2018 Raphael Groner <projects.rg@smart.ms> - 1.6.8-5
92- add python3_other subpackage for epel7
93- prepare removal of python2 subpackage in Fedora
94- use pypi macros
95- try to enable tests provided actually from tarball
96
97* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.8-4
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
99
100* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.6.8-3
101- Rebuilt for Python 3.7
102
103* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.8-2
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
105
106* Fri Dec 22 2017 Kevin Fenzi <kevin@scrye.com> - 1.6.8-1
107- Update to 1.6.8. Fixes bug #1528490
108
109* Mon Sep 11 2017 Carl George <carl@george.computer> - 1.6.7-1
110- Latest upstream
111- Add setuptools dependency
112
113* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-5
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
115
116* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-4
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
118
119* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.7-3
120- Rebuild for Python 3.6
121
122* Mon Nov 28 2016 Tim Orling <ticotimo@gmail.com> - 1.5.7-2
123- Ship python34-pysocks in EL6
124
125* Sat Sep 17 2016 Kevin Fenzi <kevin@scrye.com> - 1.5.7-1
126- Update to 1.5.7
127
128* Fri Sep 16 2016 Orion Poplawski <orion@cora.nwra.com> - 1.5.6-6
129- Ship python34-pysocks in EPEL7
130
131* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.6-5
132- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
133
134* Fri Jul 15 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-4
135- Change our conflicts on python-SocksiPy to an obsoletes/provides.
136  https://bugzilla.redhat.com/show_bug.cgi?id=1334407
137
138* Mon May 09 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-3
139- Fix typo in explicit conflicts.
140
141* Tue May 03 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-2
142- We don't actually need setuptools here.
143
144* Mon May 02 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-1
145- Initial package for Fedora
Note: See TracBrowser for help on using the repository browser.