source: projects/specs/trunk/p/python-pyrex/python-pyrex-vl.spec @ 8158

Revision 8158, 5.3 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define python_sitelib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
2%define packagename Pyrex
3Name:           python-pyrex
4Version:        0.9.9
5Release:        3%{?_dist_release}
6BuildArch:      noarch
7Summary:        A compiler/language for writing Python extension modules.
8Group:          Development/Languages
9License:        Public Domain
10URL:            http://www.cosc.canterbury.ac.nz/~greg/python/%{packagename}/
11Source0:        http://www.cosc.canterbury.ac.nz/~greg/python/%{packagename}/%{packagename}-%{version}.tar.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14BuildRequires:  python-devel
15BuildRequires:  nkf
16BuildRequires:  findutils
17Requires: python-devel
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23Pyrex is Python with C types.  It is specially designed to allow you to
24write extension modules for Python that have the speed of C and the
25simplicity and readability of Python.  You write your code in a Python-like
26language with C-typed variables, then use the pyrexc compiler to transform
27it into a C representation.  This is useful for speeding up critical sections
28of your Python code or wrapping an external library.
29
30Please see the documentation for how to get the best performance from your
31code.
32
33%prep
34%setup -q -n %{packagename}-%{version}
35
36%build
37python setup.py build
38# Remove some Macintosh-isms
39find . -name '.DS_Store' -exec rm -f \{\} \;
40for i in CHANGES.txt ToDo.txt  Demos/Makefile.nodistutils Tools/*
41do
42  nkf -Lu --in-place $i
43done
44find Doc -type f | xargs nkf -Lu --in-place
45
46%install
47rm -rf $RPM_BUILD_ROOT
48python setup.py install --skip-build --root $RPM_BUILD_ROOT
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(-,root,root,-)
55%doc USAGE.txt README.txt CHANGES.txt ToDo.txt Demos Doc Tools
56%{python_sitelib}/Pyrex*
57%exclude %{python_sitelib}/Pyrex/Mac
58%{_bindir}/pyrexc
59
60%changelog
61* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-3
62- rebuild with VineSeed environment
63
64* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-2
65- rebuild with python-2.7.2
66
67* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-1
68- new upstream release
69
70* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8.4-2
71- rebuild with python-2.6
72
73* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8.4
74- new upstream release
75
76* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.9.3-1vl5
77- rebuilt with python-2.5.2
78- added pythonlib macro
79- applied new versioning policy
80
81* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
82- initial build for Vine Linux
83
84* Tue Mar 22 2005 Jeremy Katz <katzj@redhat.com> - 0.9.3-0
85- update to 0.9.3
86- add patch to fix generated code to build with gcc4
87- require python-abi and python-devel instead of conflicting with
88  newer python-devel
89
90* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0:0.9.2.1-3
91- rebuild against python 2.4
92
93* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9.2.1-2
94- Added Steve Grubb's spec file patch (RH Bug #130200)
95
96* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9.2.1-1
97- New upstream version
98- Pyrex-0.9-split-base-types.patch synced for new version
99
100* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
101- rebuilt
102
103* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-5
104- Built to rawhide
105
106* Wed May 19 2004 Florian La Roche <Florian.LaRoche@redhat.de>
107- use rpm macros to determine lib64 usage
108
109* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-3
110- Added Pyrex-0.9-split-base-types.patch which fixes
111  long unsigned int bug showing up in dbus python binding
112  builds for the x86_64 arch
113- Added regex hack to spec to work around a bug in python's
114  distutils which would install files into /usr/lib instead of
115  /usr/lib64 on 64 bit archs
116 
117* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-2
118- Was informed that the epoch change was not needed so the epoch
119  was reverted back to 0 
120
121* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 1:0.9-1
122- Upped the epoch so as to avoid clashes with the Fedora extra package
123
124* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-1
125- Transfered to Red Hat Fedora's main tree
126- Removed need for LONG_LONG patch
127
128* Mon Feb 02 2004 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.4
129- Removed the site-packages directory from the directories owned by the
130  package
131
132* Mon Feb 02 2004 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.3
133- My mistake: rpm automatically removes %%ghost files, no need to script
134  it manually.
135- python distutils --record=FILE option doesn't record directories so include
136  the site-packages/[directories] manually
137
138* Wed Jan 15 2003 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.2
139- Merge changes from Michel Alexandre Salim <salimma[AT]users.sf.net>
140  + Require build system's python version because directories are named
141    pythonX.Y
142  + Create *.pyo files and %ghost them (Privleged user with python optimize
143    turned on may generate them, but they aren't needed for operation.
144  + Do not include the Mac Pyrex compiler stuff
145  + Change license to Public Domain
146- Script to remove any %%ghost files on package removal
147- Patch around an incompatible change between python 2.2 and python 2.3's
148  definition of LONG_LONG being renamed to PY_LONG_LONG
149 
150* Thu Jan 09 2003 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.1
151- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.