source: projects/specs/trunk/p/python-pycurl/python-pycurl-vl.spec @ 12056

Revision 12056, 6.0 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define modname pycurl
2
3Name:           python-%{modname}
4Version:        7.43.0.2
5Release:        1%{?_dist_release}
6Summary:        A Python interface to libcurl
7Summary(ja):    libcurl の Python インタフェース
8
9Group:          Development/Languages
10License:        LGPLv2+
11URL:            http://pycurl.sourceforge.net/
12Source0:        http://pycurl.sourceforge.net/download/pycurl-%{version}.tar.gz
13# fix programming mistakes detected by static analyzers
14# upstream pull request: https://github.com/pycurl/pycurl/pull/550
15Patch1:         0001-python-pycurl-7.43.0.2-static-analysis.patch
16
17# drop link-time vs. run-time TLS backend check (#1446850)
18Patch2:         0002-python-pycurl-7.43.0-tls-backend.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21
22BuildRequires:  python-devel
23BuildRequires:  python-rpm-macros
24BuildRequires:  curl-devel >= 7.19.0
25BuildRequires:  openssl-devel
26BuildRequires:  openldap-devel
27
28# During its initialization, PycURL checks that the actual libcurl version
29# is not lower than the one used when PycURL was built.
30# Yes, that should be handled by library versioning (which would then get
31# automatically reflected by rpm).
32# For now, we have to reflect that dependency.
33%define libcurl_sed '/^#define LIBCURL_VERSION "/!d;s/"[^"]*$//;s/.*"//;q'
34%define curlver_h /usr/include/curl/curlver.h
35%define libcurl_ver %(sed %{libcurl_sed} %{curlver_h} 2>/dev/null || echo 0)
36Requires:       curl >= %{libcurl_ver}
37
38Provides:       %{modname} = %{version}-%{release}
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44PycURL is a Python interface to libcurl. PycURL can be used to fetch
45objects identified by a URL from a Python program, similar to the
46urllib Python module. PycURL is mature, very fast, and supports a lot
47of features.
48
49
50%package -n python3-%{modname}
51Summary:        A Python3 interface to libcurl
52Summary(ja):    libcurl の Python3 インタフェース
53BuildRequires:  python3-devel
54BuildRequires:  python3-rpm-macros
55
56%description -n python3-%{modname}
57PycURL is a Python interface to libcurl. PycURL can be used to fetch
58objects identified by a URL from a Python program, similar to the
59urllib Python module. PycURL is mature, very fast, and supports a lot
60of features.
61
62
63%prep
64%autosetup -n %{modname}-%{version} -p1
65
66# remove binaries packaged by upstream
67rm -f tests/fake-curl/libcurl/*.so
68
69# remove a test-case that relies on sftp://web.sourceforge.net being available
70rm -f tests/ssh_key_cb_test.py
71
72# remove a test-case that fails in Koji
73rm -f tests/seek_cb_test.py
74
75# remove tests depending on the 'flaky' nose plug-in
76grep '^import flaky' -r tests | cut -d: -f1 | xargs rm -fv
77
78# drop options that are not supported by nose
79sed -e 's/ --show-skipped//' \
80    -e 's/ --with-flaky//' \
81    -i tests/run.sh
82
83%build
84%py_build -- --with-openssl
85%py3_build -- --with-openssl
86
87%check
88#export PYTHONPATH=$PWD/build/lib*
89#%{__python} tests/test_internals.py -q
90
91%install
92rm -rf %{buildroot}
93export PYCURL_SSL_LIBRARY=openssl
94%py_install
95%py3_install
96rm -rf %{buildroot}%{_datadir}/doc/pycurl
97
98
99%clean
100rm -rf %{buildroot}
101
102%files
103%defattr(-,root,root,-)
104%license COPYING-LGPL COPYING-MIT
105%doc ChangeLog README.rst examples doc tests
106%{python_sitearch}/*
107
108%files -n python3-%{modname}
109%defattr(-,root,root,-)
110%license COPYING-LGPL COPYING-MIT
111%doc ChangeLog README.rst examples doc tests
112%{python3_sitearch}/*
113
114%changelog
115* Wed Apr 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0.2-1
116- new upstream release.
117- added python3 support.
118
119* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-5
120- rebuild with VineSeed environment
121
122* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-4
123- rebuild with python-2.7.2
124
125* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 7.19.0-3
126- rebuild with python-2.6
127
128* Sat Aug  8 2009 Shu KONNO <owa@bg.wakwak.com> - 7.19.0-2
129- spec in utf-8
130- added BR: openldap-devel
131
132* Thu Aug  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 7.19.0-1
133- initial build for VineSeed
134
135* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-4
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
137
138* Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-3
139- fix typo in the previous change
140
141* Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-2
142- add a require to reflect a dependency on libcurl version (#496308)
143
144* Thu Mar  5 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.19.0-1
145- Update to 7.19.0
146
147* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.18.2-3
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
149
150* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 7.18.2-2
151- Rebuild for Python 2.6
152
153* Thu Jul  3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.2-1
154- Update to 7.18.2
155- Thanks to Ville Skytt辰 re-enable the tests and fix a minor problem
156  with the setup.py. (Bug # 45400)
157
158* Thu Jun  5 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.1-1
159- Update to 7.18.1
160- Disable tests because it's not testing the built library, it's trying to
161  test an installed library.
162
163* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.16.4-3
164- Autorebuild for GCC 4.3
165
166* Thu Jan  3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-2
167- BR openssl-devel
168
169* Wed Aug 29 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-1
170- Update to 7.16.4
171- Update license tag.
172
173* Sat Jun  9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.2.1-1
174- Update to released version.
175
176* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.0-0.1.20061207
177- Update to a CVS snapshot since development has a newer version of curl than is in FC <= 6
178
179* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-4
180- Add -DHAVE_CURL_OPENSSL to fix PPC build problem.
181
182* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-3
183- Don't forget to Provide: pycurl!!!
184
185* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-2
186- Remove INSTALL from the list of documentation
187- Use python_sitearch for all of the files
188
189* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-1
190- First version for Fedora Extras
Note: See TracBrowser for help on using the repository browser.