source: projects/specs/trunk/p/python-pycurl/python-pycurl-vl.spec @ 8158

Revision 8158, 4.7 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3Name:           python-pycurl
4Version:        7.19.0
5Release:        5%{?_dist_release}
6Summary:        A Python interface to libcurl
7Summary(ja):    libcurl の Python インタフェース
8
9Group:          Development/Languages
10License:        LGPLv2+
11URL:            http://pycurl.sourceforge.net/
12Source0:        http://pycurl.sourceforge.net/download/pycurl-%{version}.tar.gz
13Patch0:         python-pycurl-no-static-libs.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  python-devel
18BuildRequires:  curl-devel >= 7.19.0
19BuildRequires:  openssl-devel
20BuildRequires:  openldap-devel
21
22# During its initialization, PycURL checks that the actual libcurl version
23# is not lower than the one used when PycURL was built.
24# Yes, that should be handled by library versioning (which would then get
25# automatically reflected by rpm).
26# For now, we have to reflect that dependency.
27%define libcurl_sed '/^#define LIBCURL_VERSION "/!d;s/"[^"]*$//;s/.*"//;q'
28%define curlver_h /usr/include/curl/curlver.h
29%define libcurl_ver %(sed %{libcurl_sed} %{curlver_h} 2>/dev/null || echo 0)
30Requires:       curl >= %{libcurl_ver}
31
32Provides:       pycurl = %{version}-%{release}
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38PycURL is a Python interface to libcurl. PycURL can be used to fetch
39objects identified by a URL from a Python program, similar to the
40urllib Python module. PycURL is mature, very fast, and supports a lot
41of features.
42
43%prep
44%setup0 -q -n pycurl-%{version}
45%patch0 -p0
46chmod a-x examples/*
47
48%build
49CFLAGS="$RPM_OPT_FLAGS -DHAVE_CURL_OPENSSL" %{__python} setup.py build
50
51%check
52export PYTHONPATH=$PWD/build/lib*
53%{__python} tests/test_internals.py -q
54
55%install
56rm -rf %{buildroot}
57%{__python} setup.py install -O1 --skip-build --root %{buildroot}
58rm -rf %{buildroot}%{_datadir}/doc/pycurl
59 
60%clean
61rm -rf %{buildroot}
62
63%files
64%defattr(-,root,root,-)
65%doc COPYING ChangeLog README TODO examples doc tests
66%{python_sitearch}/*
67
68%changelog
69* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-5
70- rebuild with VineSeed environment
71
72* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-4
73- rebuild with python-2.7.2
74
75* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 7.19.0-3
76- rebuild with python-2.6
77
78* Sat Aug  8 2009 Shu KONNO <owa@bg.wakwak.com> - 7.19.0-2
79- spec in utf-8
80- added BR: openldap-devel
81
82* Thu Aug  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 7.19.0-1
83- initial build for VineSeed
84
85* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-4
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
87
88* Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-3
89- fix typo in the previous change
90
91* Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-2
92- add a require to reflect a dependency on libcurl version (#496308)
93
94* Thu Mar  5 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.19.0-1
95- Update to 7.19.0
96
97* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.18.2-3
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
99
100* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 7.18.2-2
101- Rebuild for Python 2.6
102
103* Thu Jul  3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.2-1
104- Update to 7.18.2
105- Thanks to Ville Skytt辰 re-enable the tests and fix a minor problem
106  with the setup.py. (Bug # 45400)
107
108* Thu Jun  5 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.1-1
109- Update to 7.18.1
110- Disable tests because it's not testing the built library, it's trying to
111  test an installed library.
112
113* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.16.4-3
114- Autorebuild for GCC 4.3
115
116* Thu Jan  3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-2
117- BR openssl-devel
118
119* Wed Aug 29 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-1
120- Update to 7.16.4
121- Update license tag.
122
123* Sat Jun  9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.2.1-1
124- Update to released version.
125
126* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.0-0.1.20061207
127- Update to a CVS snapshot since development has a newer version of curl than is in FC <= 6
128
129* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-4
130- Add -DHAVE_CURL_OPENSSL to fix PPC build problem.
131
132* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-3
133- Don't forget to Provide: pycurl!!!
134
135* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-2
136- Remove INSTALL from the list of documentation
137- Use python_sitearch for all of the files
138
139* Thu Dec  7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-1
140- First version for Fedora Extras
Note: See TracBrowser for help on using the repository browser.