source: projects/specs/trunk/p/python-pycparser/python-pycparser-vl.spec @ 11921

Revision 11921, 5.9 KB checked in by tomop, 5 years ago (diff)

new: python-cryptography and requirements

Line 
1%global with_python3 1
2
3Name:           python-pycparser
4Summary:        C parser and AST generator written in Python
5Version:        2.19
6Release:        1%{?dist}
7License:        BSD
8Group:          System Environment/Libraries
9URL:            http://github.com/eliben/pycparser
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14Source0:        https://pypi.org/simple/pycparser/pycparser-%{version}.tar.gz
15Source1:        pycparser-0.91.1-remove-relative-sys-path.py
16
17Patch100:       pycparser-2.10-ply.patch
18# This is Fedora-specific; I don't think we should request upstream to
19# remove embedded libraries from their distribuution, when we can remove
20# them during packaging.
21
22BuildArch:      noarch
23
24BuildRequires:  python-devel python-setuptools
25%{?python_provide:%python_provide python-pycparser}
26
27%if 0%{?with_python3}
28BuildRequires:  python3-devel python3-setuptools
29%endif # if with_python3
30
31BuildRequires:  dos2unix
32
33%description
34pycparser is a complete parser for the C language, written in pure Python.
35It is a module designed to be easily integrated into applications that
36need to parse C source code.
37
38%if 0%{?with_python3}
39%package -n python3-pycparser
40Summary:        C parser and AST generator written in Python
41Group:          System Environment/Libraries
42%{?python_provide:%python_provide python3-pycparser}
43
44%description -n python3-pycparser
45pycparser is a complete parser for the C language, written in pure Python.
46It is a module designed to be easily integrated into applications that
47need to parse C source code.
48%endif # if with_python3
49
50%prep
51%setup -q -n pycparser-%{version}
52#patch100 -p1 -F5 -b .ply
53
54# remove embedded copy of ply
55#rm -rf pycparser/ply
56
57# examples
58%{__python} %{SOURCE1} examples
59dos2unix LICENSE
60
61%build
62%py_build
63pushd build/lib/pycparser
64%{__python} _build_tables.py
65popd
66
67%if 0%{?with_python3}
68%py3_build
69pushd build/lib/pycparser
70%{__python3} _build_tables.py
71popd
72%endif # with_python3
73
74%install
75%py_install
76
77%if 0%{?with_python3}
78%py3_install
79%endif # with_python3
80
81%check
82#%{__python2} tests/all_tests.py
83
84%if 0%{?with_python3}
85#%{__python3} tests/all_tests.py
86%endif # with_python3
87 
88%files
89%license LICENSE
90%doc examples
91%{python_sitelib}/pycparser/
92%{python_sitelib}/pycparser-*.egg-info
93
94%if 0%{?with_python3}
95%files -n python3-pycparser
96%license LICENSE
97%doc examples
98%{python3_sitelib}/pycparser/
99%{python3_sitelib}/pycparser-*.egg-info
100%endif # with_python3
101
102%changelog
103* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.19-1
104- initial build for Vine Linux.
105- new upstream release.
106
107* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.14-15
108- Rebuilt for Python 3.7
109
110* Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.14-14
111- Update Python 2 dependency declarations to new packaging standards
112  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
113
114* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.14-13
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
116
117* Wed Sep 27 2017 Troy Dawson <tdawson@redhat.com> - 2.14-12
118- Cleanup spec file conditionals
119
120* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.14-11
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
122
123* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.14-10
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
125
126* Fri Jan 6 2017 Orion Poplawski <orion@cora.nwra.com> - 2.14-9
127- Ship python2-pycparser
128- Modernize spec
129
130* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.14-8
131- Rebuild for Python 3.6
132
133* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14-7
134- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
135
136* Fri Jul  8 2016 Tom Callaway <spot@fedoraproject.org> - 2.14-6
137- rebuild to update yacctab.py
138
139* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.14-5
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
141
142* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 2.14-4
143- Rebuilt for Python3.5 rebuild
144
145* Tue Jul 14 2015 Stephen Gallagher <sgallagh@redhat.com> - 2.14-3
146- Rebuild alongside python-ply 3.6
147
148* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14-2
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
150
151* Tue Jun 09 2015 Nathaniel McCallum <npmccallum@redhat.com> - 2.14-1
152- Update to 2.14
153
154* Wed Aug 20 2014 Eric Smith <brouhaha@fedoraproject.org> 2.10-1
155- Update to latest upstream.
156
157* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.09.1-9
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
159
160* Mon May 12 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.09.1-8
161- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
162
163* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.09.1-7
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
165
166* Tue Jul 23 2013 Eric Smith <brouhaha@fedoraproject.org> 2.09.1-6
167- Added Python 3 support.
168
169* Mon Jul 22 2013 Eric Smith <brouhaha@fedoraproject.org> 2.09.1-5
170- Renumbered Fedora-specific Patch1 to Patch100
171- Added new Patch1 to fix table generation when the build system
172  already has a python-pycparser package installed.
173- Submitted Patch0 and Patch1 as upstream issues.
174- Added comments about patches.
175
176* Sun Jul 21 2013 Eric Smith <brouhaha@fedoraproject.org> 2.09.1-4
177- Upstream repository is now on github.
178- Fix rpmlint strange-permission complaint.
179- Rename patches, Source1 to all start with pycparser-{version}, to
180  simplify updating patches for future upstream releases.
181
182* Sun Jul 21 2013 Eric Smith <brouhaha@fedoraproject.org> 2.09.1-3
183- Run _build_tables.py to build the lextab.py and yacctab.py; otherwise
184  they have to be regenerated at runtime for no benefit.
185
186* Tue Mar 19 2013 Jos de Kloe <josdekloe@gmail.com> 2.09.1-2
187- remove the embedded ply code
188
189* Fri Jan 18 2013 Scott Tsai <scottt.tw@gmail.com> 2.09.1-1
190- upstream 2.09.1
Note: See TracBrowser for help on using the repository browser.