source: projects/specs/trunk/p/python-psycopg2/python-psycopg2-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define zope_product ZPsycopgDA
2%define zope_instance %{_libdir}/zope/lib/python/Products
3
4Summary: psycopg2 is a PostgreSQL database adapter for Python
5Summary(ja): psycopg2 は Python の PostgreSQL 用データベースアダプタです
6Name: python-psycopg2
7Group: Applications/Databases
8Version: 2.0.13
9Release: 1%{?_dist_release}
10License: GNU GPL2
11Source: http://initd.org/pub/software/psycopg/psycopg2-%{version}.tar.gz
12Distribution: Vine Linux
13Vendor: Project Vine
14BuildRoot: %{_tmppath}/psycopg-%{version}-root
15BuildRequires: python-devel postgresql-devel python-egenix-mx-base
16Requires: python postgresql-libs
17
18%description
19psycopg is a PostgreSQL database adapter for the Python programming
20language. This is version 2, a complete rewrite of the original code to
21provide new-style classes for connection and cursor objects and other
22sweet candies. Like the original, psycopg 2 was written with the aim of
23being very small and fast, and stable as a rock.
24
25%package doc
26Summary: Documentation for psycopg python PostgreSQL database adapter
27Group: Applications/Databases
28%description doc
29Documenation and example files for the psycopg python PostgreSQL
30database adapter.
31
32%package ZPsycopgDA
33Summary: ZPsycopgDA is a PostgreSQL database adapter product for Zope
34Group: Development/Web Applications
35Requires: %{name} == %{version}
36Requires: Zope-zserver >= 2.9
37conflicts: Zope-ZPsycopgDA
38%description ZPsycopgDA
39ZPsycopgDA is a PostgreSQL database adapter product for Zope.
40
41
42%prep
43%setup -q -n psycopg2-%{version}
44
45%build
46python setup.py build
47
48
49%install
50python setup.py install --root $RPM_BUILD_ROOT
51mkdir -p $RPM_BUILD_ROOT%{zope_instance}
52find %{zope_product} -name CVS | xargs rm -fr
53cp -pR %{zope_product} $RPM_BUILD_ROOT%{zope_instance}
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%post
59if [ -d /var/lib/zope/Products/%{zope_product} ]; then
60        rm -rf /var/lib/zope/Products/%{zope_product}
61fi
62
63%files
64%defattr(-,root,root)
65%{python_sitearch}/psycopg2
66%{python_sitearch}/psycopg2-%{version}-py%{pyver}.egg-info
67
68%files doc
69%defattr(-,root,root)
70%doc AUTHORS INSTALL README doc
71
72%files ZPsycopgDA
73%defattr(-,zope,zope)
74%{zope_instance}/%{zope_product}
75
76%changelog
77* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.13-1
78- updated psycopg2 to 2.0.13
79
80* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.11-2
81- rebuild with python-2.6
82
83* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0.11-1
84- updated psycopg2 to 2.0.11
85- built with postgresql-8.4.0
86
87* Mon May 04 2009 Shu KONNO <owa@bg.wakwak.com> python-psycopg2-2.0.10-1vl5
88- updated psycopg2 to 2.0.10
89
90* Wed Dec 31 2008 Shu KONNO <owa@bg.wakwak.com> python-psycopg2-2.0.8-1vl5
91- updated psycopg2 to 2.0.8
92
93* Thu Jul 17 2008 Shu KONNO <owa@bg.wakwak.com> python-psycopg2-2.0.7-1vl5
94- packaged new
95
Note: See TracBrowser for help on using the repository browser.