source: projects/specs/trunk/p/python-polib/python-polib-vl.spec @ 8374

Revision 8374, 7.2 KB checked in by Takemikaduchi, 10 years ago (diff)

Cinnamon-2.2.3

Line 
1Name:           python-polib
2Version:        1.0.3
3Release:        1%{?_dist_release}
4Summary:        A library to parse and manage gettext catalogs
5
6Group:          Development/Languages
7License:        MIT
8URL:            http://bitbucket.org/izi/polib/
9Source0:        http://bitbucket.org/izi/polib/downloads/polib-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12BuildArch:      noarch
13BuildRequires:  python-devel
14
15%description
16polib allows you to manipulate, create, modify gettext files (pot, po and
17mo files). You can load existing files, iterate through it's entries, add,
18modify entries, comments or metadata, etc... or create new po files from
19scratch.
20
21polib provides a simple and pythonic API, exporting only three convenience
22functions 'pofile', 'mofile' and 'detect_encoding', and the 4 core classes:
23POFile, MOFile, POEntry and MOEntry for creating new files/entries.
24
25
26%prep
27%setup -q -n polib-%{version}
28
29%build
30%{__python} setup.py build
31
32%check
33%{__python} setup.py check
34
35%install
36rm -rf $RPM_BUILD_ROOT
37%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
38
39%clean
40rm -rf $RPM_BUILD_ROOT
41
42
43%files
44%defattr(-,root,root,-)
45%doc LICENSE README.rst
46%{python_sitelib}/*
47
48
49%changelog
50* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
51- initial build for Vine Linux
52
53
54* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-3
55- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
56
57* Tue Jul 16 2013 Ding-Yi Chen <dchen@redhat.com> - 1.0.3-2
58- Fix the build for EL6 and EL5 (without python3-polib)
59
60* Tue Jul 16 2013 Ding-Yi Chen <dchen@redhat.com> - 1.0.3-1
61- python3 binding is available (python3-polib)
62- Fixed Bug 978672 - This package should be updated.
63- Upstream update to 1.0.3
64- Version 1.0.3 (2013/02/09)
65  Fixed issue #38: POFile.append() raised a duplicate exception when you tried to add a new entry with the same msgid and a different msgctxt (only when check_for_duplicates option is set to True)
66  Fixed issue #39: Added __init__.py file for convenience
67  Fixed issue #41: UnicodeDecodeError when running setup.py build on python3 with C locale
68  polib is now fully PEP8 compliant
69  Small improvements: remove unused "typ" var (thanks Rodrigo Silva), mproved Makefile, Make sure _BaseFile.__contains__ returns a boolean value
70
71- Version 1.0.2 (2012/10/23)
72  allow empty comments, flags or occurences lines
73
74- Version 1.0.1 (2012/09/11)
75  speed up POFile.merge method (thanks @encukou)
76  allow comments starting with two '#' characters (thanks @goibhniu)
77
78* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
79- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
80
81* Mon Jul 30 2012 Ding-Yi Chen <dchen@redhat.com> - 1.0.0-1
82- Upstream update to 1.0.0
83
84* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-4
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
86
87* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-3
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
89
90* Tue Nov 01 2011 Ding-Yi Chen <dchen@redhat.com> - 0.7.0-2
91- Update to upstream commit dbafdc621bf4, which include following:
92  * Add check for unescaped quotes at the beginning of the string + unit tests
93  * Fixed issue #27 (polib didn't check unescaped double quote) + better error handling
94  * Fixed typos in previous commit
95  * Fixed issue #26 IOError when parsing empty comments (thanks Türker Sezer)
96  * Do not hardcode polib version in doc conf
97
98* Fri Oct 28 2011 Ding-Yi Chen <dchen@redhat.com> - 0.7.0-1
99- Correct URLs
100- Replace README with README.rst
101- Update to 0.7.0:
102  From Version 0.7.0 (2011/07/14)
103      This version adds support for python 3 (thanks to Vinay Sajip).
104      polib now supports out-of-the-box any version of python ranging
105      from 2.4 to latest 3.X version.
106  From Version 0.6.4 (2011/07/13)
107      * Better api, autodetected_encoding is no longer required to
108        explicitely set the encoding (fixes issue #23),
109      * Fixed issue #24 Support indented PO files (thanks to
110        François Poirotte).
111  From Version 0.6.3 (2011/02/19)
112      * Fixed issue #19 (Disappearing newline characters due to
113        textwrap module),
114      * ensure wrapping works as expected.
115  From Version 0.6.2 (2011/02/09)
116      * Backported textwrap.TextWrapper._wrap_chunks that has support
117        for the drop_whitespace parameter added in Python 2.6 (Fixes
118        #18: broken compatibility with python 2.5, thanks @jezdez).
119  From Version 0.6.1 (2011/02/09)
120      * fixed regression that prevented POFile initialization from
121        data to work (issue #17).
122  From Version 0.6.0 (2011/02/07)
123      * polib is now fully documented,
124      * switched from doctests to unit tests to keep the polib.py
125        file clean,
126      * fixed issue #7 (wrapping issues, thanks @jezdez),
127      * added a __eq__ method to _BaseFile (thanks @kost BebiX),
128      * handle msgctxt correctly when compiling mo files,
129      * compiled mo files are now exactly the same as those compiled
130        by msgfmt without using hash tables.
131  From Version 0.5.5 (2010/10/30)
132      * Removed multiline handling code, it was a mess and was the
133        source of potential bugs like issue #11,
134      * Fixed typo in README and CHANGELOG, fixes issue #13.
135  From Version 0.5.4 (2010/10/02)
136     * fixed an issue with detect_encoding(), in some cases it could
137       return an invalid charset.
138  From Version 0.5.3 (2010/08/29)
139     * correctly unescape lines containing both \\n and \n
140      (thanks to Martin Geisler),
141     * fixed issue #6: __str__() methods are returning unicode instead
142       of str,
143     * fixed issue #8: POFile.merge error when an entry is obsolete in
144       a .po, that this entry reappears in the .pot and that we merge
145       the two,
146     * added support to instanciate POFile objects using data instead
147       of file path (thanks to Diego Búrigo Zacarão),
148     * fixed issue #9: POFile.merge drop fuzzy attributes from
149       translations (thanks to Tim Gerundt),
150     * fixed issue #10: Finding entries with the same msgid and
151       different context (msgctxt).
152  From Version 0.5.2 (2010/06/09)
153     * fixed issue #1: untranslated_entries() also show fuzzy message,
154     * write back the fuzzy header if present in the pofile,
155     * added support for previous msgctxt, previous msgid and previous
156       msgid_plural comments (fixes issue #5),
157     * better handling of lines wrapping.
158
159* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-3
160- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
161
162* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.5.1-2
163- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
164
165* Mon Dec 14 2009 Diego Búrigo Zacarão <diegobz@gmail.com> - 0.5.1-1
166- Updated to 0.5.1 release
167
168* Wed Aug 19 2009 Diego Búrigo Zacarão <diegobz@gmail.com> - 0.4.2-1
169- Updated to 0.4.2 release
170
171* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2.20080217svnr60
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
173
174* Wed Feb 18 2009 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> 0.4.0-1.20080217svnr60
175- Initial RPM release
176
Note: See TracBrowser for help on using the repository browser.