source: projects/specs/trunk/p/python-pocket-lint/python-pocket-lint-vl.spec @ 4793

Revision 4793, 2.3 KB checked in by kudoh, 13 years ago (diff)

%{!?python_sitelib: %define python_sitelib %(%{python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}

Name: python-pocket-lint
Version: 0.5.21
Release: 1%{?_dist_release}
Summary: Pocket-lint a composite linter and style checker
Summary(ja): ソースコードのコンポジットリンターとスタイルチェッカー Pocket-lint

Group: Development/Languages?
License: MIT
URL:  https://launchpad.net/pocket-lint
Source0:  http://launchpad.net/pocket-lint/trunk/%{version}/+download/pocketlint-%{version}.tar.gz
BuildRoot?: %{_tmppath}/%{name}-%{version}-root

BuildArch?: noarch

BuildRequires?: python-devel
BuildRequires?: python-setuptools

Obsoletes: python-pocketlint

%description
Pocket-lint has several notable features:

  • Provides a consistent report of issues raised by the subordinate checkers.
  • Alternate Reports can be written to change the report, or integrate the report into another application.
  • Supports checking of multiple source types:
    • Python syntax and style
    • Python doctest style
    • XML/HTML style and entities
    • CSS style
    • JavaScript? syntax and style
    • Plain text
  • Supports reporting:
    • Python doctests
    • CSS
    • XML/HTML

%prep
%setup -q -n pocketlint-%{version}

%build
%{python} setup.py build

%install
rm -rf $RPM_BUILD_ROOT
%{python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING ChangeLog? HACKING INSTALL PKG-INFO README
%{_bindir}/pocketlint
%{python_sitelib}/*

%changelog

  • Mon Sep 19 2011 Toshiharu Kudoh <toshi.kd2@…> - 0.5.21-1
  • new upstream release
  • Thu Jun 09 2011 Toshiharu Kudoh <toshi.kd2@…> - 0.5.19-1
  • new upstream release
  • Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@…> - 0.5.17-1
  • new upstream release
  • Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@…> - 0.5.14-1
  • new upstream release
  • changed BuildArch? to noarch
  • Sun Dec 19 2010 Toshiharu Kudoh <toshi.kd2@…> - 0.5.5-1
  • new upstream release
  • Sun Oct 3 2010 Toshiharu Kudoh <toshi.kd2@…> - 0.5.4-3
  • rebuilt with rpm-4.8.1 for pkg-config
  • Tue Aug 17 2010 Toshiharu Kudoh <toshi.kd2@…> - 0.5.4-2
  • changed package name a little
  • Mon Aug 16 2010 Toshiharu Kudoh <toshi.kd2@…> - 0.5.4-1
  • initial build for VineSeed
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name: python-pocket-lint
4Version: 0.5.21
5Release: 1%{?_dist_release}
6Summary: Pocket-lint a composite linter and style checker
7Summary(ja): ソースコードのコンポジットリンターとスタイルチェッカー Pocket-lint
8
9Group: Development/Languages
10License: MIT
11URL: https://launchpad.net/pocket-lint
12Source0: http://launchpad.net/pocket-lint/trunk/%{version}/+download/pocketlint-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildArch: noarch
16
17BuildRequires: python-devel
18BuildRequires: python-setuptools
19
20Obsoletes: python-pocketlint
21
22%description
23Pocket-lint has several notable features:
24
25* Provides a consistent report of issues raised by the subordinate checkers.
26* Alternate Reports can be written to change the report, or integrate the report
27  into another application.
28* Supports checking of multiple source types:
29  * Python syntax and style
30  * Python doctest style
31  * XML/HTML style and entities
32  * CSS style
33  * JavaScript syntax and style
34  * Plain text
35* Supports reporting:
36  * Python doctests
37  * CSS
38  * XML/HTML
39
40
41%prep
42%setup -q -n pocketlint-%{version}
43
44
45%build
46%{__python} setup.py build
47
48
49%install
50rm -rf $RPM_BUILD_ROOT
51%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
52
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57
58%files
59%defattr(-,root,root,-)
60%doc AUTHORS COPYING ChangeLog HACKING INSTALL PKG-INFO README
61%{_bindir}/pocketlint
62%{python_sitelib}/*
63
64
65%changelog
66* Mon Sep 19 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.21-1
67- new upstream release
68
69* Thu Jun 09 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.19-1
70- new upstream release
71
72* Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.17-1
73- new upstream release
74
75* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.14-1
76- new upstream release
77- changed BuildArch to noarch
78
79* Sun Dec 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.5-1
80- new upstream release
81
82* Sun Oct 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-3
83- rebuilt with rpm-4.8.1 for pkg-config
84
85* Tue Aug 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-2
86- changed package name a little
87
88* Mon Aug 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-1
89- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.