source: projects/specs/trunk/p/python-pip/python-pip-vl.spec @ 5701

Revision 5701, 2.5 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%global srcname pip
2
3Summary:        Pip installs Python packages.  An easy_install replacement
4Summary(ja):    Pip は easy_install を置き換える Python パッケージインストーラです。
5Name:           python-%{srcname}
6Version:        0.8.1
7Release:        2%{?_dist_release}
8
9Group:          Development/Libraries
10License:        MIT
11URL:            http://pip.openplans.org
12Source0:        http://pypi.python.org/packages/source/p/pip/%{srcname}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildArch:      noarch
16BuildRequires:  python-devel
17BuildRequires:  python-setuptools
18Requires:       python-setuptools
19
20%description
21
22Pip is a replacement for `easy_install
23<http://peak.telecommunity.com/DevCenter/EasyInstall>`_.  It uses mostly the
24same techniques for finding packages, so packages that were made
25easy_installable should be pip-installable as well.
26
27pip is meant to improve on easy_install.bulletin boards, etc.).
28
29%prep
30%setup -q -n %{srcname}-%{version}
31%{__sed} -i '1d' pip/__init__.py
32
33%build
34%{__python} setup.py build
35
36%install
37%{__rm} -rf %{buildroot}
38%{__python} setup.py install -O1 --skip-build --root %{buildroot}
39%{__rm} -rf %{buildroot}%{_bindir}/pip-*
40mv %{buildroot}%{_bindir}/pip %{buildroot}%{_bindir}/pip-python
41
42%clean
43%{__rm} -rf %{buildroot}
44
45%files
46%defattr(-,root,root,-)
47%doc PKG-INFO docs
48%attr(755,root,root) %{_bindir}/pip-python
49%{python_sitelib}/pip*
50
51%changelog
52* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-2
53- rebuild with python-2.7.2
54
55* Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1
56- updated pip to 0.8.1
57
58* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8-1
59- initial build for Vine Linux
60
61* Mon Aug 30 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.8-1
62- update to 0.8 of pip
63* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.7.2-5
64- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
65
66* Wed Jul 7 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.7.2-1
67- update to 0.7.2 of pip
68* Sun May 23 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.7.1-1
69- update to 0.7.1 of pip
70* Fri Jan 1 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1.4
71- fix dependency issue
72* Tue Dec 18 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1-2
73- fix spec file
74* Mon Dec 17 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1-1
75- upgrade to 0.6.1 of pip
76* Mon Aug 31 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.4-1
77- Initial package
78
Note: See TracBrowser for help on using the repository browser.