source: projects/specs/trunk/p/python-pip/python-pip-vl.spec @ 11272

Revision 11272, 4.9 KB checked in by tomop, 6 years ago (diff)

python-pip-9.0.1-1

Line 
1%bcond_with bootstrap
2%bcond_without python3
3
4%global srcname pip
5
6%global python_wheelname %{srcname}-%{version}-py2.py3-none-any.whl
7%if %{without bootstrap}
8%global python2_wheelname %python_wheelname
9%if %{with python3}
10%global python3_wheelname %python_wheelname
11%endif
12%endif
13
14Summary:        Pip installs Python packages.  An easy_install replacement
15Summary(ja):    Pip は easy_install を置き換える Python パッケージインストーラです。
16Name:           python-%{srcname}
17Version:        9.0.1
18Release:        1%{?_dist_release}
19
20Group:          Development/Libraries
21License:        MIT
22URL:            http://pip.openplans.org
23Source0:        http://pypi.python.org/packages/source/p/pip/%{srcname}-%{version}.tar.gz
24# Patch until the following issue gets implemented upstream:
25# https://github.com/pypa/pip/issues/1351
26Patch0:         allow-stripping-given-prefix-from-wheel-RECORD-files.patch
27
28# Downstream only patch
29# Emit a warning to the user if pip install is run with root privileges
30# Issue upstream: https://github.com/pypa/pip/issues/4288
31Patch1:         emit-a-warning-when-running-with-root-privileges.patch
32BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
33
34BuildArch:      noarch
35BuildRequires:  python-rpm-macros
36BuildRequires:  python3-rpm-macros
37BuildRequires:  python-devel
38BuildRequires:  python-setuptools
39BuildRequires:  python3-devel
40BuildRequires:  python3-setuptools
41Requires:       python-setuptools
42%if %{without bootstrap}
43BuildRequires:  python-pip
44BuildRequires:  python-wheel
45%endif
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51pip is a package management system used to install and manage software packages
52written in Python. Many packages can be found in the Python Package Index
53(PyPI). pip is a recursive acronym that can stand for either "Pip Installs
54Packages" or "Pip Installs Python".
55
56
57%package -n python3-%{srcname}
58Summary:        A tool for installing and managing Python3 packages
59Group:          Development/Libraries
60%if %{without bootstrap}
61BuildRequires:  python3-pip
62BuildRequires:  python3-wheel
63%endif
64Requires:       python3-setuptools
65
66%description -n python3-%{srcname}
67pip is a package management system used to install and manage software packages
68written in Python. Many packages can be found in the Python Package Index
69(PyPI). pip is a recursive acronym that can stand for either "Pip Installs
70Packages" or "Pip Installs Python".
71
72
73%prep
74%setup -q -n %{srcname}-%{version}
75%patch0 -p1
76%patch1 -p1
77
78# Remove ordereddict as it is only required for python <= 2.6
79#rm pip/_vendor/ordereddict.py
80
81%build
82%if %{without bootstrap}
83%py_build_wheel
84%else
85%py_build
86%endif
87
88%if %{with python3}
89%if %{without bootstrap}
90%py3_build_wheel
91%else
92%py3_build
93%endif
94%endif # with python3
95
96
97%install
98%{__rm} -rf %{buildroot}
99
100%if %{with python3}
101%if %{without bootstrap}
102%py3_install_wheel %{python3_wheelname}
103%else
104%py3_install
105%endif
106
107# TODO: we have to remove this by hand now, but it'd be nice if we wouldn't have  to
108# (pip install wheel doesn't overwrite)
109rm %{buildroot}%{_bindir}/pip
110%endif # with python3
111
112%if %{without bootstrap}
113%py_install_wheel %{python_wheelname}
114%else
115%py_install
116%endif
117
118
119%clean
120%{__rm} -rf %{buildroot}
121
122%files
123%defattr(-,root,root,-)
124%license LICENSE.txt
125%doc README.rst docs
126%attr(755,root,root) %{_bindir}/pip
127%attr(755,root,root) %{_bindir}/pip2*
128%{python_sitelib}/pip*
129
130%files -n python3-pip
131%defattr(-,root,root,-)
132%license LICENSE.txt
133%doc README.rst docs
134%attr(755,root,root) %{_bindir}/pip3*
135%{python3_sitelib}/pip*
136
137%changelog
138* Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
139- new upstream release.
140- made to use python{,3}-rpm-macros.
141- added a sub-package for python3.
142
143* Sat Jul 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.6-1
144- new upstream release
145- didn't rename pip to python-pip
146
147* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-3
148- rebuild with VineSeed environment
149
150* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-2
151- rebuild with python-2.7.2
152
153* Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.1-1
154- updated pip to 0.8.1
155
156* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8-1
157- initial build for Vine Linux
158
159* Mon Aug 30 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.8-1
160- update to 0.8 of pip
161* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.7.2-5
162- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
163
164* Wed Jul 7 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.7.2-1
165- update to 0.7.2 of pip
166* Sun May 23 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.7.1-1
167- update to 0.7.1 of pip
168* Fri Jan 1 2010 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1.4
169- fix dependency issue
170* Fri Dec 18 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1-2
171- fix spec file
172* Thu Dec 17 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.6.1-1
173- upgrade to 0.6.1 of pip
174* Mon Aug 31 2009 Peter Halliday <phalliday@excelsiorsystems.net> - 0.4-1
175- Initial package
176
Note: See TracBrowser for help on using the repository browser.