source: projects/specs/trunk/p/python-pillow/python-pillow-vl.spec @ 12469

Revision 12469, 19.6 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global with_python3 1
2%global py3_incdir %(python3 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
3%global py3_libbuilddir %(python3 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
4
5%global srcname pillow
6# bootstrap building docs (pillow is required by docutils, docutils are
7#  required by sphinx; pillow build-requires sphinx)
8%global with_docs 0
9
10Name:           python-%{srcname}
11Version:        7.2.0
12Release:        2%{?_dist_release}
13Summary:        Python image processing library
14Group:          programming
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18# License: see http://www.pythonware.com/products/pil/license.htm
19License:        MIT
20URL:            http://python-pillow.github.io/
21Source0:        https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
22
23BuildRequires:  freetype2-devel
24BuildRequires:  gcc
25BuildRequires:  ghostscript
26BuildRequires:  lcms2-devel
27#BuildRequires:  libimagequant-devel
28BuildRequires:  libjpeg-devel
29#BuildRequires:  libraqm-devel
30BuildRequires:  libtiff-devel
31BuildRequires:  libwebp-devel
32BuildRequires:  openjpeg2-devel
33BuildRequires:  tk-devel
34BuildRequires:  zlib-devel
35
36%if 0%{?with_python3}
37BuildRequires:  python3-rpm-macros
38BuildRequires:  python3-cffi
39BuildRequires:  python3-devel
40BuildRequires:  python3-numpy
41#BuildRequires:  python3-olefile
42BuildRequires:  python3-qt5
43BuildRequires:  python3-setuptools
44%if 0%{?with_docs}
45BuildRequires:  python3-sphinx
46BuildRequires:  python3-sphinx_rtd_theme
47%endif
48BuildRequires:  python3-tkinter
49%endif
50
51%global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
52
53%description
54Python image processing library, fork of the Python Imaging Library (PIL)
55
56This library provides extensive file format support, an efficient
57internal representation, and powerful image processing capabilities.
58
59There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
60devel (development) and doc (documentation).
61
62
63%if 0%{?with_python3}
64%package -n python3-%{srcname}
65Summary:        Python 3 image processing library
66Group:          programming
67Requires:       ghostscript
68%{?python_provide:%python_provide python3-%{srcname}}
69Provides:       python3-imaging = %{version}-%{release}
70
71%description -n python3-%{srcname}
72Python image processing library, fork of the Python Imaging Library (PIL)
73
74This library provides extensive file format support, an efficient
75internal representation, and powerful image processing capabilities.
76
77There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
78devel (development) and doc (documentation).
79
80
81%package -n python3-%{srcname}-devel
82Summary:        Development files for %{srcname}
83Group:          programming
84Requires:       python3-devel, libjpeg-devel, zlib-devel
85Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
86%{?python_provide:%python_provide python3-%{srcname}-devel}
87Provides:       python3-imaging-devel = %{version}-%{release}
88
89%description -n python3-%{srcname}-devel
90Development files for %{srcname}.
91
92
93%package -n python3-%{srcname}-doc
94Summary:        Documentation for %{srcname}
95Group:          documentation
96BuildArch:      noarch
97Requires:       python3-%{srcname} = %{version}-%{release}
98%{?python_provide:%python_provide python3-%{srcname}-doc}
99Provides:       python3-imaging-doc = %{version}-%{release}
100Obsoletes:      python-%{srcname}-doc < 5.4.1-4
101
102%description -n python3-%{srcname}-doc
103Documentation for %{srcname}.
104
105
106%package -n python3-%{srcname}-tk
107Summary:        Tk interface for %{srcname}
108Group:          programming
109Requires:       python3-tkinter
110Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
111%{?python_provide:%python_provide python3-%{srcname}-tk}
112Provides:       python3-imaging-tk = %{version}-%{release}
113
114%description -n python3-%{srcname}-tk
115Tk interface for %{name}.
116
117
118%package -n python3-%{srcname}-qt
119Summary:        Qt %{srcname} image wrapper
120Group:          programming
121Requires:       python3-qt5
122Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
123%{?python_provide:%python_provide python3-%{srcname}-qt}
124Provides:       python3-imaging-qt = %{version}-%{release}
125
126%description -n python3-%{srcname}-qt
127Qt %{srcname} image wrapper.
128%endif
129
130
131%prep
132%autosetup -p1 -n Pillow-%{version}
133
134
135%build
136%if 0%{?with_python3}
137# Build Python 3 modules
138%py3_build
139
140%ifarch x86_64
141%if 0%{?with_docs}
142PYTHONPATH=$PWD/build/%py3_libbuilddir make -C docs html BUILDDIR=_build_py3 SPHINXBUILD=sphinx-build-%python3_version
143rm -f docs/_build_py3/html/.buildinfo
144%endif
145%endif
146%endif
147
148
149%install
150%if 0%{?with_python3}
151# Install Python 3 modules
152install -d %{buildroot}/%{py3_incdir}/Imaging
153install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
154%py3_install
155%endif
156
157
158%check
159%if 0%{?with_python3}
160# Check Python 3 modules
161ln -s $PWD/Images $PWD/build/%py3_libbuilddir/Images
162cp -R $PWD/Tests $PWD/build/%py3_libbuilddir/Tests
163cp -R $PWD/selftest.py $PWD/build/%py3_libbuilddir/selftest.py
164pushd build/%py3_libbuilddir
165PYTHONPATH=$PWD %{__python3} selftest.py
166popd
167%endif
168
169
170%if 0%{?with_python3}
171%files -n python3-%{srcname}
172%doc README.rst CHANGES.rst
173%license docs/COPYING
174%{python3_sitearch}/*
175# These are in subpackages
176%exclude %{python3_sitearch}/PIL/_imagingtk*
177%exclude %{python3_sitearch}/PIL/ImageTk*
178%exclude %{python3_sitearch}/PIL/SpiderImagePlugin*
179%exclude %{python3_sitearch}/PIL/ImageQt*
180%exclude %{python3_sitearch}/PIL/__pycache__/ImageTk*
181%exclude %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
182%exclude %{python3_sitearch}/PIL/__pycache__/ImageQt*
183
184%files -n python3-%{srcname}-devel
185%{py3_incdir}/Imaging/
186
187%ifarch x86_64
188%files -n python3-%{srcname}-doc
189%if 0%{?with_docs}
190%doc docs/_build_py3/html
191%endif
192%endif
193
194%files -n python3-%{srcname}-tk
195%{python3_sitearch}/PIL/_imagingtk*
196%{python3_sitearch}/PIL/ImageTk*
197%{python3_sitearch}/PIL/SpiderImagePlugin*
198%{python3_sitearch}/PIL/__pycache__/ImageTk*
199%{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
200
201%files -n python3-%{srcname}-qt
202%{python3_sitearch}/PIL/ImageQt*
203%{python3_sitearch}/PIL/__pycache__/ImageQt*
204%endif
205
206
207%changelog
208* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-2
209- built with python-3.8.
210
211* Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-1
212- new upstream release.
213- dropped python2 support.
214
215* Wed Jan 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.2-1
216- new upstream release.
217
218* Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
219- initial build for Vine Linux.
220
221* Mon Oct 07 2019 Petr Viktorin <pviktori@redhat.com> - 6.2.0-2
222- Remove optional build dependency on python2-cffi
223
224* Tue Oct 01 2019 Sandro Mani <manisandro@gmail.com> - 6.2.0-1
225- Update to 6.2.0
226
227* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 6.1.0-4
228- Rebuilt for Python 3.8
229
230* Mon Aug 12 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-3
231- Drop python2-pillow-qt, python2-pillow-tk
232
233* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
235
236* Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-1
237- Update to 6.1.0
238
239* Fri May 31 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 6.0.0-2
240- Fix broken Python/C interop on s390x
241
242* Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
243- Update to 6.0.0
244
245* Sun Mar 10 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
246- Drop python2-pillow-doc
247
248* Mon Mar 04 2019 Yatin Karel <ykarel@redhat.com> - 5.4.1-3
249- Fix python3 conditional
250
251* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.1-2
252- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
253
254* Mon Jan 07 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-1
255- Update to 5.4.1
256
257* Mon Oct 01 2018 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
258- Update to 5.3.0
259
260* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
261- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
262
263* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 5.2.0-2
264- Rebuilt for Python 3.7
265
266* Mon Jul 02 2018 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
267- Update to 5.2.0
268
269* Wed Jun 27 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-3
270- Fix the tkinter dependency
271
272* Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-2
273- Rebuilt for Python 3.7
274
275* Wed Apr 25 2018 Sandro Mani <manisandro@gmail.com> - 5.1.1-1
276- Update to 5.1.1
277
278* Thu Apr 05 2018 Sandro Mani <manisandro@gmail.com> - 5.1.0-1
279- Update to 5.1.0
280
281* Wed Mar 07 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-3
282- Add missing BR: gcc
283
284* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
285- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
286
287* Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
288- Update to 5.0.0
289
290* Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
291- Update to 4.3.0
292
293* Tue Sep 05 2017 Troy Dawson <tdawson@redhat.com> - 4.2.1-5
294- Cleanup spec file conditionals
295
296* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
297- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
298
299* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-3
300- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
301
302* Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.2.1-2
303- Rebuild due to bug in RPM (RHBZ #1468476)
304
305* Thu Jul 06 2017 Sandro Mani <manisandro@gmail.com> - 4.2.1-1
306- Update to 4.2.1
307
308* Sat Jul 01 2017 Sandro Mani <manisandro@gmail.com> - 4.2.0-1
309- Update to 4.2.0
310
311* Fri Apr 28 2017 Sandro Mani <manisandro@gmail.com> - 4.1.1-1
312- Update to 4.1.1
313
314* Wed Apr 05 2017 Sandro Mani <manisandro@gmail.com> - 4.1.0-1
315- Update to 4.1.0
316
317* Wed Feb 15 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-3
318- Fix some __pycache__ files in wrong subpackage (#1422606)
319
320* Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-2
321- Rebuild (libwebp)
322
323* Tue Jan 03 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-1
324- Update to 4.0.0
325
326* Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-3
327- Enable docs build
328
329* Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-2
330- Rebuild for Python 3.6
331
332* Wed Oct 19 2016 Sandro Mani <manisandro@gmail.com> - 3.4.2-1
333- Update to 3.4.2
334
335* Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.4.1-1
336- Update to 3.4.1
337
338* Mon Oct 03 2016 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
339- Update to 3.4.0
340
341* Thu Aug 18 2016 Sandro Mani <manisandro@gmail.com> - 3.3.1-1
342- Update  to 3.3.1
343
344* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-2
345- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
346
347* Sat Jul 02 2016 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
348- Update to 3.3.0
349- Modernize spec
350
351* Fri Apr 01 2016 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
352- Update to 3.2.0
353
354* Wed Feb 10 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-3
355- Fix broken python3-pillow package description
356
357* Sun Feb 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.1.1-2
358- Fix provides
359
360* Thu Feb 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-1
361- Update to 3.1.1
362- Fixes CVE-2016-0740, CVE-2016-0775
363
364* Mon Jan 11 2016 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.0-2
365- Fix executable files in doc package bringing in python 2 for the python3 doc
366  packages
367
368* Mon Jan 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
369- Update to 3.1.0
370
371* Tue Dec 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-5
372- Build with docs
373
374* Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-4
375- Rebuilt for libwebp soname bump
376
377* Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-3
378- Rebuilt for Python3.5 rebuild with docs
379
380* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-2
381- Rebuilt for Python3.5 rebuild without docs
382
383* Fri Oct 02 2015 Sandro Mani <manisandro@gmail.com> - 3.0.0-1
384- Update to 3.0.0
385
386* Wed Jul 29 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-2
387- Fix python3-pillow-tk Requires: tkinter -> python3-tkinter (#1248085)
388
389* Thu Jul 02 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-1
390- Update to 2.9.0
391
392* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
393- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
394
395* Mon Jun 08 2015 Sandro Mani <manisandro@gmail.com> - 2.8.2-1
396- Update to 2.8.2
397
398* Thu Apr 02 2015 Sandro Mani <manisandro@gmail.com> - 2.8.1-1
399- Update to 2.8.1
400
401* Wed Apr 01 2015 Sandro Mani <manisandro@gmail.com> - 2.8.0-1
402- Update to 2.8.0
403
404* Mon Jan 12 2015 Sandro Mani <manisandro@gmail.com> - 2.7.0-1
405- Update to 2.7.0
406- Drop sane subpackage, is in python-sane now
407- Fix python3 headers directory
408- Drop Obsoletes: python3-pillow on python3-pillow-qt
409
410* Mon Oct 13 2014 Sandro Mani <manisandro@gmail.com> - 2.6.1-1
411- Update to 2.6.1
412
413* Thu Oct 02 2014 Sandro Mani <manisandro@gmail.com> - 2.6.0-1
414- Update to 2.6.0
415
416* Wed Aug 20 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-3
417- Rebuilding again to resolve transient build error that caused BZ#1131723
418
419* Tue Aug 19 2014 Stephen Gallagher <sgallagh@redhat.com> - 2.5.3-2
420- Rebuilding to resolve transient build error that caused BZ#1131723
421
422* Tue Aug 19 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
423- Update to 2.5.3 (Fix CVE-2014-3598, a DOS in the Jpeg2KImagePlugin)
424
425* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
426- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
427
428* Wed Aug 13 2014 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
429- Update to 2.5.2 (Fix CVE-2014-3589, a DOS in the IcnsImagePlugin)
430
431* Sat Jul 26 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-2
432- Reenable jpeg2k tests on big endian arches
433
434* Tue Jul 15 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-1
435- Update to 2.5.1
436
437* Wed Jul 02 2014 Sandro Mani <manisandro@gmail.com> - 2.5.0-1
438- Update to 2.5.0
439
440* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-11
441- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
442
443* Wed May 28 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-10
444- Rebuild with docs enabled
445- Update python-pillow_openjpeg-2.1.0.patch
446
447* Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-9
448- Rebuild against openjpeg-2.1.0
449
450* Fri May 23 2014 Dan Horák <dan[at]danny.cz> - 2.4.0-8
451- skip jpeg2k tests on big endian arches (#1100762)
452
453* Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.0-7
454- Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
455
456* Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-6
457- Set with_docs to 1 to build docs.
458
459* Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-5
460- Bootstrap building sphinx docs because of circular dependency with sphinx.
461
462* Fri May  9 2014 Orion Poplawski <orion@cora.nwra.com> - 2.4.0-4
463- Rebuild for Python 3.4
464
465* Tue Apr 22 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-3
466- Add patch: Have the tempfile use a suffix with a dot
467
468* Thu Apr 17 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-2
469- Enable Jpeg2000 support
470- Enable webp support also on s390* archs, bug #962091 is now fixed
471- Add upstream patch for ghostscript detection
472
473* Wed Apr 02 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-1
474- Update to 2.4.0
475
476* Wed Mar 19 2014 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
477- Update to 2.3.1 (Fix insecure use of tempfile.mktemp (CVE-2014-1932 CVE-2014-1933))
478
479* Thu Mar 13 2014 Jakub Dorňák <jdornak@redhat.com> - 2.3.0-5
480- python-pillow does not provide python3-imaging
481  (python3-pillow does)
482
483* Tue Jan 07 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-4
484- Add missing ghostscript Requires and BuildRequires
485
486* Mon Jan 06 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
487- Remove python-pillow_help-theme.patch, add python-sphinx-theme-better BR
488
489* Sun Jan 05 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
490- Rebuild with docs enabled
491- Change lcms BR to lcms2
492
493* Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
494- Update to 2.3.0
495- Build with doc disabled to break circular python-pillow -> python-sphinx -> python pillow dependency
496
497* Wed Oct 23 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-2
498- Backport fix for decoding tiffs with correct byteorder, fixes rhbz#1019656
499
500* Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
501- Update to 2.2.1
502- Really enable webp on ppc, but leave disabled on s390
503
504* Thu Aug 29 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-4
505- Add patch to fix incorrect PyArg_ParseTuple tuple signature, fixes rhbz#962091 and rhbz#988767.
506- Renable webp support on bigendian arches
507
508* Wed Aug 28 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-3
509- Add patch to fix memory corruption caused by invalid palette size, see rhbz#1001122
510
511* Tue Jul 30 2013 Karsten Hopp <karsten@redhat.com> 2.1.0-2
512- Build without webp support on ppc* archs (#988767)
513
514* Wed Jul 03 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
515- Update to 2.1.0
516- Run tests in builddir, not installroot
517- Build python3-pillow docs with python3
518- python-pillow_endian.patch upstreamed
519
520* Mon May 13 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-10
521- Build without webp support on s390* archs
522  Resolves: rhbz#962059
523
524* Sat May 11 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-9.gitd1c6db8
525- Conditionaly disable build of python3 parts on RHEL system
526
527* Wed May 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-8.gitd1c6db8
528- Add patch to fix test failure on big-endian
529
530* Thu Apr 25 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.0-7.gitd1c6db8
531- Remove Obsoletes in the python-pillow-qt subpackage. Obsoletes isn't
532  appropriate since qt support didn't exist in the previous python-pillow
533  package so there's no reason to drag in python-pillow-qt when updating
534  python-pillow.
535
536* Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-6.gitd1c6db8
537- Update to latest git
538- python-pillow_quantization.patch now upstream
539- python-pillow_endianness.patch now upstream
540- Add subpackage for ImageQt module, with correct dependencies
541- Add PyQt4 and numpy BR (for generating docs / running tests)
542
543* Mon Apr 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-5.git93a488e
544- Reenable tests on bigendian, add patches for #928927
545
546* Sun Apr 07 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.git93a488e
547- Update to latest git
548- disable tests on bigendian (PPC*, S390*) until rhbz#928927 is fixed
549
550* Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.gitde210a2
551- python-pillow_tempfile.patch now upstream
552- Add python3-imaging provides (bug #924867)
553
554* Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.git2e88848
555- Update to latest git
556- Remove python-pillow-disable-test.patch, gcc is now fixed
557- Add python-pillow_tempfile.patch to prevent a temporary file from getting packaged
558
559* Tue Mar 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.git2f4207c
560- Update to 2.0.0 git snapshot
561- Enable python3 packages
562- Add libwebp-devel BR for Pillow 2.0.0
563
564* Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
565- Add ARM support
566
567* Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
568- add s390* and ppc* to arch detection
569
570* Tue Mar 05 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-4.20130305git7866759
571- Update to latest git snapshot
572- 0001-Cast-hash-table-values-to-unsigned-long.patch now upstream
573- Pillow-1.7.8-selftest.patch now upstream
574
575* Mon Feb 25 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-3.20130210gite09ff61
576- Really remove -fno-strict-aliasing
577- Place comment on how to retreive source just above the Source0 line
578
579* Mon Feb 18 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-2.20130210gite09ff61
580- Rebuild without -fno-strict-aliasing
581- Add patch for upstream issue #52
582
583* Sun Feb 10 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-1.20130210gite09ff61
584- Initial RPM package
Note: See TracBrowser for help on using the repository browser.