source: projects/specs/trunk/p/python-pillow/python-pillow-vl.spec @ 12423

Revision 12423, 19.4 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

OpenEXR-2.4.2-1

pam-1.4.0-1

python-pillow-7.2.0-1

python-qt5-5.12.3-3

sane-1.0.30-1

Line 
1%global with_python3 1
2%global py3_incdir %(python3 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
3%global py3_libbuilddir %(python3 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
4
5%global srcname pillow
6# bootstrap building docs (pillow is required by docutils, docutils are
7#  required by sphinx; pillow build-requires sphinx)
8%global with_docs 0
9
10Name:           python-%{srcname}
11Version:        7.2.0
12Release:        1%{?_dist_release}
13Summary:        Python image processing library
14Group:          Development/Libraries
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18# License: see http://www.pythonware.com/products/pil/license.htm
19License:        MIT
20URL:            http://python-pillow.github.io/
21Source0:        https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
22
23BuildRequires:  freetype2-devel
24BuildRequires:  gcc
25BuildRequires:  ghostscript
26BuildRequires:  lcms2-devel
27#BuildRequires:  libimagequant-devel
28BuildRequires:  libjpeg-devel
29#BuildRequires:  libraqm-devel
30BuildRequires:  libtiff-devel
31BuildRequires:  libwebp-devel
32BuildRequires:  openjpeg2-devel
33BuildRequires:  tk-devel
34BuildRequires:  zlib-devel
35
36BuildRequires:  python-devel
37BuildRequires:  numpy
38#BuildRequires:  python-olefile
39BuildRequires:  python-setuptools
40
41%if 0%{?with_python3}
42BuildRequires:  python3-rpm-macros
43BuildRequires:  python3-cffi
44BuildRequires:  python3-devel
45BuildRequires:  python3-numpy
46#BuildRequires:  python3-olefile
47BuildRequires:  python3-qt5
48BuildRequires:  python3-setuptools
49%if 0%{?with_docs}
50BuildRequires:  python3-sphinx
51BuildRequires:  python3-sphinx_rtd_theme
52%endif
53BuildRequires:  python3-tkinter
54%endif
55
56%global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
57
58%description
59Python image processing library, fork of the Python Imaging Library (PIL)
60
61This library provides extensive file format support, an efficient
62internal representation, and powerful image processing capabilities.
63
64There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
65devel (development) and doc (documentation).
66
67
68%if 0%{?with_python3}
69%package -n python3-%{srcname}
70Summary:        Python 3 image processing library
71Requires:       ghostscript
72%{?python_provide:%python_provide python3-%{srcname}}
73Provides:       python3-imaging = %{version}-%{release}
74
75%description -n python3-%{srcname}
76Python image processing library, fork of the Python Imaging Library (PIL)
77
78This library provides extensive file format support, an efficient
79internal representation, and powerful image processing capabilities.
80
81There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
82devel (development) and doc (documentation).
83
84
85%package -n python3-%{srcname}-devel
86Summary:        Development files for %{srcname}
87Requires:       python3-devel, libjpeg-devel, zlib-devel
88Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
89%{?python_provide:%python_provide python3-%{srcname}-devel}
90Provides:       python3-imaging-devel = %{version}-%{release}
91
92%description -n python3-%{srcname}-devel
93Development files for %{srcname}.
94
95
96%package -n python3-%{srcname}-doc
97Summary:        Documentation for %{srcname}
98BuildArch:      noarch
99Requires:       python3-%{srcname} = %{version}-%{release}
100%{?python_provide:%python_provide python3-%{srcname}-doc}
101Provides:       python3-imaging-doc = %{version}-%{release}
102Obsoletes:      python-%{srcname}-doc < 5.4.1-4
103
104%description -n python3-%{srcname}-doc
105Documentation for %{srcname}.
106
107
108%package -n python3-%{srcname}-tk
109Summary:        Tk interface for %{srcname}
110Requires:       python3-tkinter
111Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
112%{?python_provide:%python_provide python3-%{srcname}-tk}
113Provides:       python3-imaging-tk = %{version}-%{release}
114
115%description -n python3-%{srcname}-tk
116Tk interface for %{name}.
117
118
119%package -n python3-%{srcname}-qt
120Summary:        Qt %{srcname} image wrapper
121Requires:       python3-qt5
122Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
123%{?python_provide:%python_provide python3-%{srcname}-qt}
124Provides:       python3-imaging-qt = %{version}-%{release}
125
126%description -n python3-%{srcname}-qt
127Qt %{srcname} image wrapper.
128%endif
129
130
131%prep
132%autosetup -p1 -n Pillow-%{version}
133
134
135%build
136%if 0%{?with_python3}
137# Build Python 3 modules
138%py3_build
139
140%if 0%{?with_docs}
141PYTHONPATH=$PWD/build/%py3_libbuilddir make -C docs html BUILDDIR=_build_py3 SPHINXBUILD=sphinx-build-%python3_version
142rm -f docs/_build_py3/html/.buildinfo
143%endif
144%endif
145
146
147%install
148%if 0%{?with_python3}
149# Install Python 3 modules
150install -d %{buildroot}/%{py3_incdir}/Imaging
151install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
152%py3_install
153%endif
154
155
156%check
157%if 0%{?with_python3}
158# Check Python 3 modules
159ln -s $PWD/Images $PWD/build/%py3_libbuilddir/Images
160cp -R $PWD/Tests $PWD/build/%py3_libbuilddir/Tests
161cp -R $PWD/selftest.py $PWD/build/%py3_libbuilddir/selftest.py
162pushd build/%py3_libbuilddir
163PYTHONPATH=$PWD %{__python3} selftest.py
164popd
165%endif
166
167
168%if 0%{?with_python3}
169%files -n python3-%{srcname}
170%doc README.rst CHANGES.rst
171%license docs/COPYING
172%{python3_sitearch}/*
173# These are in subpackages
174%exclude %{python3_sitearch}/PIL/_imagingtk*
175%exclude %{python3_sitearch}/PIL/ImageTk*
176%exclude %{python3_sitearch}/PIL/SpiderImagePlugin*
177%exclude %{python3_sitearch}/PIL/ImageQt*
178%exclude %{python3_sitearch}/PIL/__pycache__/ImageTk*
179%exclude %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
180%exclude %{python3_sitearch}/PIL/__pycache__/ImageQt*
181
182%files -n python3-%{srcname}-devel
183%{py3_incdir}/Imaging/
184
185%files -n python3-%{srcname}-doc
186%if 0%{?with_docs}
187%doc docs/_build_py3/html
188%endif
189
190%files -n python3-%{srcname}-tk
191%{python3_sitearch}/PIL/_imagingtk*
192%{python3_sitearch}/PIL/ImageTk*
193%{python3_sitearch}/PIL/SpiderImagePlugin*
194%{python3_sitearch}/PIL/__pycache__/ImageTk*
195%{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
196
197%files -n python3-%{srcname}-qt
198%{python3_sitearch}/PIL/ImageQt*
199%{python3_sitearch}/PIL/__pycache__/ImageQt*
200%endif
201
202
203%changelog
204* Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-1
205- new upstream release.
206- dropped python2 support.
207
208* Wed Jan 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.2-1
209- new upstream release.
210
211* Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
212- initial build for Vine Linux.
213
214* Mon Oct 07 2019 Petr Viktorin <pviktori@redhat.com> - 6.2.0-2
215- Remove optional build dependency on python2-cffi
216
217* Tue Oct 01 2019 Sandro Mani <manisandro@gmail.com> - 6.2.0-1
218- Update to 6.2.0
219
220* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 6.1.0-4
221- Rebuilt for Python 3.8
222
223* Mon Aug 12 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-3
224- Drop python2-pillow-qt, python2-pillow-tk
225
226* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
228
229* Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-1
230- Update to 6.1.0
231
232* Fri May 31 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 6.0.0-2
233- Fix broken Python/C interop on s390x
234
235* Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
236- Update to 6.0.0
237
238* Sun Mar 10 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
239- Drop python2-pillow-doc
240
241* Mon Mar 04 2019 Yatin Karel <ykarel@redhat.com> - 5.4.1-3
242- Fix python3 conditional
243
244* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.1-2
245- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
246
247* Mon Jan 07 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-1
248- Update to 5.4.1
249
250* Mon Oct 01 2018 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
251- Update to 5.3.0
252
253* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
254- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
255
256* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 5.2.0-2
257- Rebuilt for Python 3.7
258
259* Mon Jul 02 2018 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
260- Update to 5.2.0
261
262* Wed Jun 27 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-3
263- Fix the tkinter dependency
264
265* Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-2
266- Rebuilt for Python 3.7
267
268* Wed Apr 25 2018 Sandro Mani <manisandro@gmail.com> - 5.1.1-1
269- Update to 5.1.1
270
271* Thu Apr 05 2018 Sandro Mani <manisandro@gmail.com> - 5.1.0-1
272- Update to 5.1.0
273
274* Wed Mar 07 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-3
275- Add missing BR: gcc
276
277* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
278- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
279
280* Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
281- Update to 5.0.0
282
283* Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
284- Update to 4.3.0
285
286* Tue Sep 05 2017 Troy Dawson <tdawson@redhat.com> - 4.2.1-5
287- Cleanup spec file conditionals
288
289* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
290- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
291
292* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-3
293- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
294
295* Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.2.1-2
296- Rebuild due to bug in RPM (RHBZ #1468476)
297
298* Thu Jul 06 2017 Sandro Mani <manisandro@gmail.com> - 4.2.1-1
299- Update to 4.2.1
300
301* Sat Jul 01 2017 Sandro Mani <manisandro@gmail.com> - 4.2.0-1
302- Update to 4.2.0
303
304* Fri Apr 28 2017 Sandro Mani <manisandro@gmail.com> - 4.1.1-1
305- Update to 4.1.1
306
307* Wed Apr 05 2017 Sandro Mani <manisandro@gmail.com> - 4.1.0-1
308- Update to 4.1.0
309
310* Wed Feb 15 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-3
311- Fix some __pycache__ files in wrong subpackage (#1422606)
312
313* Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-2
314- Rebuild (libwebp)
315
316* Tue Jan 03 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-1
317- Update to 4.0.0
318
319* Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-3
320- Enable docs build
321
322* Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-2
323- Rebuild for Python 3.6
324
325* Wed Oct 19 2016 Sandro Mani <manisandro@gmail.com> - 3.4.2-1
326- Update to 3.4.2
327
328* Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.4.1-1
329- Update to 3.4.1
330
331* Mon Oct 03 2016 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
332- Update to 3.4.0
333
334* Thu Aug 18 2016 Sandro Mani <manisandro@gmail.com> - 3.3.1-1
335- Update  to 3.3.1
336
337* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-2
338- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
339
340* Sat Jul 02 2016 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
341- Update to 3.3.0
342- Modernize spec
343
344* Fri Apr 01 2016 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
345- Update to 3.2.0
346
347* Wed Feb 10 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-3
348- Fix broken python3-pillow package description
349
350* Sun Feb 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.1.1-2
351- Fix provides
352
353* Thu Feb 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-1
354- Update to 3.1.1
355- Fixes CVE-2016-0740, CVE-2016-0775
356
357* Mon Jan 11 2016 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.0-2
358- Fix executable files in doc package bringing in python 2 for the python3 doc
359  packages
360
361* Mon Jan 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
362- Update to 3.1.0
363
364* Tue Dec 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-5
365- Build with docs
366
367* Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-4
368- Rebuilt for libwebp soname bump
369
370* Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-3
371- Rebuilt for Python3.5 rebuild with docs
372
373* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-2
374- Rebuilt for Python3.5 rebuild without docs
375
376* Fri Oct 02 2015 Sandro Mani <manisandro@gmail.com> - 3.0.0-1
377- Update to 3.0.0
378
379* Wed Jul 29 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-2
380- Fix python3-pillow-tk Requires: tkinter -> python3-tkinter (#1248085)
381
382* Thu Jul 02 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-1
383- Update to 2.9.0
384
385* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
386- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
387
388* Mon Jun 08 2015 Sandro Mani <manisandro@gmail.com> - 2.8.2-1
389- Update to 2.8.2
390
391* Thu Apr 02 2015 Sandro Mani <manisandro@gmail.com> - 2.8.1-1
392- Update to 2.8.1
393
394* Wed Apr 01 2015 Sandro Mani <manisandro@gmail.com> - 2.8.0-1
395- Update to 2.8.0
396
397* Mon Jan 12 2015 Sandro Mani <manisandro@gmail.com> - 2.7.0-1
398- Update to 2.7.0
399- Drop sane subpackage, is in python-sane now
400- Fix python3 headers directory
401- Drop Obsoletes: python3-pillow on python3-pillow-qt
402
403* Mon Oct 13 2014 Sandro Mani <manisandro@gmail.com> - 2.6.1-1
404- Update to 2.6.1
405
406* Thu Oct 02 2014 Sandro Mani <manisandro@gmail.com> - 2.6.0-1
407- Update to 2.6.0
408
409* Wed Aug 20 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-3
410- Rebuilding again to resolve transient build error that caused BZ#1131723
411
412* Tue Aug 19 2014 Stephen Gallagher <sgallagh@redhat.com> - 2.5.3-2
413- Rebuilding to resolve transient build error that caused BZ#1131723
414
415* Tue Aug 19 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
416- Update to 2.5.3 (Fix CVE-2014-3598, a DOS in the Jpeg2KImagePlugin)
417
418* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
419- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
420
421* Wed Aug 13 2014 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
422- Update to 2.5.2 (Fix CVE-2014-3589, a DOS in the IcnsImagePlugin)
423
424* Sat Jul 26 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-2
425- Reenable jpeg2k tests on big endian arches
426
427* Tue Jul 15 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-1
428- Update to 2.5.1
429
430* Wed Jul 02 2014 Sandro Mani <manisandro@gmail.com> - 2.5.0-1
431- Update to 2.5.0
432
433* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-11
434- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
435
436* Wed May 28 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-10
437- Rebuild with docs enabled
438- Update python-pillow_openjpeg-2.1.0.patch
439
440* Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-9
441- Rebuild against openjpeg-2.1.0
442
443* Fri May 23 2014 Dan Horák <dan[at]danny.cz> - 2.4.0-8
444- skip jpeg2k tests on big endian arches (#1100762)
445
446* Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.0-7
447- Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
448
449* Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-6
450- Set with_docs to 1 to build docs.
451
452* Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-5
453- Bootstrap building sphinx docs because of circular dependency with sphinx.
454
455* Fri May  9 2014 Orion Poplawski <orion@cora.nwra.com> - 2.4.0-4
456- Rebuild for Python 3.4
457
458* Tue Apr 22 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-3
459- Add patch: Have the tempfile use a suffix with a dot
460
461* Thu Apr 17 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-2
462- Enable Jpeg2000 support
463- Enable webp support also on s390* archs, bug #962091 is now fixed
464- Add upstream patch for ghostscript detection
465
466* Wed Apr 02 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-1
467- Update to 2.4.0
468
469* Wed Mar 19 2014 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
470- Update to 2.3.1 (Fix insecure use of tempfile.mktemp (CVE-2014-1932 CVE-2014-1933))
471
472* Thu Mar 13 2014 Jakub Dorňák <jdornak@redhat.com> - 2.3.0-5
473- python-pillow does not provide python3-imaging
474  (python3-pillow does)
475
476* Tue Jan 07 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-4
477- Add missing ghostscript Requires and BuildRequires
478
479* Mon Jan 06 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
480- Remove python-pillow_help-theme.patch, add python-sphinx-theme-better BR
481
482* Sun Jan 05 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
483- Rebuild with docs enabled
484- Change lcms BR to lcms2
485
486* Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
487- Update to 2.3.0
488- Build with doc disabled to break circular python-pillow -> python-sphinx -> python pillow dependency
489
490* Wed Oct 23 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-2
491- Backport fix for decoding tiffs with correct byteorder, fixes rhbz#1019656
492
493* Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
494- Update to 2.2.1
495- Really enable webp on ppc, but leave disabled on s390
496
497* Thu Aug 29 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-4
498- Add patch to fix incorrect PyArg_ParseTuple tuple signature, fixes rhbz#962091 and rhbz#988767.
499- Renable webp support on bigendian arches
500
501* Wed Aug 28 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-3
502- Add patch to fix memory corruption caused by invalid palette size, see rhbz#1001122
503
504* Tue Jul 30 2013 Karsten Hopp <karsten@redhat.com> 2.1.0-2
505- Build without webp support on ppc* archs (#988767)
506
507* Wed Jul 03 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
508- Update to 2.1.0
509- Run tests in builddir, not installroot
510- Build python3-pillow docs with python3
511- python-pillow_endian.patch upstreamed
512
513* Mon May 13 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-10
514- Build without webp support on s390* archs
515  Resolves: rhbz#962059
516
517* Sat May 11 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-9.gitd1c6db8
518- Conditionaly disable build of python3 parts on RHEL system
519
520* Wed May 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-8.gitd1c6db8
521- Add patch to fix test failure on big-endian
522
523* Thu Apr 25 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.0-7.gitd1c6db8
524- Remove Obsoletes in the python-pillow-qt subpackage. Obsoletes isn't
525  appropriate since qt support didn't exist in the previous python-pillow
526  package so there's no reason to drag in python-pillow-qt when updating
527  python-pillow.
528
529* Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-6.gitd1c6db8
530- Update to latest git
531- python-pillow_quantization.patch now upstream
532- python-pillow_endianness.patch now upstream
533- Add subpackage for ImageQt module, with correct dependencies
534- Add PyQt4 and numpy BR (for generating docs / running tests)
535
536* Mon Apr 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-5.git93a488e
537- Reenable tests on bigendian, add patches for #928927
538
539* Sun Apr 07 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.git93a488e
540- Update to latest git
541- disable tests on bigendian (PPC*, S390*) until rhbz#928927 is fixed
542
543* Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.gitde210a2
544- python-pillow_tempfile.patch now upstream
545- Add python3-imaging provides (bug #924867)
546
547* Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.git2e88848
548- Update to latest git
549- Remove python-pillow-disable-test.patch, gcc is now fixed
550- Add python-pillow_tempfile.patch to prevent a temporary file from getting packaged
551
552* Tue Mar 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.git2f4207c
553- Update to 2.0.0 git snapshot
554- Enable python3 packages
555- Add libwebp-devel BR for Pillow 2.0.0
556
557* Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
558- Add ARM support
559
560* Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
561- add s390* and ppc* to arch detection
562
563* Tue Mar 05 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-4.20130305git7866759
564- Update to latest git snapshot
565- 0001-Cast-hash-table-values-to-unsigned-long.patch now upstream
566- Pillow-1.7.8-selftest.patch now upstream
567
568* Mon Feb 25 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-3.20130210gite09ff61
569- Really remove -fno-strict-aliasing
570- Place comment on how to retreive source just above the Source0 line
571
572* Mon Feb 18 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-2.20130210gite09ff61
573- Rebuild without -fno-strict-aliasing
574- Add patch for upstream issue #52
575
576* Sun Feb 10 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-1.20130210gite09ff61
577- Initial RPM package
Note: See TracBrowser for help on using the repository browser.