source: projects/specs/trunk/p/python-pillow/python-pillow-vl.spec @ 12320

Revision 12320, 21.2 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

clamav-0.102.2-1

dhcpcd-8.1.1-1

dovecot-2.3.9.3-1

golang-1.13.5-1

llvm-9.0.1-1

libjpeg-turbo-2.0.4-1

libserf-1.3.9-2

libxml2-2.9.10-2

mariadb-10.4.12-1

nodejs-12.16.0-1

php-ext-clearsilver-0.4-15

php73-7.3.14-1

python-pillow-6.2.2-1

rust-1.40.0-1

spamassassin-3.4.4-1

sqlite3-3.31.1-1

squid-4.10-1

sudo-1.8.31-1

Line 
1%global py2_incdir %(python2 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
2%global py2_libbuilddir %(python2 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
3
4%global with_python3 1
5%global py3_incdir %(python3 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
6%global py3_libbuilddir %(python3 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
7
8%global srcname pillow
9# bootstrap building docs (pillow is required by docutils, docutils are
10#  required by sphinx; pillow build-requires sphinx)
11%global with_docs 0
12
13Name:           python-%{srcname}
14Version:        6.2.2
15Release:        1%{?_dist_release}
16Summary:        Python image processing library
17Group:          Development/Libraries
18
19Vendor:         Project Vine
20Distribution:   Vine Linux
21
22# License: see http://www.pythonware.com/products/pil/license.htm
23License:        MIT
24URL:            http://python-pillow.github.io/
25Source0:        https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
26
27BuildRequires:  freetype2-devel
28BuildRequires:  gcc
29BuildRequires:  ghostscript
30BuildRequires:  lcms2-devel
31#BuildRequires:  libimagequant-devel
32BuildRequires:  libjpeg-devel
33#BuildRequires:  libraqm-devel
34BuildRequires:  libtiff-devel
35BuildRequires:  libwebp-devel
36BuildRequires:  openjpeg2-devel
37BuildRequires:  tk-devel
38BuildRequires:  zlib-devel
39
40BuildRequires:  python-devel
41BuildRequires:  numpy
42#BuildRequires:  python-olefile
43BuildRequires:  python-setuptools
44
45%if 0%{?with_python3}
46BuildRequires:  python3-rpm-macros
47BuildRequires:  python3-cffi
48BuildRequires:  python3-devel
49BuildRequires:  python3-numpy
50#BuildRequires:  python3-olefile
51BuildRequires:  python3-qt5
52BuildRequires:  python3-setuptools
53%if 0%{?with_docs}
54BuildRequires:  python3-sphinx
55BuildRequires:  python3-sphinx_rtd_theme
56%endif
57BuildRequires:  python3-tkinter
58%endif
59
60# For EpsImagePlugin.py
61Requires:       ghostscript
62%{?python_provide:%python_provide python2-%{srcname}}
63Obsoletes:      python-imaging < 1.2.0
64Provides:       python-imaging = %{version}-%{release}
65Provides:       python2-imaging = %{version}-%{release}
66# For MicImagePlugin.py, FpxImagePlugin.py
67#Requires:       python-olefile
68
69%global __provides_exclude_from ^%{python_sitearch}/PIL/.*\\.so$
70%global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
71
72%description
73Python image processing library, fork of the Python Imaging Library (PIL)
74
75This library provides extensive file format support, an efficient
76internal representation, and powerful image processing capabilities.
77
78There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
79devel (development) and doc (documentation).
80
81
82%package devel
83Summary:        Development files for %{srcname}
84Requires:       python-devel, libjpeg-devel, zlib-devel
85Requires:       python-%{srcname}%{?_isa} = %{version}-%{release}
86%{?python_provide:%python_provide python-%{srcname}-devel}
87Provides:       python-imaging-devel = %{version}-%{release}
88Provides:       python2-imaging-devel = %{version}-%{release}
89
90%description devel
91Development files for %{srcname}.
92
93
94%if 0%{?with_python3}
95%package -n python3-%{srcname}
96Summary:        Python 3 image processing library
97%{?python_provide:%python_provide python3-%{srcname}}
98Provides:       python3-imaging = %{version}-%{release}
99# For MicImagePlugin.py, FpxImagePlugin.py
100#Requires:       python3-olefile
101
102%description -n python3-%{srcname}
103Python image processing library, fork of the Python Imaging Library (PIL)
104
105This library provides extensive file format support, an efficient
106internal representation, and powerful image processing capabilities.
107
108There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
109devel (development) and doc (documentation).
110
111
112%package -n python3-%{srcname}-devel
113Summary:        Development files for %{srcname}
114Requires:       python3-devel, libjpeg-devel, zlib-devel
115Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
116%{?python_provide:%python_provide python3-%{srcname}-devel}
117Provides:       python3-imaging-devel = %{version}-%{release}
118
119%description -n python3-%{srcname}-devel
120Development files for %{srcname}.
121
122
123%package -n python3-%{srcname}-doc
124Summary:        Documentation for %{srcname}
125BuildArch:      noarch
126Requires:       python3-%{srcname} = %{version}-%{release}
127%{?python_provide:%python_provide python3-%{srcname}-doc}
128Provides:       python3-imaging-doc = %{version}-%{release}
129Obsoletes:      python-%{srcname}-doc < 5.4.1-4
130
131%description -n python3-%{srcname}-doc
132Documentation for %{srcname}.
133
134
135%package -n python3-%{srcname}-tk
136Summary:        Tk interface for %{srcname}
137Requires:       python3-tkinter
138Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
139%{?python_provide:%python_provide python3-%{srcname}-tk}
140Provides:       python3-imaging-tk = %{version}-%{release}
141
142%description -n python3-%{srcname}-tk
143Tk interface for %{name}.
144
145
146%package -n python3-%{srcname}-qt
147Summary:        Qt %{srcname} image wrapper
148Requires:       python3-qt5
149Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
150%{?python_provide:%python_provide python3-%{srcname}-qt}
151Provides:       python3-imaging-qt = %{version}-%{release}
152
153%description -n python3-%{srcname}-qt
154Qt %{srcname} image wrapper.
155%endif
156
157
158%prep
159%autosetup -p1 -n Pillow-%{version}
160
161
162%build
163# Build Python 2 modules
164%py_build
165
166%if 0%{?with_python3}
167# Build Python 3 modules
168%py3_build
169
170%if 0%{?with_docs}
171PYTHONPATH=$PWD/build/%py3_libbuilddir make -C docs html BUILDDIR=_build_py3 SPHINXBUILD=sphinx-build-%python3_version
172rm -f docs/_build_py3/html/.buildinfo
173%endif
174%endif
175
176
177%install
178# Install Python 2 modules
179install -d %{buildroot}/%{py2_incdir}/Imaging
180install -m 644 src/libImaging/*.h %{buildroot}/%{py2_incdir}/Imaging
181%py_install
182
183%if 0%{?with_python3}
184# Install Python 3 modules
185install -d %{buildroot}/%{py3_incdir}/Imaging
186install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
187%py3_install
188%endif
189
190
191%check
192# Check Python 2 modules
193ln -s $PWD/Images $PWD/build/%py2_libbuilddir/Images
194cp -R $PWD/Tests $PWD/build/%py2_libbuilddir/Tests
195cp -R $PWD/selftest.py $PWD/build/%py2_libbuilddir/selftest.py
196pushd build/%py2_libbuilddir
197PYTHONPATH=$PWD %{__python} selftest.py
198popd
199
200%if 0%{?with_python3}
201# Check Python 3 modules
202ln -s $PWD/Images $PWD/build/%py3_libbuilddir/Images
203cp -R $PWD/Tests $PWD/build/%py3_libbuilddir/Tests
204cp -R $PWD/selftest.py $PWD/build/%py3_libbuilddir/selftest.py
205pushd build/%py3_libbuilddir
206PYTHONPATH=$PWD %{__python3} selftest.py
207popd
208%endif
209
210
211%files
212%doc README.rst CHANGES.rst
213%license docs/COPYING
214%{python_sitearch}/*
215# These are in subpackages
216%exclude %{python_sitearch}/PIL/_imagingtk*
217%exclude %{python_sitearch}/PIL/ImageTk*
218%exclude %{python_sitearch}/PIL/SpiderImagePlugin*
219%exclude %{python_sitearch}/PIL/ImageQt*
220
221%files devel
222%{py2_incdir}/Imaging/
223
224%if 0%{?with_python3}
225%files -n python3-%{srcname}
226%doc README.rst CHANGES.rst
227%license docs/COPYING
228%{python3_sitearch}/*
229# These are in subpackages
230%exclude %{python3_sitearch}/PIL/_imagingtk*
231%exclude %{python3_sitearch}/PIL/ImageTk*
232%exclude %{python3_sitearch}/PIL/SpiderImagePlugin*
233%exclude %{python3_sitearch}/PIL/ImageQt*
234%exclude %{python3_sitearch}/PIL/__pycache__/ImageTk*
235%exclude %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
236%exclude %{python3_sitearch}/PIL/__pycache__/ImageQt*
237
238%files -n python3-%{srcname}-devel
239%{py3_incdir}/Imaging/
240
241%files -n python3-%{srcname}-doc
242%if 0%{?with_docs}
243%doc docs/_build_py3/html
244%endif
245
246%files -n python3-%{srcname}-tk
247%{python3_sitearch}/PIL/_imagingtk*
248%{python3_sitearch}/PIL/ImageTk*
249%{python3_sitearch}/PIL/SpiderImagePlugin*
250%{python3_sitearch}/PIL/__pycache__/ImageTk*
251%{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
252
253%files -n python3-%{srcname}-qt
254%{python3_sitearch}/PIL/ImageQt*
255%{python3_sitearch}/PIL/__pycache__/ImageQt*
256%endif
257
258
259%changelog
260* Wed Jan 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.2-1
261- new upstream release.
262
263* Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
264- initial build for Vine Linux.
265
266* Mon Oct 07 2019 Petr Viktorin <pviktori@redhat.com> - 6.2.0-2
267- Remove optional build dependency on python2-cffi
268
269* Tue Oct 01 2019 Sandro Mani <manisandro@gmail.com> - 6.2.0-1
270- Update to 6.2.0
271
272* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 6.1.0-4
273- Rebuilt for Python 3.8
274
275* Mon Aug 12 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-3
276- Drop python2-pillow-qt, python2-pillow-tk
277
278* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
279- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
280
281* Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-1
282- Update to 6.1.0
283
284* Fri May 31 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 6.0.0-2
285- Fix broken Python/C interop on s390x
286
287* Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
288- Update to 6.0.0
289
290* Sun Mar 10 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
291- Drop python2-pillow-doc
292
293* Mon Mar 04 2019 Yatin Karel <ykarel@redhat.com> - 5.4.1-3
294- Fix python3 conditional
295
296* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.1-2
297- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
298
299* Mon Jan 07 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-1
300- Update to 5.4.1
301
302* Mon Oct 01 2018 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
303- Update to 5.3.0
304
305* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
306- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
307
308* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 5.2.0-2
309- Rebuilt for Python 3.7
310
311* Mon Jul 02 2018 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
312- Update to 5.2.0
313
314* Wed Jun 27 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-3
315- Fix the tkinter dependency
316
317* Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-2
318- Rebuilt for Python 3.7
319
320* Wed Apr 25 2018 Sandro Mani <manisandro@gmail.com> - 5.1.1-1
321- Update to 5.1.1
322
323* Thu Apr 05 2018 Sandro Mani <manisandro@gmail.com> - 5.1.0-1
324- Update to 5.1.0
325
326* Wed Mar 07 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-3
327- Add missing BR: gcc
328
329* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
330- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
331
332* Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
333- Update to 5.0.0
334
335* Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
336- Update to 4.3.0
337
338* Tue Sep 05 2017 Troy Dawson <tdawson@redhat.com> - 4.2.1-5
339- Cleanup spec file conditionals
340
341* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
342- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
343
344* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-3
345- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
346
347* Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.2.1-2
348- Rebuild due to bug in RPM (RHBZ #1468476)
349
350* Thu Jul 06 2017 Sandro Mani <manisandro@gmail.com> - 4.2.1-1
351- Update to 4.2.1
352
353* Sat Jul 01 2017 Sandro Mani <manisandro@gmail.com> - 4.2.0-1
354- Update to 4.2.0
355
356* Fri Apr 28 2017 Sandro Mani <manisandro@gmail.com> - 4.1.1-1
357- Update to 4.1.1
358
359* Wed Apr 05 2017 Sandro Mani <manisandro@gmail.com> - 4.1.0-1
360- Update to 4.1.0
361
362* Wed Feb 15 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-3
363- Fix some __pycache__ files in wrong subpackage (#1422606)
364
365* Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-2
366- Rebuild (libwebp)
367
368* Tue Jan 03 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-1
369- Update to 4.0.0
370
371* Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-3
372- Enable docs build
373
374* Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-2
375- Rebuild for Python 3.6
376
377* Wed Oct 19 2016 Sandro Mani <manisandro@gmail.com> - 3.4.2-1
378- Update to 3.4.2
379
380* Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.4.1-1
381- Update to 3.4.1
382
383* Mon Oct 03 2016 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
384- Update to 3.4.0
385
386* Thu Aug 18 2016 Sandro Mani <manisandro@gmail.com> - 3.3.1-1
387- Update  to 3.3.1
388
389* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-2
390- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
391
392* Sat Jul 02 2016 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
393- Update to 3.3.0
394- Modernize spec
395
396* Fri Apr 01 2016 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
397- Update to 3.2.0
398
399* Wed Feb 10 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-3
400- Fix broken python3-pillow package description
401
402* Sun Feb 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.1.1-2
403- Fix provides
404
405* Thu Feb 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-1
406- Update to 3.1.1
407- Fixes CVE-2016-0740, CVE-2016-0775
408
409* Mon Jan 11 2016 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.0-2
410- Fix executable files in doc package bringing in python 2 for the python3 doc
411  packages
412
413* Mon Jan 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
414- Update to 3.1.0
415
416* Tue Dec 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-5
417- Build with docs
418
419* Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-4
420- Rebuilt for libwebp soname bump
421
422* Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-3
423- Rebuilt for Python3.5 rebuild with docs
424
425* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-2
426- Rebuilt for Python3.5 rebuild without docs
427
428* Fri Oct 02 2015 Sandro Mani <manisandro@gmail.com> - 3.0.0-1
429- Update to 3.0.0
430
431* Wed Jul 29 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-2
432- Fix python3-pillow-tk Requires: tkinter -> python3-tkinter (#1248085)
433
434* Thu Jul 02 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-1
435- Update to 2.9.0
436
437* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
438- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
439
440* Mon Jun 08 2015 Sandro Mani <manisandro@gmail.com> - 2.8.2-1
441- Update to 2.8.2
442
443* Thu Apr 02 2015 Sandro Mani <manisandro@gmail.com> - 2.8.1-1
444- Update to 2.8.1
445
446* Wed Apr 01 2015 Sandro Mani <manisandro@gmail.com> - 2.8.0-1
447- Update to 2.8.0
448
449* Mon Jan 12 2015 Sandro Mani <manisandro@gmail.com> - 2.7.0-1
450- Update to 2.7.0
451- Drop sane subpackage, is in python-sane now
452- Fix python3 headers directory
453- Drop Obsoletes: python3-pillow on python3-pillow-qt
454
455* Mon Oct 13 2014 Sandro Mani <manisandro@gmail.com> - 2.6.1-1
456- Update to 2.6.1
457
458* Thu Oct 02 2014 Sandro Mani <manisandro@gmail.com> - 2.6.0-1
459- Update to 2.6.0
460
461* Wed Aug 20 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-3
462- Rebuilding again to resolve transient build error that caused BZ#1131723
463
464* Tue Aug 19 2014 Stephen Gallagher <sgallagh@redhat.com> - 2.5.3-2
465- Rebuilding to resolve transient build error that caused BZ#1131723
466
467* Tue Aug 19 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
468- Update to 2.5.3 (Fix CVE-2014-3598, a DOS in the Jpeg2KImagePlugin)
469
470* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
471- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
472
473* Wed Aug 13 2014 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
474- Update to 2.5.2 (Fix CVE-2014-3589, a DOS in the IcnsImagePlugin)
475
476* Sat Jul 26 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-2
477- Reenable jpeg2k tests on big endian arches
478
479* Tue Jul 15 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-1
480- Update to 2.5.1
481
482* Wed Jul 02 2014 Sandro Mani <manisandro@gmail.com> - 2.5.0-1
483- Update to 2.5.0
484
485* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-11
486- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
487
488* Wed May 28 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-10
489- Rebuild with docs enabled
490- Update python-pillow_openjpeg-2.1.0.patch
491
492* Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-9
493- Rebuild against openjpeg-2.1.0
494
495* Fri May 23 2014 Dan Horák <dan[at]danny.cz> - 2.4.0-8
496- skip jpeg2k tests on big endian arches (#1100762)
497
498* Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.0-7
499- Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
500
501* Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-6
502- Set with_docs to 1 to build docs.
503
504* Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-5
505- Bootstrap building sphinx docs because of circular dependency with sphinx.
506
507* Fri May  9 2014 Orion Poplawski <orion@cora.nwra.com> - 2.4.0-4
508- Rebuild for Python 3.4
509
510* Tue Apr 22 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-3
511- Add patch: Have the tempfile use a suffix with a dot
512
513* Thu Apr 17 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-2
514- Enable Jpeg2000 support
515- Enable webp support also on s390* archs, bug #962091 is now fixed
516- Add upstream patch for ghostscript detection
517
518* Wed Apr 02 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-1
519- Update to 2.4.0
520
521* Wed Mar 19 2014 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
522- Update to 2.3.1 (Fix insecure use of tempfile.mktemp (CVE-2014-1932 CVE-2014-1933))
523
524* Thu Mar 13 2014 Jakub Dorňák <jdornak@redhat.com> - 2.3.0-5
525- python-pillow does not provide python3-imaging
526  (python3-pillow does)
527
528* Tue Jan 07 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-4
529- Add missing ghostscript Requires and BuildRequires
530
531* Mon Jan 06 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
532- Remove python-pillow_help-theme.patch, add python-sphinx-theme-better BR
533
534* Sun Jan 05 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
535- Rebuild with docs enabled
536- Change lcms BR to lcms2
537
538* Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
539- Update to 2.3.0
540- Build with doc disabled to break circular python-pillow -> python-sphinx -> python pillow dependency
541
542* Wed Oct 23 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-2
543- Backport fix for decoding tiffs with correct byteorder, fixes rhbz#1019656
544
545* Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
546- Update to 2.2.1
547- Really enable webp on ppc, but leave disabled on s390
548
549* Thu Aug 29 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-4
550- Add patch to fix incorrect PyArg_ParseTuple tuple signature, fixes rhbz#962091 and rhbz#988767.
551- Renable webp support on bigendian arches
552
553* Wed Aug 28 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-3
554- Add patch to fix memory corruption caused by invalid palette size, see rhbz#1001122
555
556* Tue Jul 30 2013 Karsten Hopp <karsten@redhat.com> 2.1.0-2
557- Build without webp support on ppc* archs (#988767)
558
559* Wed Jul 03 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
560- Update to 2.1.0
561- Run tests in builddir, not installroot
562- Build python3-pillow docs with python3
563- python-pillow_endian.patch upstreamed
564
565* Mon May 13 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-10
566- Build without webp support on s390* archs
567  Resolves: rhbz#962059
568
569* Sat May 11 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-9.gitd1c6db8
570- Conditionaly disable build of python3 parts on RHEL system
571
572* Wed May 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-8.gitd1c6db8
573- Add patch to fix test failure on big-endian
574
575* Thu Apr 25 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.0-7.gitd1c6db8
576- Remove Obsoletes in the python-pillow-qt subpackage. Obsoletes isn't
577  appropriate since qt support didn't exist in the previous python-pillow
578  package so there's no reason to drag in python-pillow-qt when updating
579  python-pillow.
580
581* Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-6.gitd1c6db8
582- Update to latest git
583- python-pillow_quantization.patch now upstream
584- python-pillow_endianness.patch now upstream
585- Add subpackage for ImageQt module, with correct dependencies
586- Add PyQt4 and numpy BR (for generating docs / running tests)
587
588* Mon Apr 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-5.git93a488e
589- Reenable tests on bigendian, add patches for #928927
590
591* Sun Apr 07 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.git93a488e
592- Update to latest git
593- disable tests on bigendian (PPC*, S390*) until rhbz#928927 is fixed
594
595* Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.gitde210a2
596- python-pillow_tempfile.patch now upstream
597- Add python3-imaging provides (bug #924867)
598
599* Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.git2e88848
600- Update to latest git
601- Remove python-pillow-disable-test.patch, gcc is now fixed
602- Add python-pillow_tempfile.patch to prevent a temporary file from getting packaged
603
604* Tue Mar 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.git2f4207c
605- Update to 2.0.0 git snapshot
606- Enable python3 packages
607- Add libwebp-devel BR for Pillow 2.0.0
608
609* Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
610- Add ARM support
611
612* Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
613- add s390* and ppc* to arch detection
614
615* Tue Mar 05 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-4.20130305git7866759
616- Update to latest git snapshot
617- 0001-Cast-hash-table-values-to-unsigned-long.patch now upstream
618- Pillow-1.7.8-selftest.patch now upstream
619
620* Mon Feb 25 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-3.20130210gite09ff61
621- Really remove -fno-strict-aliasing
622- Place comment on how to retreive source just above the Source0 line
623
624* Mon Feb 18 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-2.20130210gite09ff61
625- Rebuild without -fno-strict-aliasing
626- Add patch for upstream issue #52
627
628* Sun Feb 10 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-1.20130210gite09ff61
629- Initial RPM package
Note: See TracBrowser for help on using the repository browser.