source: projects/specs/trunk/p/python-pillow/python-pillow-vl.spec @ 12521

Revision 12521, 19.7 KB checked in by tomop, 3 years ago (diff)

updated 11 packages

dnsmasq-2.84-1

firefox-78.7.0-1

kernel-5.4.93-1

libmaxminddb-1.5.0-1

nsd-4.3.5-1

openldap-2.4.57-1

python-pillow-8.1.0-1

rust-1.49.0-1

samba-4.13.4-1

sudo-1.9.5p2-1

thunderbird-78.7.0-1

Line 
1%global with_python3 1
2%global py3_incdir %(python3 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
3%global py3_libbuilddir %(python3 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
4
5%global srcname pillow
6# bootstrap building docs (pillow is required by docutils, docutils are
7#  required by sphinx; pillow build-requires sphinx)
8%global with_docs 0
9
10Name:           python-%{srcname}
11Version:        8.1.0
12Release:        1%{?_dist_release}
13Summary:        Python image processing library
14Group:          programming
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18# License: see http://www.pythonware.com/products/pil/license.htm
19License:        MIT
20URL:            http://python-pillow.github.io/
21Source0:        https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
22
23BuildRequires:  freetype2-devel
24BuildRequires:  gcc
25BuildRequires:  ghostscript
26BuildRequires:  lcms2-devel
27#BuildRequires:  libimagequant-devel
28BuildRequires:  libjpeg-devel
29#BuildRequires:  libraqm-devel
30BuildRequires:  libtiff-devel
31BuildRequires:  libwebp-devel
32BuildRequires:  openjpeg2-devel
33BuildRequires:  tk-devel
34BuildRequires:  zlib-devel
35
36%if 0%{?with_python3}
37BuildRequires:  python3-rpm-macros
38BuildRequires:  python3-cffi
39BuildRequires:  python3-devel
40BuildRequires:  python3-numpy
41#BuildRequires:  python3-olefile
42BuildRequires:  python3-qt5
43BuildRequires:  python3-setuptools
44%if 0%{?with_docs}
45BuildRequires:  python3-sphinx
46BuildRequires:  python3-sphinx_rtd_theme
47%endif
48BuildRequires:  python3-tkinter
49%endif
50
51%global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
52
53%description
54Python image processing library, fork of the Python Imaging Library (PIL)
55
56This library provides extensive file format support, an efficient
57internal representation, and powerful image processing capabilities.
58
59There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
60devel (development) and doc (documentation).
61
62
63%if 0%{?with_python3}
64%package -n python3-%{srcname}
65Summary:        Python 3 image processing library
66Group:          programming
67Requires:       ghostscript
68%{?python_provide:%python_provide python3-%{srcname}}
69Provides:       python3-imaging = %{version}-%{release}
70
71%description -n python3-%{srcname}
72Python image processing library, fork of the Python Imaging Library (PIL)
73
74This library provides extensive file format support, an efficient
75internal representation, and powerful image processing capabilities.
76
77There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
78devel (development) and doc (documentation).
79
80
81%package -n python3-%{srcname}-devel
82Summary:        Development files for %{srcname}
83Group:          programming
84Requires:       python3-devel, libjpeg-devel, zlib-devel
85Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
86%{?python_provide:%python_provide python3-%{srcname}-devel}
87Provides:       python3-imaging-devel = %{version}-%{release}
88
89%description -n python3-%{srcname}-devel
90Development files for %{srcname}.
91
92
93%package -n python3-%{srcname}-doc
94Summary:        Documentation for %{srcname}
95Group:          documentation
96BuildArch:      noarch
97Requires:       python3-%{srcname} = %{version}-%{release}
98%{?python_provide:%python_provide python3-%{srcname}-doc}
99Provides:       python3-imaging-doc = %{version}-%{release}
100Obsoletes:      python-%{srcname}-doc < 5.4.1-4
101
102%description -n python3-%{srcname}-doc
103Documentation for %{srcname}.
104
105
106%package -n python3-%{srcname}-tk
107Summary:        Tk interface for %{srcname}
108Group:          programming
109Requires:       python3-tkinter
110Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
111%{?python_provide:%python_provide python3-%{srcname}-tk}
112Provides:       python3-imaging-tk = %{version}-%{release}
113
114%description -n python3-%{srcname}-tk
115Tk interface for %{name}.
116
117
118%package -n python3-%{srcname}-qt
119Summary:        Qt %{srcname} image wrapper
120Group:          programming
121Requires:       python3-qt5
122Requires:       python3-%{srcname}%{?_isa} = %{version}-%{release}
123%{?python_provide:%python_provide python3-%{srcname}-qt}
124Provides:       python3-imaging-qt = %{version}-%{release}
125
126%description -n python3-%{srcname}-qt
127Qt %{srcname} image wrapper.
128%endif
129
130
131%debug_package
132
133
134%prep
135%autosetup -p1 -n Pillow-%{version}
136
137
138%build
139%if 0%{?with_python3}
140# Build Python 3 modules
141%py3_build
142
143%ifarch x86_64
144%if 0%{?with_docs}
145PYTHONPATH=$PWD/build/%py3_libbuilddir make -C docs html BUILDDIR=_build_py3 SPHINXBUILD=sphinx-build-%python3_version
146rm -f docs/_build_py3/html/.buildinfo
147%endif
148%endif
149%endif
150
151
152%install
153%if 0%{?with_python3}
154# Install Python 3 modules
155install -d %{buildroot}/%{py3_incdir}/Imaging
156install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
157%py3_install
158%endif
159
160
161%check
162%if 0%{?with_python3}
163# Check Python 3 modules
164ln -s $PWD/Images $PWD/build/%py3_libbuilddir/Images
165cp -R $PWD/Tests $PWD/build/%py3_libbuilddir/Tests
166cp -R $PWD/selftest.py $PWD/build/%py3_libbuilddir/selftest.py
167pushd build/%py3_libbuilddir
168PYTHONPATH=$PWD %{__python3} selftest.py
169popd
170%endif
171
172
173%if 0%{?with_python3}
174%files -n python3-%{srcname}
175%doc README.rst CHANGES.rst
176%license docs/COPYING
177%{python3_sitearch}/*
178# These are in subpackages
179%exclude %{python3_sitearch}/PIL/_imagingtk*
180%exclude %{python3_sitearch}/PIL/ImageTk*
181%exclude %{python3_sitearch}/PIL/SpiderImagePlugin*
182%exclude %{python3_sitearch}/PIL/ImageQt*
183%exclude %{python3_sitearch}/PIL/__pycache__/ImageTk*
184%exclude %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
185%exclude %{python3_sitearch}/PIL/__pycache__/ImageQt*
186
187%files -n python3-%{srcname}-devel
188%{py3_incdir}/Imaging/
189
190%ifarch x86_64
191%files -n python3-%{srcname}-doc
192%if 0%{?with_docs}
193%doc docs/_build_py3/html
194%endif
195%endif
196
197%files -n python3-%{srcname}-tk
198%{python3_sitearch}/PIL/_imagingtk*
199%{python3_sitearch}/PIL/ImageTk*
200%{python3_sitearch}/PIL/SpiderImagePlugin*
201%{python3_sitearch}/PIL/__pycache__/ImageTk*
202%{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
203
204%files -n python3-%{srcname}-qt
205%{python3_sitearch}/PIL/ImageQt*
206%{python3_sitearch}/PIL/__pycache__/ImageQt*
207%endif
208
209
210%changelog
211* Tue Jan 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.1.0-1
212- new upstream release.
213
214* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-2
215- built with python-3.8.
216
217* Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-1
218- new upstream release.
219- dropped python2 support.
220
221* Wed Jan 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.2-1
222- new upstream release.
223
224* Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
225- initial build for Vine Linux.
226
227* Mon Oct 07 2019 Petr Viktorin <pviktori@redhat.com> - 6.2.0-2
228- Remove optional build dependency on python2-cffi
229
230* Tue Oct 01 2019 Sandro Mani <manisandro@gmail.com> - 6.2.0-1
231- Update to 6.2.0
232
233* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 6.1.0-4
234- Rebuilt for Python 3.8
235
236* Mon Aug 12 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-3
237- Drop python2-pillow-qt, python2-pillow-tk
238
239* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
240- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
241
242* Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-1
243- Update to 6.1.0
244
245* Fri May 31 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 6.0.0-2
246- Fix broken Python/C interop on s390x
247
248* Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
249- Update to 6.0.0
250
251* Sun Mar 10 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
252- Drop python2-pillow-doc
253
254* Mon Mar 04 2019 Yatin Karel <ykarel@redhat.com> - 5.4.1-3
255- Fix python3 conditional
256
257* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.1-2
258- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
259
260* Mon Jan 07 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-1
261- Update to 5.4.1
262
263* Mon Oct 01 2018 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
264- Update to 5.3.0
265
266* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
267- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
268
269* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 5.2.0-2
270- Rebuilt for Python 3.7
271
272* Mon Jul 02 2018 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
273- Update to 5.2.0
274
275* Wed Jun 27 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-3
276- Fix the tkinter dependency
277
278* Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-2
279- Rebuilt for Python 3.7
280
281* Wed Apr 25 2018 Sandro Mani <manisandro@gmail.com> - 5.1.1-1
282- Update to 5.1.1
283
284* Thu Apr 05 2018 Sandro Mani <manisandro@gmail.com> - 5.1.0-1
285- Update to 5.1.0
286
287* Wed Mar 07 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-3
288- Add missing BR: gcc
289
290* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
291- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
292
293* Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
294- Update to 5.0.0
295
296* Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
297- Update to 4.3.0
298
299* Tue Sep 05 2017 Troy Dawson <tdawson@redhat.com> - 4.2.1-5
300- Cleanup spec file conditionals
301
302* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
303- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
304
305* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-3
306- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
307
308* Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.2.1-2
309- Rebuild due to bug in RPM (RHBZ #1468476)
310
311* Thu Jul 06 2017 Sandro Mani <manisandro@gmail.com> - 4.2.1-1
312- Update to 4.2.1
313
314* Sat Jul 01 2017 Sandro Mani <manisandro@gmail.com> - 4.2.0-1
315- Update to 4.2.0
316
317* Fri Apr 28 2017 Sandro Mani <manisandro@gmail.com> - 4.1.1-1
318- Update to 4.1.1
319
320* Wed Apr 05 2017 Sandro Mani <manisandro@gmail.com> - 4.1.0-1
321- Update to 4.1.0
322
323* Wed Feb 15 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-3
324- Fix some __pycache__ files in wrong subpackage (#1422606)
325
326* Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-2
327- Rebuild (libwebp)
328
329* Tue Jan 03 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-1
330- Update to 4.0.0
331
332* Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-3
333- Enable docs build
334
335* Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-2
336- Rebuild for Python 3.6
337
338* Wed Oct 19 2016 Sandro Mani <manisandro@gmail.com> - 3.4.2-1
339- Update to 3.4.2
340
341* Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.4.1-1
342- Update to 3.4.1
343
344* Mon Oct 03 2016 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
345- Update to 3.4.0
346
347* Thu Aug 18 2016 Sandro Mani <manisandro@gmail.com> - 3.3.1-1
348- Update  to 3.3.1
349
350* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-2
351- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
352
353* Sat Jul 02 2016 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
354- Update to 3.3.0
355- Modernize spec
356
357* Fri Apr 01 2016 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
358- Update to 3.2.0
359
360* Wed Feb 10 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-3
361- Fix broken python3-pillow package description
362
363* Sun Feb 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.1.1-2
364- Fix provides
365
366* Thu Feb 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-1
367- Update to 3.1.1
368- Fixes CVE-2016-0740, CVE-2016-0775
369
370* Mon Jan 11 2016 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.0-2
371- Fix executable files in doc package bringing in python 2 for the python3 doc
372  packages
373
374* Mon Jan 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
375- Update to 3.1.0
376
377* Tue Dec 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-5
378- Build with docs
379
380* Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-4
381- Rebuilt for libwebp soname bump
382
383* Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-3
384- Rebuilt for Python3.5 rebuild with docs
385
386* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-2
387- Rebuilt for Python3.5 rebuild without docs
388
389* Fri Oct 02 2015 Sandro Mani <manisandro@gmail.com> - 3.0.0-1
390- Update to 3.0.0
391
392* Wed Jul 29 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-2
393- Fix python3-pillow-tk Requires: tkinter -> python3-tkinter (#1248085)
394
395* Thu Jul 02 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-1
396- Update to 2.9.0
397
398* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
399- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
400
401* Mon Jun 08 2015 Sandro Mani <manisandro@gmail.com> - 2.8.2-1
402- Update to 2.8.2
403
404* Thu Apr 02 2015 Sandro Mani <manisandro@gmail.com> - 2.8.1-1
405- Update to 2.8.1
406
407* Wed Apr 01 2015 Sandro Mani <manisandro@gmail.com> - 2.8.0-1
408- Update to 2.8.0
409
410* Mon Jan 12 2015 Sandro Mani <manisandro@gmail.com> - 2.7.0-1
411- Update to 2.7.0
412- Drop sane subpackage, is in python-sane now
413- Fix python3 headers directory
414- Drop Obsoletes: python3-pillow on python3-pillow-qt
415
416* Mon Oct 13 2014 Sandro Mani <manisandro@gmail.com> - 2.6.1-1
417- Update to 2.6.1
418
419* Thu Oct 02 2014 Sandro Mani <manisandro@gmail.com> - 2.6.0-1
420- Update to 2.6.0
421
422* Wed Aug 20 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-3
423- Rebuilding again to resolve transient build error that caused BZ#1131723
424
425* Tue Aug 19 2014 Stephen Gallagher <sgallagh@redhat.com> - 2.5.3-2
426- Rebuilding to resolve transient build error that caused BZ#1131723
427
428* Tue Aug 19 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
429- Update to 2.5.3 (Fix CVE-2014-3598, a DOS in the Jpeg2KImagePlugin)
430
431* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
432- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
433
434* Wed Aug 13 2014 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
435- Update to 2.5.2 (Fix CVE-2014-3589, a DOS in the IcnsImagePlugin)
436
437* Sat Jul 26 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-2
438- Reenable jpeg2k tests on big endian arches
439
440* Tue Jul 15 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-1
441- Update to 2.5.1
442
443* Wed Jul 02 2014 Sandro Mani <manisandro@gmail.com> - 2.5.0-1
444- Update to 2.5.0
445
446* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-11
447- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
448
449* Wed May 28 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-10
450- Rebuild with docs enabled
451- Update python-pillow_openjpeg-2.1.0.patch
452
453* Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-9
454- Rebuild against openjpeg-2.1.0
455
456* Fri May 23 2014 Dan Horák <dan[at]danny.cz> - 2.4.0-8
457- skip jpeg2k tests on big endian arches (#1100762)
458
459* Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.0-7
460- Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
461
462* Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-6
463- Set with_docs to 1 to build docs.
464
465* Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-5
466- Bootstrap building sphinx docs because of circular dependency with sphinx.
467
468* Fri May  9 2014 Orion Poplawski <orion@cora.nwra.com> - 2.4.0-4
469- Rebuild for Python 3.4
470
471* Tue Apr 22 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-3
472- Add patch: Have the tempfile use a suffix with a dot
473
474* Thu Apr 17 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-2
475- Enable Jpeg2000 support
476- Enable webp support also on s390* archs, bug #962091 is now fixed
477- Add upstream patch for ghostscript detection
478
479* Wed Apr 02 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-1
480- Update to 2.4.0
481
482* Wed Mar 19 2014 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
483- Update to 2.3.1 (Fix insecure use of tempfile.mktemp (CVE-2014-1932 CVE-2014-1933))
484
485* Thu Mar 13 2014 Jakub Dorňák <jdornak@redhat.com> - 2.3.0-5
486- python-pillow does not provide python3-imaging
487  (python3-pillow does)
488
489* Tue Jan 07 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-4
490- Add missing ghostscript Requires and BuildRequires
491
492* Mon Jan 06 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
493- Remove python-pillow_help-theme.patch, add python-sphinx-theme-better BR
494
495* Sun Jan 05 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
496- Rebuild with docs enabled
497- Change lcms BR to lcms2
498
499* Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
500- Update to 2.3.0
501- Build with doc disabled to break circular python-pillow -> python-sphinx -> python pillow dependency
502
503* Wed Oct 23 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-2
504- Backport fix for decoding tiffs with correct byteorder, fixes rhbz#1019656
505
506* Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
507- Update to 2.2.1
508- Really enable webp on ppc, but leave disabled on s390
509
510* Thu Aug 29 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-4
511- Add patch to fix incorrect PyArg_ParseTuple tuple signature, fixes rhbz#962091 and rhbz#988767.
512- Renable webp support on bigendian arches
513
514* Wed Aug 28 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-3
515- Add patch to fix memory corruption caused by invalid palette size, see rhbz#1001122
516
517* Tue Jul 30 2013 Karsten Hopp <karsten@redhat.com> 2.1.0-2
518- Build without webp support on ppc* archs (#988767)
519
520* Wed Jul 03 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
521- Update to 2.1.0
522- Run tests in builddir, not installroot
523- Build python3-pillow docs with python3
524- python-pillow_endian.patch upstreamed
525
526* Mon May 13 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-10
527- Build without webp support on s390* archs
528  Resolves: rhbz#962059
529
530* Sat May 11 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-9.gitd1c6db8
531- Conditionaly disable build of python3 parts on RHEL system
532
533* Wed May 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-8.gitd1c6db8
534- Add patch to fix test failure on big-endian
535
536* Thu Apr 25 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.0-7.gitd1c6db8
537- Remove Obsoletes in the python-pillow-qt subpackage. Obsoletes isn't
538  appropriate since qt support didn't exist in the previous python-pillow
539  package so there's no reason to drag in python-pillow-qt when updating
540  python-pillow.
541
542* Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-6.gitd1c6db8
543- Update to latest git
544- python-pillow_quantization.patch now upstream
545- python-pillow_endianness.patch now upstream
546- Add subpackage for ImageQt module, with correct dependencies
547- Add PyQt4 and numpy BR (for generating docs / running tests)
548
549* Mon Apr 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-5.git93a488e
550- Reenable tests on bigendian, add patches for #928927
551
552* Sun Apr 07 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.git93a488e
553- Update to latest git
554- disable tests on bigendian (PPC*, S390*) until rhbz#928927 is fixed
555
556* Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.gitde210a2
557- python-pillow_tempfile.patch now upstream
558- Add python3-imaging provides (bug #924867)
559
560* Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.git2e88848
561- Update to latest git
562- Remove python-pillow-disable-test.patch, gcc is now fixed
563- Add python-pillow_tempfile.patch to prevent a temporary file from getting packaged
564
565* Tue Mar 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.git2f4207c
566- Update to 2.0.0 git snapshot
567- Enable python3 packages
568- Add libwebp-devel BR for Pillow 2.0.0
569
570* Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
571- Add ARM support
572
573* Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
574- add s390* and ppc* to arch detection
575
576* Tue Mar 05 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-4.20130305git7866759
577- Update to latest git snapshot
578- 0001-Cast-hash-table-values-to-unsigned-long.patch now upstream
579- Pillow-1.7.8-selftest.patch now upstream
580
581* Mon Feb 25 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-3.20130210gite09ff61
582- Really remove -fno-strict-aliasing
583- Place comment on how to retreive source just above the Source0 line
584
585* Mon Feb 18 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-2.20130210gite09ff61
586- Rebuild without -fno-strict-aliasing
587- Add patch for upstream issue #52
588
589* Sun Feb 10 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-1.20130210gite09ff61
590- Initial RPM package
Note: See TracBrowser for help on using the repository browser.