source: projects/specs/trunk/p/python-paramiko/python-paramiko-vl.spec @ 9551

Revision 9551, 4.9 KB checked in by kudoh, 9 years ago (diff)

new upstream release and rebuild

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3%define srcname paramiko
4
5Name:           python-paramiko
6Version:        1.15.2
7Release:        1%{?_dist_release}
8Summary:        A SSH2 protocol library for python
9Summary(ja):    python 用 SSH2 プロトコルライブラリ
10
11Group:          Development/Libraries
12# No version specified.
13License:        LGPLv2+
14URL:            https://github.com/paramiko/paramiko/
15Source0:        https://pypi.python.org/packages/source/p/paramiko/paramiko-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildArch:      noarch
18
19BuildRequires: python-ecdsa
20BuildRequires: python-setuptools
21BuildRequires: python-devel
22BuildRequires: python-crypto >= 2.1
23
24Requires:       python-crypto >= 2.1
25
26%description
27Paramiko (a combination of the esperanto words for "paranoid" and "friend") is
28a module for python 2.3 or greater that implements the SSH2 protocol for secure
29(encrypted and authenticated) connections to remote machines. Unlike SSL (aka
30TLS), the SSH2 protocol does not require heirarchical certificates signed by a
31powerful central authority. You may know SSH2 as the protocol that replaced
32telnet and rsh for secure access to remote shells, but the protocol also
33includes the ability to open arbitrary channels to remote services across an
34encrypted tunnel. (This is how sftp works, for example.)
35
36%prep
37%setup -q -n %{srcname}-%{version}
38%{__chmod} a-x demos/*
39#%{__sed} -i -e '/^#!/,1d' demos/* paramiko/rng*
40%{__sed} -i -e '/^#!/,1d' demos/*
41
42%build
43CFLAGS="$RPM_OPT_FLAGS" %{__python} -c 'import setuptools; execfile("setup.py")' build
44
45%install
46rm -rf $RPM_BUILD_ROOT
47%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
48
49%check
50python ./test.py --no-sftp --no-big-file
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(-,root,root,-)
57%doc LICENSE README demos/
58%{python_sitelib}/*
59
60%changelog
61* Sat May 09 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.15.2-1
62- new upstream release
63- fixed %%check to skip sftp test
64
65* Mon Jan 13 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.12.1-1
66- new upstream release
67- added BuildRequires: python-ecdsa
68
69* Fri Sep 06 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.11.0-1
70- new upstream release
71- added BuildRequires: python-crypto >= 2.1
72- run test script
73
74* Sun Apr 28 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.10.1-1
75- new upstream release
76- changed Source0 and URL
77
78* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.7.1-2
79- rebuild with python-2.7.2
80
81* Wed Jul 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.7.1-1
82- new upstream release
83- changed Requires: python-crypto >= 2.1
84
85* Thu Nov 5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.6-2
86- added BuildRequires: python-devel
87
88* Tue Nov 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.6-1
89- new upstream release
90
91* Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.7.5-1
92- initial build for VineSeed
93
94* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.4-5
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
96
97* Mon Feb 16 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.4-4
98- Add demos as documentation. BZ#485742
99
100* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.7.4-3
101- Rebuild for Python 2.6
102
103* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.4-2
104- fix license tag
105
106* Sun Jul  6 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.4-1
107- Update to 1.7.4
108
109* Mon Mar 24 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.3-1
110- Update to 1.7.3.
111
112* Tue Jan 22 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.2-1
113- Update to 1.7.2.
114- Remove upstreamed patch.
115
116* Mon Jan 14 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-3
117- Update to latest Python packaging guidelines.
118- Apply patch that fixes insecure use of RandomPool.
119
120* Thu Jul 19 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-2
121- Bump rev
122
123* Thu Jul 19 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
124- Update to 1.7.1
125
126* Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 1.6.4-1
127- Update to 1.6.4
128- Upstream is now shipping tarballs
129- Bump for python 2.5 in devel
130
131* Mon Oct  9 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.2-1
132- Update to 1.6.2
133
134* Sat Sep 16 2006 Shahms E. King <shahms@shahms.com> 1.6.1-3
135- Rebuild for FC6
136
137* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 1.6.1-2
138- Include, don't ghost .pyo files per new guidelines
139
140* Tue Aug 08 2006 Shahms E. King <shahms@shahms.com> 1.6.1-1
141- Update to new upstream version
142
143* Fri Jun 02 2006 Shahms E. King <shahms@shahms.com> 1.6-1
144- Update to new upstream version
145- ghost the .pyo files
146
147* Fri May 05 2006 Shahms E. King <shahms@shahms.com> 1.5.4-2
148- Fix source line and rebuild
149
150* Fri May 05 2006 Shahms E. King <shahms@shahms.com> 1.5.4-1
151- Update to new upstream version
152
153* Wed Apr 12 2006 Shahms E. King <shahms@shahms.com> 1.5.3-1
154  - Initial package
Note: See TracBrowser for help on using the repository browser.