source: projects/specs/trunk/p/python-packaging/python-packaging-vl.spec @ 12469

Revision 12469, 4.2 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%bcond_with test
2%global pypi_name packaging
3
4#global build_wheel 1
5%global with_python3 1
6
7Summary:        Core utilities for Python packages
8Name:           python-%{pypi_name}
9Version:        20.4
10Release:        1%{?_dist_release}
11Group:          programming
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15License:        BSD or ASL 2.0
16URL:            https://github.com/pypa/packaging
17Source0:        https://files.pythonhosted.org/packages/source/p/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
18
19BuildArch:      noarch
20
21# Dependencies with different names in Fedora and Epel7
22BuildRequires:  python-rpm-macros
23BuildRequires:  python2-rpm-macros
24BuildRequires:  python-setuptools
25BuildRequires:  python-devel
26BuildRequires:  python-pyparsing
27BuildRequires:  python-six
28%if %{with test}
29BuildRequires:  python-pytest
30BuildRequires:  python-pretend
31%endif
32
33# Build Python 3 subpackage only for Fedora
34%if 0%{?with_python3}
35BuildRequires:  python3-rpm-macros
36BuildRequires:  python3-setuptools
37BuildRequires:  python3-devel
38BuildRequires:  python3-pyparsing
39BuildRequires:  python3-six
40%if %{with test}
41BuildRequires:  python3-pytest
42BuildRequires:  python3-pretend
43%endif
44%endif
45
46Requires:       python-pyparsing
47Requires:       python-six
48%{?python_provide:%python_provide python2-%{pypi_name}}
49
50%description
51python-packaging provides core utilities for Python packages like utilities for
52dealing with versions, specifiers, markers etc.
53
54%if 0%{?with_python3}
55%package -n python3-%{pypi_name}
56Summary:        %{summary}
57%{?python_provide:%python_provide python3-%{pypi_name}}
58 
59Requires:       python3-pyparsing
60Requires:       python3-six
61%description -n python3-%{pypi_name}
62python3-packaging provides core utilities for Python packages like utilities for
63dealing with versions, specifiers, markers etc.
64%endif
65
66%prep
67%autosetup -n %{pypi_name}-%{version}
68# Remove bundled egg-info
69rm -rf %{pypi_name}.egg-info
70
71%build
72%py2_build
73
74%if 0%{?with_python3}
75%py3_build
76%endif
77
78%install
79%py2_install
80
81%if 0%{?with_python3}
82%py3_install
83%endif
84
85%check
86%if %{with test}
87%{__python2} -m pytest tests/
88%{__python3} -m pytest tests/
89%endif
90
91%files
92%license LICENSE LICENSE.APACHE LICENSE.BSD
93%doc README.rst CHANGELOG.rst CONTRIBUTING.rst
94%{python2_sitelib}/%{pypi_name}/
95%{python2_sitelib}/%{pypi_name}-*-info/
96
97%if 0%{?with_python3}
98%files -n python3-%{pypi_name}
99%license LICENSE LICENSE.APACHE LICENSE.BSD
100%doc README.rst CHANGELOG.rst CONTRIBUTING.rst
101%{python3_sitelib}/%{pypi_name}/
102%{python3_sitelib}/%{pypi_name}-*-info/
103%endif
104
105%changelog
106* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 20.4-1
107- new upstream release.
108
109* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 18.0-1
110- new upstream release.
111- initial build for Vine Linux.
112
113* Tue Jul 31 2018 Charalampos Stratakis <cstratak@redhat.com> - 17.1-1
114- Update to 17.1
115
116* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-11
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
118
119* Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 16.8-10
120- Rebuilt for Python 3.7
121
122* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 16.8-9
123- Bootstrap for Python 3.7
124
125* Fri Feb 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 16.8-8
126- Update Python 2 dependency declarations to new packaging standards
127  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
128
129* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-7
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
131
132* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-6
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
134
135* Wed Mar 22 2017 Lumir Balhar <lbalhar@redhat.com> - 16.8-5
136- Epel7 compatible spec/package
137
138* Mon Feb 13 2017 Charalampos Stratakis <cstratak@redhat.com> - 16.8-4
139- Rebuild as wheel
140
141* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-3
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
143
144* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 16.8-2
145- Rebuild for Python 3.6
146
147* Wed Nov 02 2016 Lumir Balhar <lbalhar@redhat.com> - 16.8-1
148- New upstream version
149
150* Fri Sep 16 2016 Lumir Balhar <lbalhar@redhat.com> - 16.7-1
151- Initial package.
Note: See TracBrowser for help on using the repository browser.