source: projects/specs/trunk/p/python-numarray/python-numarray-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_siteinc: %define python_siteinc %(%{__python} -c "from distutils.sysconfig import get_python_inc; print get_python_inc()")}
3
4Name:           python-numarray
5Version:        1.5.2
6Release:        2%{?_dist_release}
7Summary:        Python array manipulation and computational library
8
9Group:          Development/Languages
10License:        BSD
11URL:            http://www.stsci.edu/resources/software_hardware/numarray
12Source0:        http://dl.sf.net/numpy/numarray-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15BuildRequires:  python-devel
16Provides:   %{name}-devel = %{version}-%{release}
17
18%description
19Numarray provides array manipulation and computational capabilities
20similar to those found in IDL, Matlab, or Octave. Using numarray, it is
21possible to write many efficient numerical data processing applications
22directly in Python without using any C, C++ or Fortran code (as well as
23doing such analysis interactively within Python or PyRAF). For algorithms
24that are not well suited for efficient computation using array facilities
25it is possible to write C functions (and eventually Fortran) that can
26read and write numarray arrays that can be called from Python.
27
28
29%prep
30%setup -q -n numarray-%{version}
31find -name \*~ | xargs rm -f
32
33%build
34CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
35
36
37%install
38rm -rf $RPM_BUILD_ROOT
39%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
40chmod +x $RPM_BUILD_ROOT%{python_sitearch}/numarray/examples/convolve/benchmark.py
41
42 
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46
47%files
48%defattr(-,root,root,-)
49%doc LICENSE.txt README.txt Doc/*
50%{python_siteinc}/numarray/
51%{python_sitearch}/numarray/
52%{python_sitearch}/numarray-*.egg-info
53
54
55%changelog
56* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.2-2
57- rebuild with python-2.6
58
59* Fri Oct 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.5.2-1
60- initial build for VineSeed
61
62* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5.2-6
63- Autorebuild for GCC 4.3
64
65* Wed Jan  9 2008 - Orion Poplawski <orion@cora.nwra.com> - 1.5.2-5
66- Add python egg-info file
67
68* Thu Aug 23 2007 - Orion Poplawski <orion@cora.nwra.com> - 1.5.2-4
69- Update license tag to BSD
70- Rebuild for BuildID
71
72* Thu May 17 2007 - Orion Poplawski <orion@cora.nwra.com> - 1.5.2-3
73- Rebuild to reduce shared object sizes
74
75* Tue Dec 12 2006 - Jef Spaleta <jspaleta@gmail.com> - 1.5.2-2
76- Bump and release for python 2.5 rebuild
77
78* Wed Sep  6 2006 - Orion Poplawski <orion@cora.nwra.com> - 1.5.2-1
79- Update to 1.5.2
80- No longer ghost .pyo files
81
82* Tue Feb 14 2006 - Orion Poplawski <orion@cora.nwra.com> - 1.5.1-1
83- Update to 1.5.1
84
85* Thu Dec 22 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.5.0-1
86- Update to 1.5.0
87
88* Thu Aug 11 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.3.3-4
89- Use sitearch macro instead of sitelib
90
91* Thu Aug 11 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.3.3-3
92- Properly %ghost .pyo files
93
94* Tue Aug 09 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.3.3-2
95- Cleanup
96- Added -devel provides
97
98* Tue Aug 02 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.3.3-1
99- Initial release for Fedora Extras
Note: See TracBrowser for help on using the repository browser.