source: projects/specs/trunk/p/python-numarray/python-numarray-vl.spec @ 8158

Revision 8158, 3.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_siteinc: %define python_siteinc %(%{__python} -c "from distutils.sysconfig import get_python_inc; print get_python_inc()")}
3
4Name:           python-numarray
5Version:        1.5.2
6Release:        4%{?_dist_release}
7Summary:        Python array manipulation and computational library
8
9Group:          Development/Languages
10License:        BSD
11URL:            http://www.stsci.edu/resources/software_hardware/numarray
12Source0:        http://dl.sf.net/numpy/numarray-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15BuildRequires:  python-devel
16Provides:   %{name}-devel = %{version}-%{release}
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22Numarray provides array manipulation and computational capabilities
23similar to those found in IDL, Matlab, or Octave. Using numarray, it is
24possible to write many efficient numerical data processing applications
25directly in Python without using any C, C++ or Fortran code (as well as
26doing such analysis interactively within Python or PyRAF). For algorithms
27that are not well suited for efficient computation using array facilities
28it is possible to write C functions (and eventually Fortran) that can
29read and write numarray arrays that can be called from Python.
30
31
32%prep
33%setup -q -n numarray-%{version}
34find -name \*~ | xargs rm -f
35
36%build
37CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
38
39
40%install
41rm -rf $RPM_BUILD_ROOT
42%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
43chmod +x $RPM_BUILD_ROOT%{python_sitearch}/numarray/examples/convolve/benchmark.py
44
45 
46%clean
47rm -rf $RPM_BUILD_ROOT
48
49
50%files
51%defattr(-,root,root,-)
52%doc LICENSE.txt README.txt Doc/*
53%{python_siteinc}/numarray/
54%{python_sitearch}/numarray/
55%{python_sitearch}/numarray-*.egg-info
56
57
58%changelog
59* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.2-4
60- rebuild with VineSeed environment
61
62* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.2-3
63- rebuild with python-2.7.2
64
65* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.2-2
66- rebuild with python-2.6
67
68* Fri Oct 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.5.2-1
69- initial build for VineSeed
70
71* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5.2-6
72- Autorebuild for GCC 4.3
73
74* Wed Jan  9 2008 - Orion Poplawski <orion@cora.nwra.com> - 1.5.2-5
75- Add python egg-info file
76
77* Thu Aug 23 2007 - Orion Poplawski <orion@cora.nwra.com> - 1.5.2-4
78- Update license tag to BSD
79- Rebuild for BuildID
80
81* Thu May 17 2007 - Orion Poplawski <orion@cora.nwra.com> - 1.5.2-3
82- Rebuild to reduce shared object sizes
83
84* Tue Dec 12 2006 - Jef Spaleta <jspaleta@gmail.com> - 1.5.2-2
85- Bump and release for python 2.5 rebuild
86
87* Wed Sep  6 2006 - Orion Poplawski <orion@cora.nwra.com> - 1.5.2-1
88- Update to 1.5.2
89- No longer ghost .pyo files
90
91* Tue Feb 14 2006 - Orion Poplawski <orion@cora.nwra.com> - 1.5.1-1
92- Update to 1.5.1
93
94* Thu Dec 22 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.5.0-1
95- Update to 1.5.0
96
97* Thu Aug 11 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.3.3-4
98- Use sitearch macro instead of sitelib
99
100* Thu Aug 11 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.3.3-3
101- Properly %ghost .pyo files
102
103* Tue Aug 09 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.3.3-2
104- Cleanup
105- Added -devel provides
106
107* Tue Aug 02 2005 - Orion Poplawski <orion@cora.nwra.com> - 1.3.3-1
108- Initial release for Fedora Extras
Note: See TracBrowser for help on using the repository browser.