source: projects/specs/trunk/p/python-nose/python-nose-vl.spec @ 7634

Revision 7634, 3.6 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4%define pkg_release     1%{?_dist_release}
5
6Name:           python-nose
7Version:        1.3.0
8Release:        %{pkg_release}
9Summary:        A discovery-based unittest extension for Python
10Summary(ja):    Python 用の発見型ユニットテスト・エクステンション
11
12Group:          Development/Languages
13License:        LGPLv2
14URL:            http://somethingaboutorange.com/mrl/projects/nose/
15Source0:        http://somethingaboutorange.com/mrl/projects/nose/nose-%{version}.tar.gz
16#Patch0:        no-google-analytics.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20BuildArch:      noarch
21BuildRequires:  python-devel, python-setuptools
22Requires:       python-setuptools
23
24
25%description
26nose: a discovery-based unittest extension.
27
28nose provides an alternate test discovery and running process for unittest,
29one that is intended to mimic the behavior of py.test as much as is
30reasonably possible without resorting to too much magic.
31
32
33%prep
34%setup -q -n nose-%{version}
35#%patch0 -p1
36
37%build
38CFLAGS="${RPM_OPT_FLAGS}" %{__python} setup.py build
39
40%install
41rm -rf ${RPM_BUILD_ROOT}
42%{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT} --install-data=%{_datadir}
43
44%clean
45rm -rf ${RPM_BUILD_ROOT}
46
47%files
48%defattr(-,root,root,-)
49%doc AUTHORS CHANGELOG lgpl.txt NEWS README.txt
50%{_bindir}/nosetests
51%{_bindir}/nosetests-2.7
52%{_mandir}/man1/nosetests.1.gz
53%{python_sitelib}/nose-%{version}-py%{pyver}.egg-info
54%{python_sitelib}/nose
55
56%changelog
57* Sun Apr 28 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.3.0-1
58- new upstream release
59- deleted Patch0
60
61* Sun Jun 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.2-1
62- new upstream release
63- added Patch0 from Debian sid to delete google analytics
64
65* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.4-3
66- rebuild with python-2.7.2
67
68* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.10.4-2
69- rebuild with python-2.6
70
71* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.4-1
72- initial build for Vine Linux based on fedora package
73
74* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.4-1
75- Update to 0.10.4 to fix 2.6 issues
76
77* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.3-2
78- Rebuild for Python 2.6
79
80* Sat Aug 02 2008 Luke Macken <lmacken@redhat.com> 0.10.3-1
81- Update to 0.10.3
82
83* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> 0.10.1-1
84- Update to 0.10.1
85
86* Mon Dec  3 2007 Luke Macken <lmacken@redhat.com> 0.10.0-2
87- Add python-setuptools to Requires (Bug #408491)
88
89* Tue Nov 27 2007 Luke Macken <lmacken@redhat.com> 0.10.0-1
90- 0.10.0
91
92* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.3.b1
93- Update for python-setuptools changes in rawhide
94
95* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.2.b1
96- 0.10.0b1
97- Update license tag to LGPLv2
98
99* Wed Jun 20 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.1.a2
100- 0.10.0a2
101
102* Sat Jun  2 2007 Luke Macken <lmacken@redhat.com> 0.9.3-1
103- Latest upstream release
104- Remove python-nose-0.9.2-mandir.patch
105
106* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> 0.9.2-1
107- Add nosetests(1) manpage, and python-nose-0.9.2-mandir.patch to put it in
108  the correct location.
109- 0.9.2
110
111* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> 0.9.1-2
112- Rebuild for python 2.5
113
114* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> 0.9.1-1
115- 0.9.1
116
117* Fri Sep  8 2006 Luke Macken <lmacken@redhat.com> 0.9.0-1
118- 0.9.0
119
120* Wed Apr 19 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.8.7.2-1
121- Initial RPM release
Note: See TracBrowser for help on using the repository browser.