source: projects/specs/trunk/p/python-nose/python-nose-vl.spec @ 6416

Revision 6416, 3.5 KB checked in by kudoh, 12 years ago (diff)

python-nose-vl.spec

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4%define pkg_release     1%{?_dist_release}
5
6Name:           python-nose
7Version:        1.1.2
8Release:        %{pkg_release}
9Summary:        A discovery-based unittest extension for Python
10Summary(ja):    Python 用の発見型ユニットテスト・エクステンション
11
12Group:          Development/Languages
13License:        LGPLv2
14URL:            http://somethingaboutorange.com/mrl/projects/nose/
15Source0:        http://somethingaboutorange.com/mrl/projects/nose/nose-%{version}.tar.gz
16Patch0:        no-google-analytics.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20BuildArch:      noarch
21BuildRequires:  python-devel, python-setuptools
22Requires:       python-setuptools
23
24
25%description
26nose: a discovery-based unittest extension.
27
28nose provides an alternate test discovery and running process for unittest,
29one that is intended to mimic the behavior of py.test as much as is
30reasonably possible without resorting to too much magic.
31
32
33%prep
34%setup -q -n nose-%{version}
35%patch0 -p1
36
37%build
38CFLAGS="${RPM_OPT_FLAGS}" %{__python} setup.py build
39
40%install
41rm -rf ${RPM_BUILD_ROOT}
42%{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT} --install-data=%{_datadir}
43
44%clean
45rm -rf ${RPM_BUILD_ROOT}
46
47%files
48%defattr(-,root,root,-)
49%doc AUTHORS CHANGELOG lgpl.txt NEWS README.txt
50%{_bindir}/nosetests
51%{_bindir}/nosetests-2.7
52%{_mandir}/man1/nosetests.1.gz
53%{python_sitelib}/nose-%{version}-py%{pyver}.egg-info
54%{python_sitelib}/nose
55
56%changelog
57* Sun Jun 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.2-1
58- new upstream release
59- added Patch0 from Debian sid to delete google analytics
60
61* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.4-3
62- rebuild with python-2.7.2
63
64* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.10.4-2
65- rebuild with python-2.6
66
67* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.4-1
68- initial build for Vine Linux based on fedora package
69
70* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.4-1
71- Update to 0.10.4 to fix 2.6 issues
72
73* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.3-2
74- Rebuild for Python 2.6
75
76* Sat Aug 02 2008 Luke Macken <lmacken@redhat.com> 0.10.3-1
77- Update to 0.10.3
78
79* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> 0.10.1-1
80- Update to 0.10.1
81
82* Mon Dec  3 2007 Luke Macken <lmacken@redhat.com> 0.10.0-2
83- Add python-setuptools to Requires (Bug #408491)
84
85* Tue Nov 27 2007 Luke Macken <lmacken@redhat.com> 0.10.0-1
86- 0.10.0
87
88* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.3.b1
89- Update for python-setuptools changes in rawhide
90
91* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.2.b1
92- 0.10.0b1
93- Update license tag to LGPLv2
94
95* Fri Jun 20 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.1.a2
96- 0.10.0a2
97
98* Sat Jun  2 2007 Luke Macken <lmacken@redhat.com> 0.9.3-1
99- Latest upstream release
100- Remove python-nose-0.9.2-mandir.patch
101
102* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> 0.9.2-1
103- Add nosetests(1) manpage, and python-nose-0.9.2-mandir.patch to put it in
104  the correct location.
105- 0.9.2
106
107* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> 0.9.1-2
108- Rebuild for python 2.5
109
110* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> 0.9.1-1
111- 0.9.1
112
113* Fri Sep  8 2006 Luke Macken <lmacken@redhat.com> 0.9.0-1
114- 0.9.0
115
116* Wed Apr 19 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.8.7.2-1
117- Initial RPM release
Note: See TracBrowser for help on using the repository browser.