source: projects/specs/trunk/p/python-nose/python-nose-vl.spec @ 5701

Revision 5701, 3.3 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4%define pkg_release     3%{?_dist_release}
5
6Name:           python-nose
7Version:        0.10.4
8Release:        %{pkg_release}
9Summary:        A discovery-based unittest extension for Python
10Summary(ja):    Python 用の発見型ユニットテスト・エクステンション
11
12Group:          Development/Languages
13License:        LGPLv2
14URL:            http://somethingaboutorange.com/mrl/projects/nose/
15Source0:        http://somethingaboutorange.com/mrl/projects/nose/nose-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildArch:      noarch
19BuildRequires:  python-devel, python-setuptools
20Requires:       python-setuptools
21
22
23%description
24nose: a discovery-based unittest extension.
25
26nose provides an alternate test discovery and running process for unittest,
27one that is intended to mimic the behavior of py.test as much as is
28reasonably possible without resorting to too much magic.
29
30
31%prep
32%setup -q -n nose-%{version}
33
34%build
35CFLAGS="${RPM_OPT_FLAGS}" %{__python} setup.py build
36
37%install
38rm -rf ${RPM_BUILD_ROOT}
39%{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT} --install-data=%{_datadir}
40
41%clean
42rm -rf ${RPM_BUILD_ROOT}
43
44%files
45%defattr(-,root,root,-)
46%doc AUTHORS CHANGELOG lgpl.txt NEWS README.txt
47%{_bindir}/nosetests
48%{_mandir}/man1/nosetests.1.gz
49%{python_sitelib}/nose-%{version}-py%{pyver}.egg-info
50%{python_sitelib}/nose
51
52%changelog
53* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.4-3
54- rebuild with python-2.7.2
55
56* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.10.4-2
57- rebuild with python-2.6
58
59* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.4-1
60- initial build for Vine Linux based on fedora package
61
62* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.4-1
63- Update to 0.10.4 to fix 2.6 issues
64
65* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.3-2
66- Rebuild for Python 2.6
67
68* Sat Aug 02 2008 Luke Macken <lmacken@redhat.com> 0.10.3-1
69- Update to 0.10.3
70
71* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> 0.10.1-1
72- Update to 0.10.1
73
74* Mon Dec  3 2007 Luke Macken <lmacken@redhat.com> 0.10.0-2
75- Add python-setuptools to Requires (Bug #408491)
76
77* Tue Nov 27 2007 Luke Macken <lmacken@redhat.com> 0.10.0-1
78- 0.10.0
79
80* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.3.b1
81- Update for python-setuptools changes in rawhide
82
83* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.2.b1
84- 0.10.0b1
85- Update license tag to LGPLv2
86
87* Fri Jun 20 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.1.a2
88- 0.10.0a2
89
90* Sat Jun  2 2007 Luke Macken <lmacken@redhat.com> 0.9.3-1
91- Latest upstream release
92- Remove python-nose-0.9.2-mandir.patch
93
94* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> 0.9.2-1
95- Add nosetests(1) manpage, and python-nose-0.9.2-mandir.patch to put it in
96  the correct location.
97- 0.9.2
98
99* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> 0.9.1-2
100- Rebuild for python 2.5
101
102* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> 0.9.1-1
103- 0.9.1
104
105* Fri Sep  8 2006 Luke Macken <lmacken@redhat.com> 0.9.0-1
106- 0.9.0
107
108* Wed Apr 19 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.8.7.2-1
109- Initial RPM release
Note: See TracBrowser for help on using the repository browser.