source: projects/specs/trunk/p/python-nose/python-nose-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4%define pkg_release     2%{?_dist_release}
5
6Name:           python-nose
7Version:        0.10.4
8Release:        %{pkg_release}
9Summary:        A discovery-based unittest extension for Python
10Summary(ja):    Python 用の発見型ユニットテスト・エクステンション
11
12Group:          Development/Languages
13License:        LGPLv2
14URL:            http://somethingaboutorange.com/mrl/projects/nose/
15Source0:        http://somethingaboutorange.com/mrl/projects/nose/nose-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildArch:      noarch
19BuildRequires:  python-devel, python-setuptools
20Requires:       python-setuptools
21
22
23%description
24nose: a discovery-based unittest extension.
25
26nose provides an alternate test discovery and running process for unittest,
27one that is intended to mimic the behavior of py.test as much as is
28reasonably possible without resorting to too much magic.
29
30
31%prep
32%setup -q -n nose-%{version}
33
34%build
35CFLAGS="${RPM_OPT_FLAGS}" %{__python} setup.py build
36
37%install
38rm -rf ${RPM_BUILD_ROOT}
39%{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT} \
40        --single-version-externally-managed --install-data=%{_datadir}
41
42%clean
43rm -rf ${RPM_BUILD_ROOT}
44
45%files
46%defattr(-,root,root,-)
47%doc AUTHORS CHANGELOG lgpl.txt NEWS README.txt
48%{_bindir}/nosetests
49%{_mandir}/man1/nosetests.1.gz
50%{python_sitelib}/nose-%{version}-py%{pyver}.egg-info
51%{python_sitelib}/nose
52
53%changelog
54* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.10.4-2
55- rebuild with python-2.6
56
57* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.4-1
58- initial build for Vine Linux based on fedora package
59
60* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.4-1
61- Update to 0.10.4 to fix 2.6 issues
62
63* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.3-2
64- Rebuild for Python 2.6
65
66* Sat Aug 02 2008 Luke Macken <lmacken@redhat.com> 0.10.3-1
67- Update to 0.10.3
68
69* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> 0.10.1-1
70- Update to 0.10.1
71
72* Mon Dec  3 2007 Luke Macken <lmacken@redhat.com> 0.10.0-2
73- Add python-setuptools to Requires (Bug #408491)
74
75* Tue Nov 27 2007 Luke Macken <lmacken@redhat.com> 0.10.0-1
76- 0.10.0
77
78* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.3.b1
79- Update for python-setuptools changes in rawhide
80
81* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.2.b1
82- 0.10.0b1
83- Update license tag to LGPLv2
84
85* Fri Jun 20 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.1.a2
86- 0.10.0a2
87
88* Sat Jun  2 2007 Luke Macken <lmacken@redhat.com> 0.9.3-1
89- Latest upstream release
90- Remove python-nose-0.9.2-mandir.patch
91
92* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> 0.9.2-1
93- Add nosetests(1) manpage, and python-nose-0.9.2-mandir.patch to put it in
94  the correct location.
95- 0.9.2
96
97* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> 0.9.1-2
98- Rebuild for python 2.5
99
100* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> 0.9.1-1
101- 0.9.1
102
103* Fri Sep  8 2006 Luke Macken <lmacken@redhat.com> 0.9.0-1
104- 0.9.0
105
106* Wed Apr 19 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.8.7.2-1
107- Initial RPM release
Note: See TracBrowser for help on using the repository browser.