source: projects/specs/trunk/p/python-nose/python-nose-vl.spec @ 12474

Revision 12474, 6.1 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

brotli-1.0.7-5

graphviz-2.44.1-1

llvm-10.0.1-1

libplist-2.2.0-2

libpwquality-1.4.2-2

python-nose-1.3.7-2

Line 
1%define modname nose
2
3Summary:        A discovery-based unittest extension for Python
4Summary(ja):    Python 用の発見型ユニットテスト・エクステンション
5Name:           python-nose
6Version:        1.3.7
7Release:        2%{?_dist_release}
8Group:          programming
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        LGPLv2
13URL:            http://somethingaboutorange.com/mrl/projects/nose/
14Source0:        http://somethingaboutorange.com/mrl/projects/nose/nose-%{version}.tar.gz
15
16# Make compatible with coverage 4.1
17# https://github.com/nose-devs/nose/pull/1004
18Patch0:         python-nose-coverage4.patch
19# Fix python 3.5 compat
20# https://github.com/nose-devs/nose/pull/983
21Patch1:         python-nose-py35.patch
22# Fix UnicodeDecodeError with captured output
23# https://github.com/nose-devs/nose/pull/988
24Patch2:         python-nose-unicode.patch
25# Allow docutils to read utf-8 source
26Patch3:         python-nose-readunicode.patch
27# Fix Python 3.6 compatibility
28# Python now returns ModuleNotFoundError instead of the previous ImportError
29# https://github.com/nose-devs/nose/pull/1029
30Patch4:         python-nose-py36.patch
31
32BuildArch:      noarch
33BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
34
35BuildRequires:  dos2unix
36BuildRequires:  python-rpm-macros
37BuildRequires:  python-devel, python-setuptools, python2-rpm-macros
38BuildRequires:  python3-devel, python3-setuptools, python3-rpm-macros
39Requires:       python-setuptools
40
41
42%description
43nose: a discovery-based unittest extension.
44
45nose provides an alternate test discovery and running process for unittest,
46one that is intended to mimic the behavior of py.test as much as is
47reasonably possible without resorting to too much magic.
48
49
50%package -n python3-nose
51Summary:        A discovery-based unittest extension for Python
52Summary(ja):    Python 用の発見型ユニットテスト・エクステンション
53Group:          programming
54Requires:       python3-setuptools
55
56%description -n python3-nose
57nose: a discovery-based unittest extension.
58
59nose provides an alternate test discovery and running process for unittest,
60one that is intended to mimic the behavior of py.test as much as is
61reasonably possible without resorting to too much magic.
62
63
64%prep
65%setup -qc
66pushd %{modname}-%{version}
67%autopatch -p1
68dos2unix examples/attrib_plugin.py
69cp -pr lgpl.txt AUTHORS CHANGELOG examples NEWS README.txt ..
70popd
71mv %{modname}-%{version} python2
72cp -pr python2 python3
73
74
75%build
76pushd python2
77%py2_build
78popd
79pushd python3
80%py3_build
81popd
82
83
84%install
85rm -rf ${RPM_BUILD_ROOT}
86
87mkdir -p %{buildroot}%{_mandir}/man1
88pushd python2
89%py2_install
90mv %{buildroot}%{_bindir}/nosetests{,-%{python_version}}
91ln -sf nosetests-%{python_version} %{buildroot}%{_bindir}/nosetests-2
92mv %{buildroot}%{_prefix}/man/man1/nosetests.1 %{buildroot}%{_mandir}/man1/nosetests-%{python_version}.1
93ln -sf nosetests-%{python_version}.1 %{buildroot}%{_mandir}/man1/nosetests-2.1
94popd
95pushd python3
96%py3_install
97mv %{buildroot}%{_bindir}/nosetests{,-%{python3_version}}
98ln -sf nosetests-%{python3_version} %{buildroot}%{_bindir}/nosetests-3
99mv %{buildroot}%{_prefix}/man/man1/nosetests.1 %{buildroot}%{_mandir}/man1/nosetests-%{python3_version}.1
100ln -sf nosetests-%{python3_version}.1 %{buildroot}%{_mandir}/man1/nosetests-3.1
101popd
102
103ln -sf nosetests-3 %{buildroot}%{_bindir}/nosetests
104ln -sf nosetests-3.1 %{buildroot}%{_mandir}/man1/nosetests.1
105
106
107%check
108pushd python2
109%{__python2} selftest.py
110popd
111pushd python3
112%{__python3} setup.py build_tests
113%{__python3} selftest.py
114popd
115
116
117%clean
118rm -rf ${RPM_BUILD_ROOT}
119
120
121%files
122%defattr(-,root,root,-)
123%doc AUTHORS CHANGELOG lgpl.txt NEWS README.txt
124%{_bindir}/nosetests-2*
125%{_mandir}/man1/nosetests-2*
126%{python_sitelib}/nose-%{version}-py%{pyver}.egg-info
127%{python_sitelib}/nose
128
129%files -n python3-nose
130%defattr(-,root,root,-)
131%doc AUTHORS CHANGELOG lgpl.txt NEWS README.txt
132%{_bindir}/nosetests
133%{_bindir}/nosetests-3*
134%{_mandir}/man1/nosetests.1*
135%{_mandir}/man1/nosetests-3*
136%{python3_sitelib}/nose-%{version}-py%{python3_version}.egg-info
137%{python3_sitelib}/nose
138
139%changelog
140* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7-2
141- built with python-3.8.
142
143* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7-1
144- new upstream release.
145- added python3 support.
146
147* Sun Apr 28 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.3.0-1
148- new upstream release
149- deleted Patch0
150
151* Sun Jun 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.2-1
152- new upstream release
153- added Patch0 from Debian sid to delete google analytics
154
155* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.4-3
156- rebuild with python-2.7.2
157
158* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.10.4-2
159- rebuild with python-2.6
160
161* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.4-1
162- initial build for Vine Linux based on fedora package
163
164* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.4-1
165- Update to 0.10.4 to fix 2.6 issues
166
167* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.10.3-2
168- Rebuild for Python 2.6
169
170* Sat Aug 02 2008 Luke Macken <lmacken@redhat.com> 0.10.3-1
171- Update to 0.10.3
172
173* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> 0.10.1-1
174- Update to 0.10.1
175
176* Mon Dec  3 2007 Luke Macken <lmacken@redhat.com> 0.10.0-2
177- Add python-setuptools to Requires (Bug #408491)
178
179* Tue Nov 27 2007 Luke Macken <lmacken@redhat.com> 0.10.0-1
180- 0.10.0
181
182* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.3.b1
183- Update for python-setuptools changes in rawhide
184
185* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.2.b1
186- 0.10.0b1
187- Update license tag to LGPLv2
188
189* Wed Jun 20 2007 Luke Macken <lmacken@redhat.com> 0.10.0-0.1.a2
190- 0.10.0a2
191
192* Sat Jun  2 2007 Luke Macken <lmacken@redhat.com> 0.9.3-1
193- Latest upstream release
194- Remove python-nose-0.9.2-mandir.patch
195
196* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> 0.9.2-1
197- Add nosetests(1) manpage, and python-nose-0.9.2-mandir.patch to put it in
198  the correct location.
199- 0.9.2
200
201* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> 0.9.1-2
202- Rebuild for python 2.5
203
204* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> 0.9.1-1
205- 0.9.1
206
207* Fri Sep  8 2006 Luke Macken <lmacken@redhat.com> 0.9.0-1
208- 0.9.0
209
210* Wed Apr 19 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.8.7.2-1
211- Initial RPM release
Note: See TracBrowser for help on using the repository browser.