source: projects/specs/trunk/p/python-mechanize/python-mechanize-vl.spec @ 521

Revision 521, 3.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-mechanize
4Version:        0.1.10
5Release:        2%{?_dist_release}
6Summary:        Stateful programmatic web browsing
7Summary(ja):    ウェブ・ブラウジング・プログラム用 Python モジュール
8
9Group:          System Environment/Libraries
10License:        BSD
11URL:            http://wwwsearch.sourceforge.net/mechanize
12Source0:        http://wwwsearch.sourceforge.net/mechanize/src/mechanize-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  python-devel
17BuildRequires:  python-setuptools
18Requires:       python-clientform
19
20
21%description
22Stateful programmatic web browsing, after Andy Lester's Perl module
23WWW::Mechanize.
24
25The library is layered: mechanize.Browser (stateful web browser),
26mechanize.UserAgent (configurable URL opener), plus urllib2 handlers.
27
28Features include: ftp:, http: and file: URL schemes, browser history,
29high-level hyperlink and HTML form support, HTTP cookies, HTTP-EQUIV and
30Refresh, Referer [sic] header, robots.txt, redirections, proxies, and
31Basic and Digest HTTP authentication.  mechanize's response objects are
32(lazily-) .seek()able and still work after .close().
33
34Much of the code originally derived from Perl code by Gisle Aas
35(libwww-perl), Johnny Lee (MSIE Cookie support) and last but not least
36Andy Lester (WWW::Mechanize).  urllib2 was written by Jeremy Hylton.
37
38
39%prep
40%setup -q -n mechanize-%{version}
41
42
43%build
44%{__python} setup.py build
45
46
47%install
48rm -rf $RPM_BUILD_ROOT
49%{__python} setup.py install --single-version-externally-managed \
50                             -O1 --root=$RPM_BUILD_ROOT
51
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56
57%files
58%defattr(-,root,root,-)
59%doc COPYING.txt README.txt README.html GeneralFAQ.html doc.html examples
60%{python_sitelib}/*
61
62
63%changelog
64* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
65- rebuild with python-2.6
66
67* Sun Dec 28 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.1.10-1
68- initial build for Vine Linux based on fedora package
69
70* Wed Dec 10 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.1.10-1
71- Update to 0.1.10
72
73* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.1.6-0.3.b
74- Rebuild for Python 2.6
75
76* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 0.1.6-0.2.b
77- Update for python-setuptools changes in rawhide
78
79* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 0.1.6-0.1.b
80- 0.1.6b
81
82* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 0.1.5-0.1.b
83- Rebuild for python 2.5
84- 0.1.5b
85
86* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-5
87- Rebuild for FC6
88
89* Sun Jul  9 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-4
90- Remove unnecessary python-abi requirement
91
92* Wed May 17 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-3
93- Add BuildArch: noarch (bug #192155)
94
95* Sun May 14 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-2
96- Add python-abi Requires
97- Remove noarch
98
99* Thu May 11 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-1
100- Packaged for Fedora Extras
Note: See TracBrowser for help on using the repository browser.