source: projects/specs/trunk/p/python-mechanize/python-mechanize-vl.spec @ 8158

Revision 8158, 3.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-mechanize
4Version:        0.2.2
5Release:        3%{?_dist_release}
6Summary:        Stateful programmatic web browsing
7Summary(ja):    ウェブ・ブラウジング・プログラム用 Python モジュール
8
9Group:          System Environment/Libraries
10License:        BSD
11URL:            http://wwwsearch.sourceforge.net/mechanize
12Source0:        http://wwwsearch.sourceforge.net/mechanize/src/mechanize-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  python-devel
17BuildRequires:  python-setuptools
18Requires:       python-clientform
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24Stateful programmatic web browsing, after Andy Lester's Perl module
25WWW::Mechanize.
26
27The library is layered: mechanize.Browser (stateful web browser),
28mechanize.UserAgent (configurable URL opener), plus urllib2 handlers.
29
30Features include: ftp:, http: and file: URL schemes, browser history,
31high-level hyperlink and HTML form support, HTTP cookies, HTTP-EQUIV and
32Refresh, Referer [sic] header, robots.txt, redirections, proxies, and
33Basic and Digest HTTP authentication.  mechanize's response objects are
34(lazily-) .seek()able and still work after .close().
35
36Much of the code originally derived from Perl code by Gisle Aas
37(libwww-perl), Johnny Lee (MSIE Cookie support) and last but not least
38Andy Lester (WWW::Mechanize).  urllib2 was written by Jeremy Hylton.
39
40
41%prep
42%setup -q -n mechanize-%{version}
43
44
45%build
46%{__python} setup.py build
47
48
49%install
50%__rm -rf $RPM_BUILD_ROOT
51%{__python} setup.py install --single-version-externally-managed \
52                             -O1 --root=$RPM_BUILD_ROOT
53
54
55%clean
56%__rm -rf $RPM_BUILD_ROOT
57
58
59%files
60%defattr(-,root,root,-)
61%doc COPYING.txt README.txt docs examples
62%{python_sitelib}/*
63
64
65%changelog
66* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.2.2-3
67- rebuild with VineSeed environment
68
69* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.2.2-2
70- rebuild with python-2.7.2
71
72* Tue Aug 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.2.2-1
73- new upstream release
74
75* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
76- rebuild with python-2.6
77
78* Sun Dec 28 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.1.10-1
79- initial build for Vine Linux based on fedora package
80
81* Wed Dec 10 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.1.10-1
82- Update to 0.1.10
83
84* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.1.6-0.3.b
85- Rebuild for Python 2.6
86
87* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 0.1.6-0.2.b
88- Update for python-setuptools changes in rawhide
89
90* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 0.1.6-0.1.b
91- 0.1.6b
92
93* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 0.1.5-0.1.b
94- Rebuild for python 2.5
95- 0.1.5b
96
97* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-5
98- Rebuild for FC6
99
100* Sun Jul  9 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-4
101- Remove unnecessary python-abi requirement
102
103* Wed May 17 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-3
104- Add BuildArch: noarch (bug #192155)
105
106* Sun May 14 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-2
107- Add python-abi Requires
108- Remove noarch
109
110* Thu May 11 2006 Luke Macken <lmacken@redhat.com> - 0.1.1a-1
111- Packaged for Fedora Extras
Note: See TracBrowser for help on using the repository browser.