source: projects/specs/trunk/p/python-markupsafe/python-markupsafe-vl.spec @ 12469

Revision 12469, 2.9 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global with_python3 1
2
3Summary: Implements a XML/HTML/XHTML Markup safe string for Python
4Name: python-markupsafe
5Version: 1.1.1
6Release: 1%{?_dist_release}
7Group: programming
8Vendor: Project Vine
9Distribution: Vine Linux
10
11License: BSD
12URL: https://pypi.python.org/pypi/MarkupSafe
13Source0: https://pypi.python.org/packages/source/M/MarkupSafe/MarkupSafe-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires: python-rpm-macros
18BuildRequires: python-devel python-setuptools python2-rpm-macros
19%if 0%{?with_python3}
20BuildRequires: python3-devel python3-setuptools python3-rpm-macros
21%endif # if with_python3
22
23%description
24A library for safe markup escaping.
25
26
27%if 0%{?with_python3}
28%package -n python3-markupsafe
29Summary: Implements a XML/HTML/XHTML Markup safe string for Python
30Group: programming
31
32%description -n python3-markupsafe
33A library for safe markup escaping.
34%endif #if with_python3
35
36
37%prep
38%setup -q -n MarkupSafe-%{version}
39
40%if 0%{?with_python3}
41%__rm -rf %{py3dir}
42%__cp -a . %{py3dir}
43%endif # with_python3
44
45%build
46export CFLAGS="$RPM_OPT_FLAGS"
47%py2_build
48%if 0%{?with_python3}
49%py3_build
50%endif # with_python3
51
52
53%install
54%__rm -rf $RPM_BUILD_ROOT
55%py2_install
56# C code errantly gets installed
57%__rm $RPM_BUILD_ROOT/%{python_sitearch}/markupsafe/*.c
58%if 0%{?with_python3}
59%py3_install
60%__rm $RPM_BUILD_ROOT/%{python3_sitearch}/markupsafe/*.c
61%endif # with_python3
62
63
64%check
65%{__python2} setup.py test
66
67%if 0%{?with_python3}
68%{__python3} setup.py test
69%endif # with_python3
70
71%clean
72%__rm -rf $RPM_BUILD_ROOT
73
74
75%files
76%defattr(-,root,root,-)
77%license LICENSE*
78%doc CHANGES* README*
79%{python2_sitearch}/*
80
81%if 0%{?with_python3}
82%files -n python3-markupsafe
83%defattr(-,root,root,-)
84%license LICENSE*
85%doc CHANGES* README*
86%{python3_sitearch}/*
87%endif # with_python3
88
89
90%changelog
91* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
92- new upstream release.
93
94* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.0-1
95- new upstream release.
96- added python3 support.
97
98* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12-3
99- rebuild with VineSeed environment
100
101* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12-2
102- rebuild with python-2.7.2
103
104* Thu May  5 2011 IWAI, Masaharu <iwai@alib.jp> 0.12-1
105- new upstream release
106- add Vendor and Distribution tags
107
108* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.9.2-1
109- initial build based on Fedora development
110
111* Fri Jul 23 2010 David Malcolm <dmalcolm@redhat.com> - 0.9.2-4
112- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
113
114* Thu Jun 24 2010 Kyle VanderBeek <kylev@kylev.com> - 0.9.2-3
115- Fix missing setuptools BuildRequires.
116
117* Thu Jun 24 2010 Kyle VanderBeek <kylev@kylev.com> - 0.9.2-2
118- Fixed sitearch and python3 definitions to work better with older Fedora/RHEL.
119
120* Wed Jun 23 2010 Kyle VanderBeek <kylev@kylev.com> - 0.9.2-1
121- Initial version.
Note: See TracBrowser for help on using the repository browser.