source: projects/specs/trunk/p/python-jinja2/python-jinja2-vl.spec @ 12469

Revision 12469, 6.8 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1# async support is valid only on Python >= 3.6
2%bcond_without async
3# Enable building without docs to avoid a circular dependency between this
4# and python-sphinx:
5%bcond_with docs
6
7%global with_python3 1
8
9Summary:        General purpose template engine
10Name:           python-jinja2
11Version:        2.11.2
12Release:        1%{?_dist_release}
13Group:          programming
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17License:        BSD
18URL:            https://jinja.palletsprojects.com/
19Source0:        https://pypi.python.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
20
21BuildArch:      noarch
22BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
23BuildRequires:  python-rpm-macros
24BuildRequires:  python-devel
25BuildRequires:  python2-rpm-macros
26BuildRequires:  python-setuptools
27BuildRequires:  python-markupsafe
28%if %{with docs}
29BuildRequires:  python-sphinx
30%endif # with docs
31Requires:       python-babel >= 0.8
32Requires:       python-markupsafe
33%if 0%{?with_python3}
34BuildRequires:  python3-devel
35BuildRequires:  python3-rpm-macros
36BuildRequires:  python3-setuptools
37BuildRequires:  python3-markupsafe
38# babel isn't py3k ready yet, and is only a weak dependency
39#Requires:       python3-babel >= 0.8
40%endif # with_python3
41
42%description
43Jinja2 is a template engine written in pure Python.  It provides a
44Django inspired non-XML syntax but supports inline expressions and an
45optional sandboxed environment.
46
47If you have any exposure to other text-based template languages, such
48as Smarty or Django, you should feel right at home with Jinja2. It's
49both designer and developer friendly by sticking to Python's
50principles and adding functionality useful for templating
51environments.
52
53
54%if 0%{?with_python3}
55%package -n python3-jinja2
56Summary:        General purpose template engine
57Group:          programming
58Requires:       python3-markupsafe
59Requires:       python3-babel
60
61%description -n python3-jinja2
62Jinja2 is a template engine written in pure Python.  It provides a
63Django inspired non-XML syntax but supports inline expressions and an
64optional sandboxed environment.
65
66If you have any exposure to other text-based template languages, such
67as Smarty or Django, you should feel right at home with Jinja2. It's
68both designer and developer friendly by sticking to Python's
69principles and adding functionality useful for templating
70environments.
71%endif # with_python3
72
73
74%prep
75%setup -q -n Jinja2-%{version}
76# cleanup
77find . -name '*.pyo' -o -name '*.pyc' -delete
78
79
80%build
81%py2_build
82%if %{with docs}
83make -C docs html PYTHONPATH=$(pwd) SPHINXBUILD=sphinx-build-2
84%endif # with docs
85
86%if 0%{?with_python3}
87%py3_build
88%if %{with docs}
89make -C docs html PYTHONPATH=$(pwd) SPHINXBUILD=sphinx-build-3
90%endif # with docs
91%endif # with_python3
92
93
94%install
95%__rm -rf %{buildroot}
96%py2_install
97
98# remove hidden file
99rm -rf docs/_build/html/.buildinfo
100
101# these files are valid only on Python 3.6+
102rm %{buildroot}%{python2_sitelib}/jinja2/asyncsupport.py
103rm %{buildroot}%{python2_sitelib}/jinja2/asyncfilters.py
104
105%if %{with python3}
106%py3_install
107
108# remove hidden file
109rm -rf docs/_build/html/.buildinfo
110
111%if ! %{with async}
112# these files are valid only on Python 3.6+
113rm %{buildroot}%{python3_sitelib}/jinja2/asyncsupport.py
114rm %{buildroot}%{python3_sitelib}/jinja2/asyncfilters.py
115%endif # ! with async
116%endif # with python3
117
118
119%clean
120%__rm -rf %{buildroot}
121
122
123%files
124%defattr(-,root,root,-)
125%doc CHANGES.rst
126%doc ext
127%doc examples
128%license LICENSE*
129%if %{with docs}
130%doc docs/_build/html
131%endif # with docs
132%{python_sitelib}/jinja2
133%{python_sitelib}/Jinja2-%{version}-py*.egg-info
134
135%if 0%{?with_python3}
136%files -n python3-jinja2
137%defattr(-,root,root,-)
138%doc CHANGES.rst
139%doc ext
140%doc examples
141%license LICENSE*
142%if %{with docs}
143%doc docs/_build/html
144%endif # with docs
145%{python3_sitelib}/jinja2
146%{python3_sitelib}/Jinja2-%{version}-py*.egg-info
147%endif # with_python3
148
149
150%changelog
151* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.11.2-1
152- new upstream release.
153
154* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10-2
155- fixed R:.
156
157* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10-1
158- new upstream release.
159- added python3 support.
160
161* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.5-3
162- rebuild with VineSeed environment
163
164* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.5-2
165- rebuild with python-2.7.2
166
167* Thu May  5 2011 IWAI, Masaharu <iwai@alib.jp> 2.5.5-1
168- new upstream release
169- add Project and Distribution tags
170
171* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 2.5.2-1
172- initial build based on Fedora development
173
174* Thu Aug 19 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.2-1
175- Update to upstream version 2.5.2.
176- Package depends on python-markupsafe and is noarch now.
177
178* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.5-4
179- add explicit build-requirement on python-setuptools
180- fix doc disablement for python3 subpackage
181
182* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.5-3
183- support disabling documentation in the build to break a circular build-time
184dependency with python-sphinx; disable docs for now
185
186* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.5-2
187- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
188
189* Tue Jul 13 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.5-1
190- Update to upstream version 2.5.
191- Create python3 subpackage.
192- Minor specfile fixes.
193- Add examples directory.
194- Thanks to Gareth Armstrong for additional hints.
195
196* Wed Apr 21 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.4.1-1
197- Update to 2.4.1.
198
199* Tue Apr 13 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.4-1
200- Update to 2.4.
201
202* Tue Feb 23 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.3.1-1
203- Update to 2.3.1.
204- Docs are built using Sphinx now.
205- Run the testsuite.
206
207* Sat Sep 19 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.2.1-1
208- Update to 2.2.1, mainly a bugfix release.
209- Remove patch no longer needed.
210- Remove conditional for FC-8.
211- Compilation of speedup module has to be explicitly requested now.
212
213* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-3
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
215
216* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
218
219* Sat Jan 10 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.1.1-1
220- Update to 2.1.1 (bugfix release).
221
222* Thu Dec 18 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.1-1
223- Update to 2.1, which fixes a number of bugs.
224  See http://jinja.pocoo.org/2/documentation/changelog#version-2-1.
225
226* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0-3
227- Rebuild for Python 2.6
228
229* Tue Jul 22 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-2
230- Use rpm buildroot macro instead of RPM_BUILD_ROOT.
231
232* Sun Jul 20 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-1
233- Upstream released 2.0.
234
235* Sun Jun 29 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-0.1.rc1
236- Modified specfile from the existing python-jinja package.
Note: See TracBrowser for help on using the repository browser.