source: projects/specs/trunk/p/python-inotify/python-inotify-vl.spec @ 12477

Revision 12477, 6.2 KB checked in by tomop, 4 years ago (diff)

updated 11 packages

libxml2-2.9.10-4

newt-0.52.21-2

python-docutils-0.16-2

python-inotify-0.9.6-3

python-lxml-4.5.2-2

python-pykf-0.3.4-8

python-2.7.18-1

rhpxl-1.9-10

rrdtool-1.7.2-3

system-config-date-1.9.61-3

system-config-network-1.6.2-2

Line 
1%global with_python3 1
2%global oname  pyinotify
3
4Summary:       Monitor filesystem events with Python under Linux
5Name:          python-inotify
6Version:       0.9.6
7Release:       3%{?_dist_release}
8Group:         programming
9Vendor:        Project Vine
10Distribution:  Vine Linux
11
12License:       MIT
13URL:           https://github.com/seb-m/pyinotify
14Source0:       https://github.com/seb-m/pyinotify/archive/0.9.6.tar.gz#/pyinotify-%{version}.tar.gz
15Source1:       %{oname}
16Patch01:       pyinotify-0.9.6-epoint.patch
17
18BuildArch:     noarch
19BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20BuildRequires: python-rpm-macros
21BuildRequires: python-devel python-setuptools python2-rpm-macros
22%if 0%{?with_python3}
23BuildRequires: python3-devel python3-setuptools python3-rpm-macros
24%endif
25
26%description
27This is a Python module for watching filesystems changes. pyinotify
28can be used for various kind of fs monitoring. pyinotify relies on a
29recent Linux Kernel feature (merged in kernel 2.6.13) called
30inotify. inotify is an event-driven notifier, its notifications are
31exported from kernel space to user space.
32
33
34%package       examples
35Summary:       Examples for Python inotify module
36Group:         programming
37Requires:      python-inotify = %{version}-%{release}
38
39%description   examples
40This package includes some examples usage of the Python inotify module.
41
42
43%if 0%{?with_python3}
44%package -n    python3-inotify
45Summary:       Monitor filesystem events with Python under Linux
46Group:         programming
47
48%description -n python3-inotify
49This is a Python 3 module for watching filesystems changes. pyinotify
50can be used for various kind of fs monitoring. pyinotify relies on a
51recent Linux Kernel feature (merged in kernel 2.6.13) called
52inotify. inotify is an event-driven notifier, its notifications are
53exported from kernel space to user space.
54
55This is the Python 3 build of pyinotify
56%endif # if with_python3
57
58
59%prep
60%setup -q -n %{oname}-%{version}
61%patch01 -p1
62sed -i '1c#! %{__python3}' python3/pyinotify.py
63rm -rf %{py3dir}
64cp -a . %{py3dir}
65
66
67%build
68%py2_build
69%if 0%{?with_python3}
70pushd %{py3dir}
71%py3_build
72popd
73%endif
74
75
76%install
77%{__rm} -rf %{buildroot}
78
79%py2_install
80%{__install} -D -m 0755 -p %{SOURCE1} %{buildroot}%{_bindir}/python2-%{oname}
81%{__chmod} 0755 %{buildroot}%{python_sitelib}/%{oname}.py
82
83%if 0%{?with_python3}
84pushd %{py3dir}
85%py3_install
86popd
87%{__install} -D -m 0755 -p %{SOURCE1} %{buildroot}%{_bindir}/python3-%{oname}
88%{__sed} -i -e 's/^python /python3 /' %{buildroot}%{_bindir}/python3-%{oname}
89ln -sf python3-%{oname} %{buildroot}%{_bindir}/%{oname}
90%{__chmod} 0755 %{buildroot}%{python3_sitelib}/%{oname}.py
91%endif
92
93# examples
94%{__install} -d -m 0755 %{buildroot}%{_datadir}/%{oname}
95%{__cp} -a python2/examples/* %{buildroot}%{_datadir}/%{oname}
96
97
98%clean
99%{__rm} -rf %{buildroot}
100
101
102%files
103%defattr(-, root, root, -)
104%license COPYING
105%doc ACKS README.md
106%{_bindir}/python2-%{oname}
107%{python_sitelib}/%{oname}*
108
109%files examples
110%defattr(-, root, root, -)
111%{_datadir}/%{oname}
112
113%if 0%{?with_python3}
114%files -n python3-inotify
115%defattr(-, root, root, -)
116%license COPYING
117%doc ACKS README.md
118%{_bindir}/%{oname}
119%{_bindir}/python3-%{oname}
120%{python3_sitelib}/%{oname}*
121%{python3_sitelib}/__pycache__/%{oname}*
122%endif
123
124
125%changelog
126* Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.6-3
127- fixed dependency.
128
129* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.6-2
130- rebuilt with python-3.8.
131
132* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.6-1
133- new upstream release.
134
135* Sun Feb 8 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.5-1
136- new upstream release.
137
138* Mon Jun 10 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.4-1
139- new upstream release.
140
141* Thu Oct 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.3-2
142- initial build for Vine Linux.
143
144* Wed Feb 01 2012 Terje Rosten <terje.rosten@ntnu.no> - 0.9.3-1
145- 0.9.3
146
147* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
149
150* Mon May 02 2011 Terje Rosten <terje.rosten@ntnu.no> - 0.9.2-1
151- 0.9.2
152
153* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.1-2
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
155
156* Mon Feb 07 2011 Terje Rosten <terje.rosten@ntnu.no> - 0.9.1-1
157- 0.9.1
158
159* Wed Aug 25 2010 Thomas Spura <tomspur@fedoraproject.org> - 0.9.0-3
160- rebuild with python3.2
161  http://lists.fedoraproject.org/pipermail/devel/2010-August/141368.html
162
163* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.9.0-2
164- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
165
166* Sat Jun 19 2010 Terje Rosten <terje.rosten@ntnu.no> - 0.9.0-1
167- 0.9.0
168- Add python 3 subpackage
169- License changed to MIT
170
171* Sun Dec 06 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.8.8-1
172- 0.8.8
173
174* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-2.git20090518
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
176
177* Mon May 18 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.8.6-1.git20090518
178- Update to latest git, fixing bz #500934.
179
180* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2.git20090208
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
182
183* Sun Feb  8 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.8.1-1.git20090208
184- 0.8.1
185
186* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.8.0-4.r
187- Rebuild for Python 2.6
188
189* Sun Jun 22 2008 Terje Rosten <terjeros@phys.ntnu.no> - 0.8.0-3.r
190- rebuild
191
192* Tue Jun 17 2008 Terje Rosten <terjeros@phys.ntnu.no> - 0.8.0-2.r
193- 0.8.0r
194- add wrapper in /usr/bin
195
196* Mon Jun 16 2008 Terje Rosten <terjeros@phys.ntnu.no> - 0.8.0-1.q
197- 0.8.0q
198- Update url, license and source url
199
200* Sat Feb  9 2008 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.1-2
201- Rebuild
202
203* Wed Aug 08 2007 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.1-1
204- New upstream release: 0.7.1
205- Fix license tag
206
207* Mon Jun 25 2007 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.0-3
208- Remove autopath from example package (bz #237464)
209
210* Tue Mar 27 2007 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.0-2
211- Fix email address
212
213* Tue Mar  6 2007 Terje Rosten <terjeros@phys.ntnu.no> - 0.7.0-1
214- Initial build
215
Note: See TracBrowser for help on using the repository browser.