source: projects/specs/trunk/p/python-imagesize/python-imagesize-vl.spec @ 11940

Revision 11940, 2.9 KB checked in by tomop, 5 years ago (diff)

python-sphinx-1.7.9-1 and requirements

Line 
1
2%global pypi_name imagesize
3%global sum  Python module for analyzing image file headers and returning image sizes
4
5Name:           python-%{pypi_name}
6Version:        1.1.0
7Release:        1%{?_dist_release}
8Summary:        %{sum}
9
10License:        MIT
11URL:            https://github.com/shibukawa/imagesize_py
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16Source0:        https://files.pythonhosted.org/packages/source/i/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
17BuildArch:      noarch
18
19BuildRequires:  python-setuptools
20BuildRequires:  python-devel
21BuildRequires:  python-rpm-macros
22
23BuildRequires:  python3-setuptools
24BuildRequires:  python3-devel
25BuildRequires:  python3-rpm-macros
26
27%{?python_provide:%python_provide python2-%{pypi_name}}
28
29%description
30The imagesize package parses image file headers and returns the image sizes.
31
32* PNG
33* JPEG
34* JPEG2000
35* GIF
36
37This is a pure Python library.
38
39%package -n     python3-%{pypi_name}
40Summary:        %{sum}
41%{?python_provide:%python_provide python3-%{pypi_name}}
42
43%description -n python3-%{pypi_name}
44The imagesize package parses image file headers and returns the image sizes.
45
46* PNG
47* JPEG
48* JPEG2000
49* GIF
50
51This is a pure Python library.
52
53%prep
54%autosetup -n %{pypi_name}-%{version}
55# Remove bundled egg-info
56rm -rf %{pypi_name}.egg-info
57
58%build
59%py_build
60%py3_build
61
62%install
63%py3_install
64%py_install
65
66%check
67#py.test-2
68#py.test-3
69
70%files
71%doc README.rst
72%license LICENSE.rst
73%{python_sitelib}/*
74
75%files -n python3-%{pypi_name}
76%doc README.rst
77%license LICENSE.rst
78%{python3_sitelib}/*
79
80%changelog
81* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-1
82- initial build for Vine Linux.
83- new upstream release.
84
85* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
87
88* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0.0-2
89- Rebuilt for Python 3.7
90
91* Mon Apr 16 2018 Avram Lubkin <aviso@rockhopper.net> - 1.0.0-1
92- Updated to 1.0.0 (bz#1545961)
93
94* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-7
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
96
97* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-6
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
99
100* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-5
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
102
103* Tue Dec 13 2016 Stratakis Charalampos <cstratak@redhat.com> - 0.7.1-4
104- Enable tests
105
106* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.7.1-3
107- Rebuild for Python 3.6
108- Disable python3 tests
109
110* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-2
111- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
112
113* Thu May 26 2016 Avram Lubkin <aviso@rockhopper.net> - 0.7.1-1
114- Initial package.
Note: See TracBrowser for help on using the repository browser.