source: projects/specs/trunk/p/python-idna/python-idna-vl.spec @ 12469

Revision 12469, 5.6 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global with_python3 1
2%global srcname idna
3
4Name:           python-%{srcname}
5Version:        2.10
6Release:        1%{?_dist_release}
7Summary:        Internationalized Domain Names in Applications (IDNA)
8Group:          programming
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        BSD and Python and Unicode
13URL:            https://github.com/kjd/idna
14Source0:        https://pypi.io/packages/source/i/%{srcname}/%{srcname}-%{version}.tar.gz
15
16BuildArch:      noarch
17BuildRequires:  python-rpm-macros
18BuildRequires:  python-devel
19BuildRequires:  python-setuptools
20%if 0%{?with_python3}
21BuildRequires:  python%{python3_pkgversion}-rpm-macros
22BuildRequires:  python%{python3_pkgversion}-devel
23BuildRequires:  python%{python3_pkgversion}-setuptools
24%endif # with_python3
25
26%{?python_provide:%python_provide python2-%{srcname}}
27
28%description
29A library to support the Internationalised Domain Names in Applications (IDNA)
30protocol as specified in RFC 5891 <http://tools.ietf.org/html/rfc5891>.  This
31version of the protocol is often referred to as "IDNA2008" and can produce
32different results from the earlier standard from 2003.
33
34The library is also intended to act as a suitable drop-in replacement for the
35"encodings.idna" module that comes with the Python standard library but
36currently only supports the older 2003 specification.
37
38
39%if 0%{?with_python3}
40%package -n python%{python3_pkgversion}-%{srcname}
41Summary:        Internationalized Domain Names in Applications (IDNA)
42Group:          programming
43%{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
44
45%description -n python%{python3_pkgversion}-%{srcname}
46A library to support the Internationalised Domain Names in Applications (IDNA)
47protocol as specified in RFC 5891 <http://tools.ietf.org/html/rfc5891>.  This
48version of the protocol is often referred to as "IDNA2008" and can produce
49different results from the earlier standard from 2003.
50
51The library is also intended to act as a suitable drop-in replacement for the
52"encodings.idna" module that comes with the Python standard library but
53currently only supports the older 2003 specification.
54%endif # with_python3
55
56
57%prep
58%setup -q -n %{srcname}-%{version}
59# Remove bundled egg-info
60rm -rf %{srcname}.egg-info
61
62
63%build
64%py_build
65
66%if 0%{?with_python3}
67%py3_build
68%endif # with_python3
69
70
71%install
72%if 0%{?with_python3}
73%py3_install
74%endif # with_python3
75
76%py_install
77
78
79%check
80#{__python2} setup.py test
81%if 0%{?with_python3}
82#{__python3} setup.py test
83%endif # with_python3
84
85
86%files
87%license LICENSE.rst
88%doc README.rst HISTORY.rst
89%{python_sitelib}/%{srcname}
90%{python_sitelib}/%{srcname}-%{version}-py%{python_version}.egg-info
91
92%if 0%{?with_python3}
93%files -n python%{python3_pkgversion}-%{srcname}
94%license LICENSE.rst
95%doc README.rst HISTORY.rst
96%{python3_sitelib}/%{srcname}
97%{python3_sitelib}/%{srcname}-%{version}-py%{python3_version}.egg-info
98%endif # with_python3
99
100
101%changelog
102* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.10-1
103- new upstream release.
104
105* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7-4
106- initial build for Vine Linux.
107
108* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-3
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
110
111* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7-2
112- Rebuilt for Python 3.7
113
114* Tue Jun 12 2018 Jeremy Cline <jeremy@jcline.org> - 2.7-1
115- Update to v2.7 (rhbz 1589803)
116
117* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-4
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
119
120* Fri Jan 19 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.5-3
121- Update Python 2 dependency declarations to new packaging standards
122  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
123
124* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-2
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
126
127* Tue Mar 07 2017 Jeremy Cline <jeremy@jcline.org> - 2.5-1
128- Update to version 2.5
129
130* Wed Mar 01 2017 Jeremy Cline <jeremy@jcline.org> - 2.4-1
131- Update to version 2.4
132
133* Tue Feb 28 2017 Paul Wouters <pwouters@redhat.com> - 2.3-1
134- Resolves: rhbz#1427499 Update to 2.3 for IDNAError bugfix and memory improvement
135
136* Thu Feb 09 2017 Jeremy Cline <jeremy@jcline.org> - 2.2-1
137- Update to version 2.2 (#1406757)
138
139* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.1-3
140- Rebuild for Python 3.6
141
142* Mon Nov 28 2016 Orion Poplawski <orion@cora.nwra.com> - 2.1-2
143- Ship python2-idna
144- Enable python3 for EPEL
145- Modernize spec
146
147* Mon Oct 17 2016 tom.prince@ualberta.net - 2.1-1
148- Bump version.
149
150* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0-4
151- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
152
153* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0-3
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
155
156* Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 2.0-2
157- Rebuilt for Python3.5 rebuild
158
159* Thu Aug 13 2015 Paul Wouters <pwouters@redhat.com> - 2.0-1
160- Update to 2.0 which is required by python-cryptography
161
162* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
164
165* Wed Dec 31 2014 tom.prince@ualberta.net - 1.0-1
166- Bump version.
167
168* Mon Oct 27 2014 tom.prince@ualberta.net - 0.8-3
169- Update licences.
170
171* Sat Jul 12 2014 tom.prince@ualberta.net - 0.8-2
172- Be more specfic about .egg-info directories.
173- Use python2-devel
174
175* Sat Jul 12 2014 tom.prince@ualberta.net - 0.8-1
176- Initial package.
Note: See TracBrowser for help on using the repository browser.