source: projects/specs/trunk/p/python-idna/python-idna-vl.spec @ 11921

Revision 11921, 5.4 KB checked in by tomop, 5 years ago (diff)

new: python-cryptography and requirements

Line 
1%global with_python3 1
2%global srcname idna
3
4Name:           python-%{srcname}
5Version:        2.7
6Release:        4%{?_dist_release}
7Summary:        Internationalized Domain Names in Applications (IDNA)
8
9License:        BSD and Python and Unicode
10URL:            https://github.com/kjd/idna
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15Source0:        https://pypi.io/packages/source/i/%{srcname}/%{srcname}-%{version}.tar.gz
16BuildArch:      noarch
17
18BuildRequires:  python-rpm-macros
19BuildRequires:  python-devel
20BuildRequires:  python-setuptools
21%if 0%{?with_python3}
22BuildRequires:  python%{python3_pkgversion}-rpm-macros
23BuildRequires:  python%{python3_pkgversion}-devel
24BuildRequires:  python%{python3_pkgversion}-setuptools
25%endif # with_python3
26
27%{?python_provide:%python_provide python2-%{srcname}}
28
29%description
30A library to support the Internationalised Domain Names in Applications (IDNA)
31protocol as specified in RFC 5891 <http://tools.ietf.org/html/rfc5891>.  This
32version of the protocol is often referred to as "IDNA2008" and can produce
33different results from the earlier standard from 2003.
34
35The library is also intended to act as a suitable drop-in replacement for the
36"encodings.idna" module that comes with the Python standard library but
37currently only supports the older 2003 specification.
38
39%if 0%{?with_python3}
40%package -n python%{python3_pkgversion}-%{srcname}
41Summary:        Internationalized Domain Names in Applications (IDNA)
42%{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
43
44%description -n python%{python3_pkgversion}-%{srcname}
45A library to support the Internationalised Domain Names in Applications (IDNA)
46protocol as specified in RFC 5891 <http://tools.ietf.org/html/rfc5891>.  This
47version of the protocol is often referred to as "IDNA2008" and can produce
48different results from the earlier standard from 2003.
49
50The library is also intended to act as a suitable drop-in replacement for the
51"encodings.idna" module that comes with the Python standard library but
52currently only supports the older 2003 specification.
53%endif # with_python3
54
55%prep
56%setup -q -n %{srcname}-%{version}
57# Remove bundled egg-info
58rm -rf %{srcname}.egg-info
59
60%build
61%py_build
62
63%if 0%{?with_python3}
64%py3_build
65%endif # with_python3
66
67%install
68%if 0%{?with_python3}
69%py3_install
70%endif # with_python3
71
72%py_install
73
74%check
75#{__python2} setup.py test
76
77%if 0%{?with_python3}
78#{__python3} setup.py test
79%endif # with_python3
80
81
82%files
83%license LICENSE.rst
84%doc README.rst HISTORY.rst
85%{python_sitelib}/%{srcname}
86%{python_sitelib}/%{srcname}-%{version}-py%{python_version}.egg-info
87
88%if 0%{?with_python3}
89%files -n python%{python3_pkgversion}-%{srcname}
90%license LICENSE.rst
91%doc README.rst HISTORY.rst
92%{python3_sitelib}/%{srcname}
93%{python3_sitelib}/%{srcname}-%{version}-py%{python3_version}.egg-info
94%endif # with_python3
95
96%changelog
97* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7-4
98- initial build for Vine Linux.
99
100* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-3
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
102
103* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7-2
104- Rebuilt for Python 3.7
105
106* Tue Jun 12 2018 Jeremy Cline <jeremy@jcline.org> - 2.7-1
107- Update to v2.7 (rhbz 1589803)
108
109* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-4
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
111
112* Fri Jan 19 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.5-3
113- Update Python 2 dependency declarations to new packaging standards
114  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
115
116* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-2
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
118
119* Tue Mar 07 2017 Jeremy Cline <jeremy@jcline.org> - 2.5-1
120- Update to version 2.5
121
122* Wed Mar 01 2017 Jeremy Cline <jeremy@jcline.org> - 2.4-1
123- Update to version 2.4
124
125* Tue Feb 28 2017 Paul Wouters <pwouters@redhat.com> - 2.3-1
126- Resolves: rhbz#1427499 Update to 2.3 for IDNAError bugfix and memory improvement
127
128* Thu Feb 09 2017 Jeremy Cline <jeremy@jcline.org> - 2.2-1
129- Update to version 2.2 (#1406757)
130
131* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.1-3
132- Rebuild for Python 3.6
133
134* Mon Nov 28 2016 Orion Poplawski <orion@cora.nwra.com> - 2.1-2
135- Ship python2-idna
136- Enable python3 for EPEL
137- Modernize spec
138
139* Mon Oct 17 2016 tom.prince@ualberta.net - 2.1-1
140- Bump version.
141
142* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0-4
143- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
144
145* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0-3
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
147
148* Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 2.0-2
149- Rebuilt for Python3.5 rebuild
150
151* Thu Aug 13 2015 Paul Wouters <pwouters@redhat.com> - 2.0-1
152- Update to 2.0 which is required by python-cryptography
153
154* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
156
157* Wed Dec 31 2014 tom.prince@ualberta.net - 1.0-1
158- Bump version.
159
160* Mon Oct 27 2014 tom.prince@ualberta.net - 0.8-3
161- Update licences.
162
163* Sat Jul 12 2014 tom.prince@ualberta.net - 0.8-2
164- Be more specfic about .egg-info directories.
165- Use python2-devel
166
167* Sat Jul 12 2014 tom.prince@ualberta.net - 0.8-1
168- Initial package.
Note: See TracBrowser for help on using the repository browser.