source: projects/specs/trunk/p/python-funcparserlib/python-funcparserlib-vl.spec @ 12469

Revision 12469, 3.3 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Summary: Recursive descent parsing library for Python based on functional combinators
2Name: python-funcparserlib
3Version: 0.3.6
4Release: 2%{?_dist_release}
5Group: programming
6Vendor: Project Vine
7Distribution: Vine Linux
8
9License: MIT License
10URL: https://pypi.org/project/funcparserlib/
11Source0:https://pypi.python.org/packages/source/f/funcparserlib/funcparserlib-%{version}.tar.gz
12
13BuildArch: noarch
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
15BuildRequires: python-rpm-macros
16BuildRequires: python-devel
17BuildRequires: python-setuptools
18BuildRequires: python2-rpm-macros
19Requires: python
20
21%description
22Parser combinators are just higher-order functions that take parsers as
23their arguments and return them as result values. Parser combinators are:
24
25- First-class values
26- Extremely composable
27- Tend to make the code quite compact
28- Resemble the readable notation of xBNF grammars
29
30Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
31that it's very easy to write them without thinking about look-aheads and
32all that hardcore parsing stuff. But the recursive descent parsing is a
33rather slow method compared to LL(k) or LR(k) algorithms.
34
35So the primary domain for funcparserlib is parsing little languages or
36external DSLs (domain specific languages).
37
38
39%package -n python3-funcparserlib
40Summary: Recursive descent parsing library for Python based on functional combinators
41Group: programming
42BuildRequires: python3-devel
43BuildRequires: python3-setuptools
44BuildRequires: python3-rpm-macros
45Requires: python3
46
47%description -n python3-funcparserlib
48Parser combinators are just higher-order functions that take parsers as
49their arguments and return them as result values. Parser combinators are:
50
51- First-class values
52- Extremely composable
53- Tend to make the code quite compact
54- Resemble the readable notation of xBNF grammars
55
56Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
57that it's very easy to write them without thinking about look-aheads and
58all that hardcore parsing stuff. But the recursive descent parsing is a
59rather slow method compared to LL(k) or LR(k) algorithms.
60
61So the primary domain for funcparserlib is parsing little languages or
62external DSLs (domain specific languages).
63
64
65%prep
66%setup -q -n funcparserlib-%{version}
67
68
69%build
70%py2_build
71%py3_build
72
73
74%install
75%__rm -rf %{buildroot}
76%py2_install
77%py3_install
78
79sed -i \
80        -e 's/except NoParseError, e:/except NoParseError as e:/' \
81        %{buildroot}%{python3_sitelib}/funcparserlib/parser.py
82
83
84%clean
85%__rm -rf %{buildroot}
86
87
88%files
89%defattr(-,root,root,-)
90%license LICENSE
91%doc CHANGES README doc examples
92%{python_sitelib}/funcparserlib-%{version}-py*.egg-info
93%{python_sitelib}/funcparserlib
94
95%files -n python3-funcparserlib
96%defattr(-,root,root,-)
97%license LICENSE
98%doc CHANGES README doc examples
99%{python3_sitelib}/funcparserlib*
100
101
102%changelog
103* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.6-2
104- rebuilt with python-3.8.
105
106* Thu Nov 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.6-1
107- new upstream release.
108- added python3 support.
109
110* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-3
111- rebuild with VineSeed environment
112
113* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-2
114- rebuild with python-2.7.2
115
116* Mon May 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.3.5-1
117- Initial build.
Note: See TracBrowser for help on using the repository browser.