source: projects/specs/trunk/p/python-funcparserlib/python-funcparserlib-vl.spec @ 12316

Revision 12316, 3.2 KB checked in by tomop, 4 years ago (diff)

updated 22 packages

actdiag-0.5.4-1

blockdiag-1.5.4-1

clamav-0.102.1-1

ghostscript-9.27-3

git-2.24.1-1

incron-0.5.12-4

iputils-20190709-2

libsass-3.6.3-1

libxslt-1.1.34-1

nginx-1.16.1-4

nsd-4.2.4-1

nwdiag-1.0.4-1

oniguruma-6.9.4-1

php73-7.3.12-1

python-funcparserlib-0.3.6-1

python-webcolors-1.10-1

samba-4.10.10-1

seqdiag-0.9.6-1

strongswan-5.8.1-1

trousers-0.3.14-1

unbound-1.9.6-1

unrar-free-0.0.1.20140707-1

Line 
1Summary: Recursive descent parsing library for Python based on functional combinators
2Name: python-funcparserlib
3Version: 0.3.6
4Release: 1%{?_dist_release}
5Group: Development/Libraries
6
7Vendor: Project Vine
8Distribution: Vine Linux
9
10License: MIT License
11URL: https://pypi.org/project/funcparserlib/
12Source0:https://pypi.python.org/packages/source/f/funcparserlib/funcparserlib-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
14BuildArch: noarch
15BuildRequires: python-devel
16BuildRequires: python-setuptools
17BuildRequires: python-rpm-macros
18Requires: python
19
20
21%description
22Parser combinators are just higher-order functions that take parsers as
23their arguments and return them as result values. Parser combinators are:
24
25- First-class values
26- Extremely composable
27- Tend to make the code quite compact
28- Resemble the readable notation of xBNF grammars
29
30Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
31that it's very easy to write them without thinking about look-aheads and
32all that hardcore parsing stuff. But the recursive descent parsing is a
33rather slow method compared to LL(k) or LR(k) algorithms.
34
35So the primary domain for funcparserlib is parsing little languages or
36external DSLs (domain specific languages).
37
38
39%package -n python3-funcparserlib
40Summary: Recursive descent parsing library for Python based on functional combinators
41BuildRequires: python3-devel
42BuildRequires: python3-setuptools
43BuildRequires: python3-rpm-macros
44Requires: python3
45
46%description -n python3-funcparserlib
47Parser combinators are just higher-order functions that take parsers as
48their arguments and return them as result values. Parser combinators are:
49
50- First-class values
51- Extremely composable
52- Tend to make the code quite compact
53- Resemble the readable notation of xBNF grammars
54
55Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
56that it's very easy to write them without thinking about look-aheads and
57all that hardcore parsing stuff. But the recursive descent parsing is a
58rather slow method compared to LL(k) or LR(k) algorithms.
59
60So the primary domain for funcparserlib is parsing little languages or
61external DSLs (domain specific languages).
62
63
64%prep
65%setup -q -n funcparserlib-%{version}
66
67%build
68%py_build
69%py3_build
70
71%install
72%__rm -rf %{buildroot}
73%py_install
74%py3_install
75
76sed -i \
77        -e 's/except NoParseError, e:/except NoParseError as e:/' \
78        %{buildroot}%{python3_sitelib}/funcparserlib/parser.py
79
80%clean
81%__rm -rf %{buildroot}
82
83%files
84%defattr(-,root,root,-)
85%license LICENSE
86%doc CHANGES README doc examples
87%{python_sitelib}/funcparserlib-%{version}-py*.egg-info
88%{python_sitelib}/funcparserlib
89
90%files -n python3-funcparserlib
91%defattr(-,root,root,-)
92%license LICENSE
93%doc CHANGES README doc examples
94%{python3_sitelib}/funcparserlib*
95
96%changelog
97* Thu Nov 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.6-1
98- new upstream release.
99- added python3 support.
100
101* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-3
102- rebuild with VineSeed environment
103
104* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-2
105- rebuild with python-2.7.2
106
107* Mon May 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.3.5-1
108- Initial build.
109
110
Note: See TracBrowser for help on using the repository browser.