source: projects/specs/trunk/p/python-funcparserlib/python-funcparserlib-vl.spec @ 12469

Revision 12469, 3.3 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

RevLine 
[3891]1Summary: Recursive descent parsing library for Python based on functional combinators
2Name: python-funcparserlib
[12316]3Version: 0.3.6
[12469]4Release: 2%{?_dist_release}
5Group: programming
[12316]6Vendor: Project Vine
7Distribution: Vine Linux
8
[3891]9License: MIT License
[12316]10URL: https://pypi.org/project/funcparserlib/
11Source0:https://pypi.python.org/packages/source/f/funcparserlib/funcparserlib-%{version}.tar.gz
[12469]12
13BuildArch: noarch
[3891]14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
[12469]15BuildRequires: python-rpm-macros
[3891]16BuildRequires: python-devel
[12316]17BuildRequires: python-setuptools
[12469]18BuildRequires: python2-rpm-macros
[3891]19Requires: python
20
21%description
22Parser combinators are just higher-order functions that take parsers as
23their arguments and return them as result values. Parser combinators are:
24
25- First-class values
26- Extremely composable
27- Tend to make the code quite compact
28- Resemble the readable notation of xBNF grammars
29
30Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
31that it's very easy to write them without thinking about look-aheads and
32all that hardcore parsing stuff. But the recursive descent parsing is a
33rather slow method compared to LL(k) or LR(k) algorithms.
34
35So the primary domain for funcparserlib is parsing little languages or
36external DSLs (domain specific languages).
37
[12316]38
39%package -n python3-funcparserlib
40Summary: Recursive descent parsing library for Python based on functional combinators
[12469]41Group: programming
[12316]42BuildRequires: python3-devel
43BuildRequires: python3-setuptools
44BuildRequires: python3-rpm-macros
45Requires: python3
46
47%description -n python3-funcparserlib
48Parser combinators are just higher-order functions that take parsers as
49their arguments and return them as result values. Parser combinators are:
50
51- First-class values
52- Extremely composable
53- Tend to make the code quite compact
54- Resemble the readable notation of xBNF grammars
55
56Parsers made with funcparserlib are pure-Python LL(*) parsers. It means
57that it's very easy to write them without thinking about look-aheads and
58all that hardcore parsing stuff. But the recursive descent parsing is a
59rather slow method compared to LL(k) or LR(k) algorithms.
60
61So the primary domain for funcparserlib is parsing little languages or
62external DSLs (domain specific languages).
63
64
[3891]65%prep
[12316]66%setup -q -n funcparserlib-%{version}
[3891]67
[12469]68
[3891]69%build
[12469]70%py2_build
[12316]71%py3_build
[3891]72
[12469]73
[3891]74%install
75%__rm -rf %{buildroot}
[12469]76%py2_install
[12316]77%py3_install
[3891]78
[12316]79sed -i \
80        -e 's/except NoParseError, e:/except NoParseError as e:/' \
81        %{buildroot}%{python3_sitelib}/funcparserlib/parser.py
82
[12469]83
[3891]84%clean
85%__rm -rf %{buildroot}
86
[12469]87
[3891]88%files
89%defattr(-,root,root,-)
[12316]90%license LICENSE
91%doc CHANGES README doc examples
92%{python_sitelib}/funcparserlib-%{version}-py*.egg-info
[3891]93%{python_sitelib}/funcparserlib
94
[12316]95%files -n python3-funcparserlib
96%defattr(-,root,root,-)
97%license LICENSE
98%doc CHANGES README doc examples
99%{python3_sitelib}/funcparserlib*
100
[12469]101
[3891]102%changelog
[12469]103* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.6-2
104- rebuilt with python-3.8.
105
[12316]106* Thu Nov 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.6-1
107- new upstream release.
108- added python3 support.
109
[8158]110* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-3
111- rebuild with VineSeed environment
112
[5701]113* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.5-2
114- rebuild with python-2.7.2
115
[3891]116* Mon May 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.3.5-1
117- Initial build.
Note: See TracBrowser for help on using the repository browser.