source: projects/specs/trunk/p/python-ethtool/python-ethtool-vl.spec @ 8158

Revision 8158, 3.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_ver: %define python_ver %(%{__python} -c "import sys ; print sys.version[:3]")}
3
4Summary: Ethernet settings python bindings
5Summary(ja): ethtool の python バインディング
6Name: python-ethtool
7Version: 0.3
8Release: 4%{?_dist_release}
9URL: http://git.kernel.org/?p=linux/kernel/git/acme/python-ethtool.git
10Source: http://userweb.kernel.org/~acme/python-ethtool/%{name}-%{version}.tar.bz2
11License: GPLv2
12Group: System Environment/Libraries
13BuildRequires: python-devel
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20Python bindings for the ethtool kernel interface, that allows querying and
21changing of ethernet card settings, such as speed, port, autonegotiation, and
22PCI locations.
23
24%prep
25%setup -q
26
27%build
28%{__python} setup.py build
29
30%install
31rm -rf %{buildroot}
32%{__python} setup.py install --skip-build --root %{buildroot}
33mkdir -p %{buildroot}%{_sbindir}
34cp -p pethtool.py %{buildroot}%{_sbindir}/pethtool
35cp -p pifconfig.py %{buildroot}%{_sbindir}/pifconfig
36
37%clean
38rm -rf %{buildroot}
39
40%files
41%defattr(-,root,root)
42%doc COPYING
43%{_sbindir}/pethtool
44%{_sbindir}/pifconfig
45%{python_sitearch}/ethtool.so
46%if "%{python_ver}" >= "2.5"
47%{python_sitearch}/*.egg-info
48%endif
49
50%changelog
51* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3-4
52- rebuild with VineSeed environment
53
54* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3-3
55- rebuild with python-2.7.2
56
57* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3-2
58- rebuild with python-2.6
59
60* Wed Sep 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1
61- initial build for Vine Linux
62
63* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-5
64- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
65
66* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-4
67- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
68
69* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.3-3
70- Rebuild for Python 2.6
71
72* Fri Sep  5 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.3-2
73- Rewrote build and install sections as part of the fedora review process
74  BZ #459549
75
76* Tue Aug 26 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.3-1
77- Add get_flags method from the first python-ethtool contributor, yay
78- Add pifconfig command, that mimics the ifconfig tool using the
79  bindings available
80
81* Wed Aug 20 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.2-1
82- Expand description and summary fields, as part of the fedora
83  review process.
84
85* Tue Jun 10 2008 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.1-3
86- add dist to the release tag
87
88* Tue Dec 18 2007 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.1-2
89- First build into MRG repo
90
91* Tue Dec 18 2007 Arnaldo Carvalho de Melo <acme@redhat.com> - 0.1-1
92- Get ethtool code from rhpl 0.212
Note: See TracBrowser for help on using the repository browser.