source: projects/specs/trunk/p/python-enum34/python-enum34-vl.spec @ 11921

Revision 11921, 4.7 KB checked in by tomop, 5 years ago (diff)

new: python-cryptography and requirements

Line 
1%if 0%{?fedora} || 0%{?rhel} > 7
2# Should not build for Python 3 for Fedora releases that provide
3# Python 3.4 (Fedora 22 or higher?).
4%endif
5
6Name:           python-enum34
7Version:        1.1.6
8Release:        8%{?_dist_release}
9Group:          Development/Libraries
10Summary:        Backport of Python 3.4 Enum
11License:        BSD
12BuildArch:      noarch
13URL:            https://pypi.python.org/pypi/enum34
14
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18Source0:        https://files.pythonhosted.org/packages/source/e/enum34/enum34-%{version}.tar.gz
19
20BuildRequires:  python-devel python-setuptools
21BuildRequires:  python-rpm-macros
22
23%{?python_provide:%python_provide python2-enum34}
24
25%global _description\
26Python 3.4 introduced official support for enumerations.  This is a\
27backport of that feature to Python 3.3, 3.2, 3.1, 2.7, 2.5, 2.5, and 2.4.\
28\
29An enumeration is a set of symbolic names (members) bound to unique,\
30constant values. Within an enumeration, the members can be compared by\
31identity, and the enumeration itself can be iterated over.\
32\
33This module defines two enumeration classes that can be used to define\
34unique sets of names and values: Enum and IntEnum. It also defines one\
35decorator, unique, that ensures only unique member names are present\
36in an enumeration.\
37
38
39%description %_description
40
41
42%prep
43%setup -q -n enum34-%{version}
44
45
46%build
47%py_build
48
49%check
50pushd %{buildroot}/%{python_sitelib}
51PYTHONPATH=".:${PYTHONPATH}" %{__python} enum/test.py
52popd
53
54%install
55%py_install
56# remove docs from sitelib, we'll put them in doc dir instead
57rm -rf %{buildroot}%{python_sitelib}/enum/{LICENSE,README,doc}
58
59%files
60%license enum/LICENSE
61%doc PKG-INFO enum/README enum/doc/enum.rst
62%{python_sitelib}/*
63
64%changelog
65* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.6-8
66- initial build for Vine Linux.
67
68* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.6-7
69- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
70
71* Fri Apr 20 2018 Orion Poplawski <orion@nwra.com> - 1.1.6-6
72- Minor spec cleanup
73- Use %%license
74
75* Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.1.6-5
76- Update Python 2 dependency declarations to new packaging standards
77  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
78
79* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.6-4
80- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
81
82* Sat Aug 19 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.1.6-3
83- Python 2 binary package renamed to python2-enum34
84  See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
85
86* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.6-2
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
88
89* Thu Jun 15 2017 Eric Smith <brouhaha@fedoraproject.org> 1.1.6-1
90- New upstream version 1.1.6 (#1441428)
91- Update upstream tarball dir
92- Convert to newer build marcos
93- Update tests to pass in new build
94- These RPM spec changes were all provided by Greg Hellings.
95
96* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-7
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
98
99* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-6
100- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
101
102* Wed Feb 24 2016 Robert Kuska <rkuska@redhat.com> - 1.0.4-5
103- Remove python3 subpackage, enum34 is now provided by python3
104
105* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-4
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
107
108* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-3
109- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
110
111* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-2
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
113
114* Wed Apr 08 2015 Eric Smith <brouhaha@fedoraproject.org> 1.0.4-1
115- Updated to latest upstream.
116
117* Mon Jul 21 2014 Matěj Cepl <mcepl@redhat.com> - 1.0-4
118- No, we don’t have python3 in RHEL-7 :'(
119
120* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
122
123* Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 1.0-2
124- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
125
126* Mon May 26 2014 Eric Smith <brouhaha@fedoraproject.org> 1.0-1
127- Updated to latest upstream.
128
129* Mon Mar 17 2014 Eric Smith <brouhaha@fedoraproject.org> 0.9.23-1
130- Updated to latest upstream.
131- Spec updated per review comments (#1033975).
132
133* Sun Nov 24 2013 Eric Smith <brouhaha@fedoraproject.org> 0.9.19-1
134- Initial version.
Note: See TracBrowser for help on using the repository browser.