source: projects/specs/trunk/p/python-dulwich/python-dulwich-vl.spec @ 7378

Revision 7378, 3.9 KB checked in by kudoh, 11 years ago (diff)
Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3%global srcname dulwich
4
5Name:           python-%{srcname}
6Version:        0.8.7
7Release:        1%{?_dist_release}
8Summary:        A python implementation of the Git file formats and protocols
9Summary(ja):    Git ファイルフォーマットとプロトコルの python 実装
10
11Group:          Development/Libraries
12License:        GPLv2+
13URL:            http://samba.org/~jelmer/dulwich/
14Source0:        http://samba.org/~jelmer/%{srcname}/%{srcname}-%{version}.tar.gz
15#Patch0:         01_less_strict_index_tests
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires:  python-devel
20BuildRequires:  python-setuptools
21BuildRequires:  python-nose
22#BuildRequires:  python-unittest2
23
24
25%description
26Dulwich is a pure-Python implementation of the Git file formats and
27protocols. The project is named after the village in which Mr. and
28Mrs. Git live in the Monty Python sketch.
29
30
31%prep
32%setup -q -n %{srcname}-%{version}
33#%patch0 -p1
34
35
36%build
37CFLAGS="%{optflags}" %{__python} setup.py build
38
39
40%install
41rm -rf %{buildroot}
42%{__python} setup.py install --skip-build --root %{buildroot}
43
44
45%clean
46rm -rf %{buildroot}
47
48
49%check
50cd dulwich/tests
51#nosetests test*.py
52nosetests test_blackbox.py
53nosetests test_client.py
54#nosetests test_diff_tree.py
55nosetests test_fastexport.py
56nosetests test_file.py
57nosetests test_index.py
58nosetests test_lru_cache.py
59nosetests test_objects.py
60nosetests test_object_store.py
61nosetests test_patch.py
62nosetests test_pack.py
63nosetests test_protocol.py
64nosetests test_repository.py
65nosetests test_server.py
66nosetests test_web.py
67
68
69%files
70%defattr(-,root,root,-)
71%doc AUTHORS COPYING HACKING NEWS README docs/
72%{_bindir}/dul-*
73%{_bindir}/%{srcname}
74%{python_sitearch}/%{srcname}*
75%exclude %{python_sitearch}/%{srcname}/tests*
76
77
78%changelog
79* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.7-1
80- new upstream release
81
82* Fri Nov 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.6-1
83- new upstream release
84- deleted Patch0
85
86* Wed May 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.5-2
87- dropt BuildRequires: python-unittest2
88
89* Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.5-1
90- new upstream release
91- added Patch0 from Debian sid
92
93* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.3-2
94- rebuild with python-2.7.2
95
96* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.3-1
97- initial build for Vine Linux
98
99* Sun Apr 17 2011 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
100- Updated to new upstream version 0.7.1
101
102* Fri Mar 11 2011 Fabian Affolter <fabian@bernewireless.net> - 0.7.0-3
103- Test section reworked
104
105* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
107
108* Thu Jan 27 2011 Fabian Affolter <fabian@bernewireless.net> - 0.7.0-1
109- Updated to new upstream version 0.7.0
110
111* Sat Nov 08 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
112- Filtering added
113- Updated to new upstream version 0.6.2
114
115* Wed Sep 01 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
116- Fixed grep parameter
117- Run all test now
118- Updated to new upstream version 0.6.1
119
120* Sat Jul 03 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.0-3
121- Removed exec permission from test.py
122- Added python-nose
123
124* Fri Jun 25 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.0-2
125- Changed summary
126- Change to srcname
127- Fixed rpmlint issue
128- Added check section and exclude the tests directory
129
130* Thu Jun 17 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.0-1
131- Fixed some rpmlint issues
132- Added docs directory
133- Updated to new upstream version 0.6.0
134
135* Wed Apr 28 2010 Fabian Affolter <fabian@bernewireless.net> - 0.5.0-2
136- Doc added
137- Added BR setuptools
138
139* Fri Apr 16 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> 0.5.0-1
140- Initial package
Note: See TracBrowser for help on using the repository browser.