source: projects/specs/trunk/p/python-dulwich/python-dulwich-vl.spec @ 5525

Revision 5525, 3.3 KB checked in by kudoh, 12 years ago (diff)
Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3%global srcname dulwich
4
5Name:           python-%{srcname}
6Version:        0.8.3
7Release:        1%{?_dist_release}
8Summary:        A python implementation of the Git file formats and protocols
9Summary(ja):    Git ファイルフォーマットとプロトコルの python 実装
10
11Group:          Development/Libraries
12License:        GPLv2+
13URL:            http://samba.org/~jelmer/dulwich/
14Source0:        http://samba.org/~jelmer/%{srcname}/%{srcname}-%{version}.tar.gz
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  python-devel
18BuildRequires:  python-setuptools
19BuildRequires:  python-nose
20BuildRequires:  python-unittest2
21
22
23%description
24Dulwich is a pure-Python implementation of the Git file formats and
25protocols. The project is named after the village in which Mr. and
26Mrs. Git live in the Monty Python sketch.
27
28
29%prep
30%setup -q -n %{srcname}-%{version}
31
32
33%build
34CFLAGS="%{optflags}" %{__python} setup.py build
35
36
37%install
38rm -rf %{buildroot}
39%{__python} setup.py install --skip-build --root %{buildroot}
40
41
42%clean
43rm -rf %{buildroot}
44
45
46%check
47cd dulwich/tests
48#nosetests test*.py
49nosetests test_blackbox.py
50nosetests test_client.py
51#nosetests test_diff_tree.py
52nosetests test_fastexport.py
53nosetests test_file.py
54nosetests test_index.py
55nosetests test_lru_cache.py
56nosetests test_objects.py
57nosetests test_object_store.py
58nosetests test_patch.py
59nosetests test_pack.py
60nosetests test_protocol.py
61nosetests test_repository.py
62nosetests test_server.py
63nosetests test_web.py
64
65
66%files
67%defattr(-,root,root,-)
68%doc AUTHORS COPYING HACKING NEWS README docs/
69%{_bindir}/dul-*
70%{_bindir}/%{srcname}
71%{python_sitearch}/%{srcname}*
72%exclude %{python_sitearch}/%{srcname}/tests*
73
74
75%changelog
76* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.3-1
77- initial build for Vine Linux
78
79* Sun Apr 17 2011 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
80- Updated to new upstream version 0.7.1
81
82* Fri Mar 11 2011 Fabian Affolter <fabian@bernewireless.net> - 0.7.0-3
83- Test section reworked
84
85* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-2
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
87
88* Thu Jan 27 2011 Fabian Affolter <fabian@bernewireless.net> - 0.7.0-1
89- Updated to new upstream version 0.7.0
90
91* Sat Nov 08 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
92- Filtering added
93- Updated to new upstream version 0.6.2
94
95* Wed Sep 01 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
96- Fixed grep parameter
97- Run all test now
98- Updated to new upstream version 0.6.1
99
100* Sat Jul 03 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.0-3
101- Removed exec permission from test.py
102- Added python-nose
103
104* Fri Jun 25 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.0-2
105- Changed summary
106- Change to srcname
107- Fixed rpmlint issue
108- Added check section and exclude the tests directory
109
110* Thu Jun 17 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.0-1
111- Fixed some rpmlint issues
112- Added docs directory
113- Updated to new upstream version 0.6.0
114
115* Wed Apr 28 2010 Fabian Affolter <fabian@bernewireless.net> - 0.5.0-2
116- Doc added
117- Added BR setuptools
118
119* Fri Apr 16 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> 0.5.0-1
120- Initial package
Note: See TracBrowser for help on using the repository browser.