source: projects/specs/trunk/p/python-dulwich/python-dulwich-vl.spec @ 10328

Revision 10328, 4.1 KB checked in by kudoh, 8 years ago (diff)

new upstream release

Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3%global srcname dulwich
4
5Name:           python-%{srcname}
6Version:        0.13.0
7Release:        1%{?_dist_release}
8Summary:        A python implementation of the Git file formats and protocols
9Summary(ja):    Git ファイルフォーマットとプロトコルの python 実装
10
11Group:          Development/Libraries
12License:        GPLv2+
13URL:            http://samba.org/~jelmer/dulwich/
14Source0:        http://samba.org/~jelmer/%{srcname}/%{srcname}-%{version}.tar.gz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  python-devel
19BuildRequires:  python-setuptools
20BuildRequires:  python-nose
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26Dulwich is a pure-Python implementation of the Git file formats and
27protocols. The project is named after the village in which Mr. and
28Mrs. Git live in the Monty Python sketch.
29
30
31%prep
32%setup -q -n %{srcname}-%{version}
33
34
35%build
36CFLAGS="%{optflags}" %{__python} setup.py build
37
38
39%install
40rm -rf %{buildroot}
41%{__python} setup.py install --skip-build --root %{buildroot}
42
43rm -rf %{buildroot}%{python_sitearch}/docs
44
45
46%clean
47rm -rf %{buildroot}
48
49
50%check
51cd dulwich/tests
52#nosetests test*.py
53nosetests test_blackbox.py
54nosetests test_client.py
55#nosetests test_diff_tree.py
56nosetests test_fastexport.py
57nosetests test_file.py
58nosetests test_index.py
59nosetests test_lru_cache.py
60nosetests test_objects.py
61nosetests test_object_store.py
62nosetests test_patch.py
63nosetests test_pack.py
64nosetests test_protocol.py
65nosetests test_repository.py
66nosetests test_server.py
67nosetests test_web.py
68
69
70%files
71%defattr(-,root,root,-)
72%doc AUTHORS COPYING NEWS docs/
73%{_bindir}/dul-*
74%{_bindir}/%{srcname}
75%{python_sitearch}/%{srcname}*
76%exclude %{python_sitearch}/%{srcname}/tests*
77
78
79%changelog
80* Tue May 24 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.0-1
81- new upstream release
82- fixed %%doc
83
84* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.9.4-1
85- new upstream release
86
87* Sat Jul 20 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.0-1
88- new upstream release
89
90* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.7-1
91- new upstream release
92
93* Fri Nov 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.6-1
94- new upstream release
95- deleted Patch0
96
97* Wed May 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.5-2
98- dropt BuildRequires: python-unittest2
99
100* Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.5-1
101- new upstream release
102- added Patch0 from Debian sid
103
104* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.3-2
105- rebuild with python-2.7.2
106
107* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.3-1
108- initial build for Vine Linux
109
110* Sun Apr 17 2011 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
111- Updated to new upstream version 0.7.1
112
113* Fri Mar 11 2011 Fabian Affolter <fabian@bernewireless.net> - 0.7.0-3
114- Test section reworked
115
116* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-2
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
118
119* Thu Jan 27 2011 Fabian Affolter <fabian@bernewireless.net> - 0.7.0-1
120- Updated to new upstream version 0.7.0
121
122* Mon Nov 08 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
123- Filtering added
124- Updated to new upstream version 0.6.2
125
126* Wed Sep 01 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
127- Fixed grep parameter
128- Run all test now
129- Updated to new upstream version 0.6.1
130
131* Sat Jul 03 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.0-3
132- Removed exec permission from test.py
133- Added python-nose
134
135* Fri Jun 25 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.0-2
136- Changed summary
137- Change to srcname
138- Fixed rpmlint issue
139- Added check section and exclude the tests directory
140
141* Thu Jun 17 2010 Fabian Affolter <fabian@bernewireless.net> - 0.6.0-1
142- Fixed some rpmlint issues
143- Added docs directory
144- Updated to new upstream version 0.6.0
145
146* Wed Apr 28 2010 Fabian Affolter <fabian@bernewireless.net> - 0.5.0-2
147- Doc added
148- Added BR setuptools
149
150* Fri Apr 16 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> 0.5.0-1
151- Initial package
Note: See TracBrowser for help on using the repository browser.