source: projects/specs/trunk/p/python-docutils/python-docutils-vl.spec @ 1746

Revision 1746, 3.7 KB checked in by owa, 14 years ago (diff)

replaced docutils with python-docutils

Line 
1%define srcname docutils
2Summary: an open-source text processing system written in Python
3Summary(ja): Pythonで書かれたテキスト処理システム
4Name: python-%{srcname}
5Version: 0.6
6Release: 2%{?_dist_release}
7Group: Development/Languages
8License: Public Domain and MIT and Python and GPLv2
9URL: http://docutils.sourceforge.net/
10Source0: http://prdownloads.sourceforge.net/%{srcname}/%{srcname}-%{version}.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12BuildArch: noarch
13BuildRequires: python-devel
14BuildRequires: python-setuptools
15Requires: python
16Requires: python-imaging
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: shaolin, munepi, owa
21Provides: docutils = %{version}-%{release}
22Obsoletes: docutils <= 0.5
23
24%description
25Docutils is an open-source text processing system for processing
26plaintext documentation into useful formats, such as HTML or LaTeX.
27It includes reStructuredText, the easy to read, easy to use,
28what-you-see-is-what-you-get plaintext markup language.
29
30%description -l ja
31Docutilsはオープンソースのテキスト処理システムで、プレーンテキストの
32文書をHTMLやLaTeXなどの使いやすいフォーマットに変換するものです。
33読みやすく使いやすくWYSIWYGなプレーンテキストのマークアップ言語である
34reStructuresTextを含んでいます。
35
36
37%prep
38%setup -q -n %{srcname}-%{version}
39
40# Remove a shebang from one of the library files
41%__sed -i -e '/#! *\/usr\/bin\/.*python.*/{1D}' docutils/readers/python/pynodes.py
42
43
44%build
45CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
46
47
48%install
49%__rm -rf $RPM_BUILD_ROOT
50%{__python} setup.py install --skip-build --root=$RPM_BUILD_ROOT
51
52for file in %{buildroot}/%{_bindir}/*.py; do
53    mv $file `dirname $file`/`basename $file .py`
54    ln -sf `basename $file .py` `dirname $file`/`basename $file`
55done
56
57# We want the licenses but don't need this build file
58%__rm -f licenses/docutils.conf
59
60# docutils only installs this if its not already on the system.  Due to the
61# possibility that a previous version of docutils may be installed, we install
62# it manually here.
63install -D -m644 extras/roman.py ${RPM_BUILD_ROOT}/%{python_sitelib}/roman.py
64
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69
70%files
71%defattr(-,root,root)
72%doc BUGS.txt HISTORY.txt RELEASE-NOTES.txt docs COPYING.txt THANKS.txt FAQ.txt README.txt
73%doc licenses docs tools/editors
74%{_bindir}/*
75%{python_sitelib}/%{srcname}/
76%{python_sitelib}/roman.*
77%{python_sitelib}/docutils-*.egg-info
78
79
80%changelog
81* Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6-2
82- changed package-name to python-docutils from docutils
83- added Provides: docutils = %%{version}-%%{release}
84- added Obsoletes: docutils <= 0.5
85- added BR: python-setuptools
86- added RQ: python-imaging
87  (merged from '* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> python-docutils-0.6-1')
88
89* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.5-3
90- rebuilt with python-2.6.4
91
92* Thu Aug  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5-2
93- rename /usr/bin/*.py to /usr/bin/*
94  (keep symlinking to *.py for compatibility - should be removed in the future)
95
96* Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 0.5-1
97- updated docutils to 0.5
98- added BuildArch: noarch
99
100* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
101- rebuilt with python-2.5.2
102- applied new versioning policy and spec in utf-8
103
104* Thu Jan 31 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-0vl4
105- defined python_sitelib by using distutils.sysconfig.get_python_lib()
106- updated module directory with platform-independent path
107- added script to install extras/roman.py (missing if it's already on the system)
108
109* Sun Sep 9 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.4-0vl2
110- initial build for Vine Linux
111
Note: See TracBrowser for help on using the repository browser.