source: projects/specs/trunk/p/python-docutils/python-docutils-vl.spec @ 1741

Revision 1741, 6.8 KB checked in by munepi, 14 years ago (diff)

NEW calibre: updated/added calibre's dependencies

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3%define srcname docutils
4
5Name:           python-%{srcname}
6Version:        0.6
7Release:        1%{?_dist_release}
8Summary:        System for processing plaintext documentation
9
10Group:          Development/Languages
11# See COPYING.txt for information
12License:        Public Domain and MIT and Python and GPLv2
13URL:            http://docutils.sourceforge.net
14Source0:        http://downloads.sourceforge.net/docutils/%{srcname}-%{version}.tar.gz
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildArch:       noarch
17
18BuildRequires:  python-devel
19BuildRequires: python-setuptools
20
21Requires: python-imaging
22Provides: docutils = %{version}-%{release}
23
24%description
25The Docutils project specifies a plaintext markup language, reStructuredText,
26which is easy to read and quick to write.  The project includes a python
27library to parse rST files and transform them into other useful formats such
28as HTML, XML, and TeX as well as commandline tools that give the enduser
29access to this functionality.
30
31Currently, the library supports parsing rST that is in standalone files and
32PEPs (Python Enhancement Proposals).  Work is underway to parse rST from
33Python inline documentation modules and packages.
34
35%prep
36%setup -q -n %{srcname}-%{version}
37
38# Remove a shebang from one of the library files
39%__sed -i -e '/#! *\/usr\/bin\/.*python.*/{1D}' docutils/readers/python/pynodes.py
40
41%build
42CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
43
44
45%install
46rm -rf %{buildroot}
47
48%{__python} setup.py install --skip-build --root %{buildroot}
49
50for file in %{buildroot}/%{_bindir}/*.py; do
51    mv $file `dirname $file`/`basename $file .py`
52done
53
54# We want the licenses but don't need this build file
55%__rm -f licenses/docutils.conf
56
57# docutils only installs this if its not already on the system.  Due to the
58# possibility that a previous version of docutils may be installed, we install
59# it manually here.
60file=roman.py
61extradest=%{python_sitelib}
62fullextradest=%{buildroot}/$extradest
63install -D -m 0644 extras/$file $fullextradest/$file
64
65%clean
66%__rm -rf %{buildroot}
67
68%files
69%defattr(-,root,root,-)
70%doc BUGS.txt COPYING.txt FAQ.txt HISTORY.txt README.txt RELEASE-NOTES.txt
71%doc THANKS.txt licenses docs tools/editors
72%{_bindir}/*
73%{python_sitelib}/docutils/
74%{python_sitelib}/roman.*
75%{python_sitelib}/*egg-info
76
77%changelog
78* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.6-1
79- initial build based on Fedora development
80
81* Tue Jan 19 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-1
82- Update for 0.6 release.
83- Switch from setuptools installed egg-info to distutils egg-info.  Note that
84  this works because we're also changing docutils version.  To do this between
85  0.5-4 and 0.5-5, for instance, we'd need to have %%preun scriptlet to get rid
86  of the egg-info directory.
87
88* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5-4
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
90
91* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5-3
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
93
94* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
95- Rebuild for Python 2.6
96
97* Wed Aug 6 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.5-1
98- New upstream version.
99
100* Mon Mar 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4-8
101- Use regular Requires syntax for python-imaging as missingok is just wrong.
102
103* Thu Sep 27 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4-7
104- Build egg info.
105
106* Mon Aug 13 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4-6
107- Last version had both the old and new rst.el.  Try again with only
108  the new one.
109
110* Sun Aug 12 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4-5
111- Make License tag conform to the new Licensing Policy.
112- Fix the rst emacs mode (RH BZ 250100)
113
114* Sat Dec 09 2006 Toshio Kuratomi <toshio-tiki-lounge.com> 0.4-4
115- Bump and rebuild for python 2.5 in devel.
116
117* Tue Aug 29 2006 Toshio Kuratomi <toshio-tiki-lounge.com> 0.4-3
118- Bump for FC6 rebuild.
119- Remove python byte compilation as this is handled automatically in FC4+.
120- No longer %%ghost .pyo files.
121 
122* Thu Feb 16 2006 Toshio Kuratomi <toshio-tiki-lounge.com> 0.4-2
123- Bump and rebuild for FC5.
124 
125* Sun Jan 15 2006 Toshio Kuratomi <toshio-tiki-lounge.com> 0.4-1
126- Update to 0.4.
127- Scripted the listing of files in the python module.
128- Add a missingok requirement on python-imaging as docutils can make use of
129  it when converting to formats that have images.
130 
131* Tue Jun 7 2005 Toshio Kuratomi <toshio-tiki-lounge.com> 0.3.9-1
132- Update to version 0.3.9.
133- Use a dist tag as there aren't any differences between supported fc
134  releases (FC3, FC4, devel.)
135
136* Thu May 12 2005 Toshio Kuratomi <toshio-tiki-lounge.com> 0.3.7-7
137- Bump version and rebuild to sync across architectures.
138
139* Sun Mar 20 2005 Toshio Kuratomi <toshio-tiki-lounge.com> 0.3.7-6
140- Rebuild for FC4t1
141
142* Sat Mar 12 2005 Toshio Kuratomi <toshio.tiki-lounge.com> 0.3.7-5
143- Add GPL as a license (mschwendt)
144- Use versioned Obsoletes and Provides (mschwendt)
145
146* Fri Mar 04 2005 Toshio Kuratomi <toshio.tiki-lounge.com> 0:0.3.7-4
147- Rename to python-docutils per the new packaging guidelines.
148
149* Wed Jan 12 2005 Toshio Kuratomi <toshio.tiki-lounge.com> 0:0.3.7-0.fdr.3
150- Really install roman.py and build roman.py[co].  Needed to make sure I have
151  docutils installed to test that it builds roman.py fine in that case.
152
153* Tue Jan 11 2005 Toshio Kuratomi <toshio.tiki-lounge.com> 0:0.3.7-0.fdr.2
154- Special case roman.py to always install.  This is the behaviour we want
155  unless something else provides it.  Will need to watch out for this in
156  future Core and Extras packages, but the auto detection code makes it
157  possible that builds will not be reproducible if roman.py were installed
158  from another package.... Lesser of two evils here.
159- Provide python-docutils in case that package were preinstalled from
160  another repository.
161 
162* Fri Dec 31 2004 Toshio Kuratomi <toshio.tiki-lounge.com> 0:0.3.7-0.fdr.1
163- Update to 0.3.7
164- Rename from python-docutils to docutils.
165- Make roman.py optionally a part of the files list.  In FC2, this will be
166  included.  In FC3, this won't.
167- BuildConflict with self since the docutils build detects the presence
168  of roman.py and doesn't reinstall itself.
169 
170* Mon Aug 9 2004 Toshio Kuratomi <toshio.tiki-lounge.com> 0:0.3.5-0.fdr.1
171- Update to 0.3.5.
172- Update spec style to latest fedora-rpmdevtools.
173- Merge everything into a single package.  There isn't very much space
174  advantage to having separate packages in a package this small and in
175  this case, the documentation on using docutils as a library is also a
176  good example of how to write in ReSructuredText.
177
178* Sat Jan 10 2004 Michel Alexandre Salim <salimma[AT]users.sf.net> 0:0.3-0.fdr.1
179- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.