source: projects/specs/trunk/p/python-dns/python-dns-vl.spec @ 8158

Revision 8158, 9.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Name:           python-dns
2Version:        1.10.0
3Release:        3%{?_dist_release}
4Summary:        DNS toolkit for Python
5Summary(ja):    Python 用 DNS ツールキット
6
7Group:          Development/Languages
8License:        MIT
9URL:            http://www.dnspython.org/
10Source0:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
11Source1:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildArch:      noarch
15BuildRequires: python-setuptools
16BuildRequires: python-devel
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22dnspython is a DNS toolkit for Python. It supports almost all record
23types. It can be used for queries, zone transfers, and dynamic
24updates. It supports TSIG authenticated messages and EDNS0.
25
26dnspython provides both high and low level access to DNS. The high
27level classes perform queries for data of a given name, type, and
28class, and return an answer set. The low level classes allow direct
29manipulation of DNS zones, messages, names, and records.
30
31%prep
32%setup0 -q -n dnspython-%{version}
33
34# strip executable permissions so that we don't pick up dependencies
35# from documentation
36find examples -type f | xargs chmod a-x
37
38%build
39CFLAGS="%{optflags}" %{__python} -c 'import setuptools; execfile("setup.py")' build
40
41%install
42rm -rf %{buildroot}
43%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root %{buildroot}
44
45%check
46pushd tests
47# skip one test because it queries the network
48for py in *.py
49do
50        if [ $py != resolver.py ]
51        then
52                PYTHONPATH=%{buildroot}%{python_sitelib} %{__python} $py
53        fi
54done
55
56%clean
57rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root,-)
61%doc ChangeLog LICENSE README examples
62
63%{python_sitelib}/*egg-info
64%{python_sitelib}/dns
65
66%changelog
67* Sun Jan 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3
68- rebuild with VineSeed environment
69
70* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
71- add BR: python-devel, python
72
73* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
74- new upstream release
75
76* Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
77- initial build for Vine Linux
78
79* Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
80-
81- dnspython 1.9.4 has been released and is available at
82- http://www.dnspython.org/kits/1.9.4/
83-
84- There is no new functionality in this release; just a few bug fixes
85- in RRSIG and SIG code.
86-
87- I will be eliminating legacy code for earlier versions of DNSSEC in a
88- future release of dnspython.
89
90* Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
91-
92- New since 1.9.2:
93-
94-     A boolean parameter, 'raise_on_no_answer', has been added to
95- the query() methods.  In no-error, no-data situations, this
96- parameter determines whether NoAnswer should be raised or not.
97- If True, NoAnswer is raised.  If False, then an Answer()
98- object with a None rrset will be returned.
99-
100- Resolver Answer() objects now have a canonical_name field.
101-
102- Rdata now have a __hash__ method.
103-
104- Bugs fixed since 1.9.2:
105-
106-        Dnspython was erroneously doing case-insensitive comparisons
107- of the names in NSEC and RRSIG RRs.
108-
109- We now use "is" and not "==" when testing what section an RR
110- is in.
111-
112- The resolver now disallows metaqueries.
113
114* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
116
117* Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
118- It's brown paper bag time :) The fix for the import problems was
119- actually bad, but didn't show up in testing because the test suite's
120- conditional importing code hid the problem.
121-
122- Any, 1.9.2 is out.
123-
124- Sorry for the churn!
125
126* Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
127- New since 1.9.0:
128-
129-        Nothing.
130-
131- Bugs fixed since 1.9.0
132-
133-        The dns.dnssec module didn't work with DSA due to namespace
134-        contamination from a "from"-style import.
135-
136- New since 1.8.0:
137-
138-        dnspython now uses poll() instead of select() when available.
139-
140-        Basic DNSSEC validation can be done using dns.dnsec.validate()
141-        and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
142-        later installed.  Complete secure resolution is not yet
143-        available.
144-
145-        Added key_id() to the DNSSEC module, which computes the DNSSEC
146-        key id of a DNSKEY rdata.
147-
148-        Added make_ds() to the DNSSEC module, which returns the DS RR
149-        for a given DNSKEY rdata.
150-
151-        dnspython now raises an exception if HMAC-SHA284 or
152-        HMAC-SHA512 are used with a Python older than 2.5.2.  (Older
153-        Pythons do not compute the correct value.)
154-
155-        Symbolic constants are now available for TSIG algorithm names.
156-
157- Bugs fixed since 1.8.0
158-
159-        dns.resolver.zone_for_name() didn't handle a query response
160-        with a CNAME or DNAME correctly in some cases.
161-
162-        When specifying rdata types and classes as text, Unicode
163-        strings may now be used.
164-
165-        Hashlib compatibility issues have been fixed.
166-
167-        dns.message now imports dns.edns.
168-
169-        The TSIG algorithm value was passed incorrectly to use_tsig()
170-        in some cases.
171
172* Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
173- Add a patch from upstream to fix a Python 2.7 issue.
174
175* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
176- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
177
178* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
179- Fix error
180
181* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
182- New since 1.7.1:
183-
184-  Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
185-  hmac-sha512 has been contributed by Kevin Chen.
186-
187-  The tokenizer's tokens are now Token objects instead of (type,
188-  value) tuples.
189-
190- Bugs fixed since 1.7.1:
191-
192-  Escapes in masterfiles now work correctly.  Previously they were
193-  only working correctly when the text involved was part of a domain
194-  name.
195-
196-  When constructing a DDNS update, if the present() method was used
197-  with a single rdata, a zero TTL was not added.
198-
199-  The entropy pool needed locking to be thread safe.
200-
201-  The entropy pool's reading of /dev/random could cause dnspython to
202-  block.
203-
204-  The entropy pool did buffered reads, potentially consuming more
205-  randomness than we needed.
206-
207-  The entropy pool did not seed with high quality randomness on
208-  Windows.
209-
210-  SRV records were compared incorrectly.
211-
212-  In the e164 query function, the resolver parameter was not used.
213
214* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
216
217* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
218- New since 1.7.0:
219-
220-        Nothing
221-
222- Bugs fixed since 1.7.0:
223-
224-        The 1.7.0 kitting process inadventently omitted the code for the
225-        DLV RR.
226-
227-        Negative DDNS prerequisites are now handled correctly.
228
229* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
230- New since 1.6.0:
231-
232-        Rdatas now have a to_digestable() method, which returns the
233-        DNSSEC canonical form of the rdata, suitable for use in
234-        signature computations.
235-
236-        The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
237-
238-        An entropy module has been added and is used to randomize query ids.
239-
240-        EDNS0 options are now supported.
241-
242-        UDP IXFR is now supported.
243-
244-        The wire format parser now has a 'one_rr_per_rrset' mode, which
245-        suppresses the usual coalescing of all RRs of a given type into a
246-        single RRset.
247-
248-        Various helpful DNSSEC-related constants are now defined.
249-
250-        The resolver's query() method now has an optional 'source' parameter,
251-        allowing the source IP address to be specified.
252-
253- Bugs fixed since 1.6.0:
254-
255-        On Windows, the resolver set the domain incorrectly.
256-
257-        DS RR parsing only allowed one Base64 chunk.
258-
259-        TSIG validation didn't always use absolute names.
260-
261-        NSEC.to_text() only printed the last window.
262-
263-        We did not canonicalize IPv6 addresses before comparing them; we
264-        would thus treat equivalent but different textual forms, e.g.
265-        "1:00::1" and "1::1" as being non-equivalent.
266-
267-        If the peer set a TSIG error, we didn't raise an exception.
268-
269-        Some EDNS bugs in the message code have been fixed (see the ChangeLog
270-        for details).
271
272* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
273- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
274
275* Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
276- Rebuild for Python 2.6
277
278* Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
279- fix license tag
280
281* Tue Dec  4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
282- Update to 1.6.0
283
284* Tue Oct  9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
285- Follow new Python egg packaging specs
286
287* Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
288- Update to 1.5.0
289
290* Fri Dec  8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
291- Bump release for rebuild with Python 2.5
292
293* Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
294- No longer ghost *.pyo files, thus further simplifying the files section.
295
296* Sat Aug  5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
297- Update to 1.4.0
298- Remove unneeded python-abi requires
299- Remove unneeded python_sitearch macro
300
301* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
302- First version for Fedora Extras
303
Note: See TracBrowser for help on using the repository browser.